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Chapter 1
About ClearPass 6.6.4

ClearPass 6.6.4 is a cumulative patch release that introduces new features and provides fixes to previously
outstanding issues. An HTML version of these Release Notes is also available.

These release notes contain the following chapters:

l "System Requirements for ClearPass 6.6" on page 11—Provides important system requirements
information for this release.

l "Upgrade and Update Information " on page 23—Provides considerations and instructions for version
upgrades and patch updates.

l "What’s New in This Release" on page 29—Describes new features and issues introduced in this 6.6.4
release as well as issues fixed in this 6.6.4 release.

l "Change of Behaviors in Previous 6.6.x Releases" on page 39—Provides a summary of behavior and
resource changes introduced in earlier 6.6 releases.

l "Enhancements in Previous 6.6.x Releases" on page 43—Describes new features introduced in earlier 6.6
releases.

l "Issues Fixed in Previous 6.6.x Releases" on page 69—Lists issues fixed in earlier 6.6 releases.

l "Known Issues Identified in Previous Releases" on page 89—Lists currently existing issues identified in
previous releases.

Related Documents
The following documents are part of the complete documentation set for the ClearPass 6.6 platform:

l ClearPass Policy Manager 6.6 User Guide

l ClearPass Guest 6.6 User Guide

l ClearPass Policy Manager 6.6 Getting Started Guide

l ClearPass 6.6 Deployment Guide

l Tech Note: Installing or Upgrading to 6.6 on a Virtual Appliance

l Tech Note: Upgrading to ClearPass 6.6

Use of Cookies
Cookies are small text files that are placed on a user’s computer by Web sites the user visits. They are widely
used in order to make Web sites work, or work more efficiently, as well as to provide information to the owners
of a site. Session cookies are temporary cookies that last only for the duration of one user session.

When a user registers or logs in via an Aruba captive portal, Aruba uses session cookies solely to remember
between clicks who a guest or operator is. Aruba uses this information in a way that does not identify any user-
specific information, and does not make any attempt to find out the identities of those using its ClearPass
products. Aruba does not associate any data gathered by the cookie with any personally identifiable
information (PII) from any source. Aruba uses session cookies only during the user’s active session and does

http://www.arubanetworks.com/techdocs/ClearPass/CP_ReleaseNotes_6.6.4/Default.htm
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not store any permanent cookies on a user’s computer. Session cookies are deleted when the user closes his or
her Web browser.

Contacting Support

Main Site arubanetworks.com

Support Site support.arubanetworks.com

Airheads Social Forums and
Knowledge Base

community.arubanetworks.com

North American Telephone 1-800-943-4526 (Toll Free)
1-408-754-1200

International Telephones arubanetworks.com/support-services/contact-support/

Software Licensing Site hpe.com/networking/support

End-of-Life Information arubanetworks.com/support-services/end-of-life/

Security Incident
Response Team

Site: arubanetworks.com/support-services/security-bulletins
Email: sirt@arubanetworks.com

http://www.arubanetworks.com/
https://support.arubanetworks.com/
http://community.arubaanetworks.com/
http://www.arubanetworks.com/support-services/contact-support/
https://hpe.com/networking/support
http://www.arubanetworks.com/support-services/end-of-life/
http://www.arubanetworks.com/support-services/security-bulletins
mailto:sirt@arubanetworks.com
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Chapter 2
System Requirements for ClearPass 6.6

This chapter provides important system requirements information specific to this release. It should be read
carefully before upgrading to ClearPass 6.6.

This chapter provides the following information:

l "End of Support" on page 11

l "Virtual Appliance Requirements" on page 12

l "Supported Browsers" on page 16

l "ClearPass OnGuard Unified Agent Requirements" on page 16

l "ClearPass Onboard Requirements" on page 21

The IP address to access the licensing server clearpass.arubanetworks.com is 104.36.248.89. If you have any firewall
rules allowing access, please be sure to allow access for this IP address.

End of Support
This section describes ClearPass and third-party systems, software, and features that are no longer supported
or that are approaching their end-of-support date.

ClearPass 6.6 Milestones
l Release Date: April 6th 2016

l End of Development: April 6th 2018

l End of Support: April 6th 2019

For more details on the Aruba End of Life policy, please refer to http://www.arubanetworks.com/support-
services/end-of-life/end-of-life-policy/.

ClearPass 6.6 Deprecated Features
The following features are no longer supported in ClearPass 6.6:

l VMware ESX 4.0.

l OnGuard External Posture Servers: The Configuration > Posture > Posture Servers page and the
Administration > Dictionaries > Posture page have been removed.

ClearPass 6.6 Deprecation Notice
The following features will not be supported after ClearPass 6.6:

l ClearPass 6.6 is the last release that will support Java for the Windows or Mac OS X ClearPass OnGuard
Dissolvable Agent. ClearPass 6.6.5 (cumulative patch 5) will contain the last updates to the Java-based
Dissolvable Agent. No further updates will be provided.

l ClearPass 6.6 significantly builds on the unified REST API framework introduced in ClearPass 6.5. All future
R&D will focus on this framework. Accordingly, this is the last release that will support the TipsAPI (XML),
Guest SOAP APIs, and Guest XML-RPC APIs listed below. ClearPass 6.6 now includes a variety of RESTful

http://www.arubanetworks.com/support-services/end-of-life/end-of-life-policy/
http://www.arubanetworks.com/support-services/end-of-life/end-of-life-policy/
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APIs to replace these legacy APIs, and we will build on these to enable a wider variety of use cases.
Customers are encouraged to migrate any planned or existing applications to interface with the new API
framework. We will not provide any further bug fixes or feature enhancements related to supporting the
following legacy APIs, and future versions of ClearPass may remove these APIs completely, so we
recommend that you migrate to the appropriate RESTful API as soon as possible:

n GuestUser TipsAPI is replaced by GuestManager RESTful APIs

n OnboardDevice TipsAPI is replaced by Onboard RESTful API

n Guest SOAP APIs are replaced by the GuestManager, Onboard, OperatorLogins, and SmsServices
RESTful APIs

n Guest XML-RPC APIs are replaced by the GuestManager, Onboard, OperatorLogins, and
SmsServices RESTful APIs

For more details on the RESTful interface, please go to https://<ClearPass-Server-IP-or-FQDN>/api-docs
(requires login) on any ClearPass appliance.

l ClearPass 6.6 is the last major release that will support the following products, as they are no longer
supported by their vendors:

n VMware ESX 5.1 and earlier.

n Mac OS X 10.7 (Lion) — October 2014

n Mac OS X 10.8 (Mountain Lion) — September 2015

n Mac OS X 10.9 (Mavericks) — September 2016

Third-Party Vendor End-of-Support
Please be aware that the following vendors have officially stopped supporting their respective operating
systems on the stated dates.

Aruba will attempt to preserve compatibility with these legacy operating systems; however, recent versions of
software agents (such as the ClearPass OnGuard Unified Agent) might not be able to provide the same level of
functionality that they provide on newer operating systems.

We will not provide any further bug fixes or feature enhancements related to supporting these operating
systems. Our TAC organization will also not be able to service customer support requests related to clients
running these operating systems. Customers should consider these operating systems as unsupported with
ClearPass:

l Microsoft Corporation:

n Windows Server 2003 — July 14, 2015

n Windows XP — April 8, 2014

l Apple, Inc:

n Mac OS X 10.6 (Snow Leopard) — February 26, 2014

Virtual Appliance Requirements
Please carefully review all virtual appliance (VA) requirements, including functional IOP ratings, and verify that
your system meets these requirements. These requirements supersede earlier requirements that were
published for ClearPass 6.x installations.



Virtual appliance requirements are adjusted to align with the shipping ClearPass hardware appliance
specifications. If you do not have the VA resources to support a full workload, then you should consider
ordering a ClearPass hardware appliance.

This section includes the following:

l "Supported Hypervisors" on page 13

l "VMware vSphere Hypervisor (ESXi) Requirements " on page 13

l "Hyper-V Requirements " on page 14

l "KVM Requirements" on page 15

For complete information on installing, configuring, or morphing an ESXi™, Hyper-V®, or KVM hypervisor, see
the Tech Note: Installing or Upgrading to 6.6 on a Virtual Appliance.

Supported Hypervisors
The following hypervisors are supported. Hypervisors that run on a client computer such as VMware Player are
not supported.

l VMware vSphere Hypervisor (ESXi) 5.5. 6.0, or 6.5

l Microsoft Hyper-V Server 2012 R2, Microsoft Hyper-V Server 2016, Windows Server 2012 R2 with Hyper-V,
or Windows Server 2016 with Hyper-V

l KVM on CentOS 6.6, 6.7, or 6.8.

VMware vSphere Hypervisor (ESXi) Requirements

CP-SW-EVAL (Evaluation OVF)
l 2 Virtual CPUs

l 4 GB RAM

l 80 GB disk space

CP-VA-500 (500 Virtual Appliance OVF)
l 8 Virtual CPUs

n Underlying CPU is recommended to have a PassMark® of 3000 or higher

l 8 GB RAM

l Disk space:

n 500 GB disk space required for existing deployments (upgrading from 6.3.6, 6.4.7, or 6.5.x)

n 1000 GB disk space recommended for new deployments

l 2 Gigabit virtual switched ports

l Functional IOP rating for a 40-60 read/write profile for 4K random read/write = 75

CP-VA-5K (5K Virtual Appliance OVF)
l 8 Virtual CPUs

n Underlying CPU is recommended to have a PassMark® of 9600 or higher

l 8 GB RAM

l Disk space:

ClearPass 6.6.4 | Release Notes System Requirements for ClearPass 6.6 | 13
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n 500 GB disk space required for existing deployments (upgrading from 6.3.6, 6.4.7, or 6.5.x)

n 1000 GB disk space recommended for new deployments

l 2 Gigabit virtual switched ports

l Functional IOP rating for a 40-60 read/write profile for 4K random read/write = 105

CP-VA-25K (25K Virtual Appliance OVF)
l 24 Virtual CPUs

n Underlying CPUs are recommended to have a PassMark® of 9900 or higher

l 64 GB RAM

l Disk space:

n 1000 GB disk space required for existing deployments (upgrading from 6.3.6, 6.4.7, or 6.5.x)

n 1800 GB disk space recommended for new deployments

l 2 Gigabit virtual switched ports

l Functional IOP rating for a 40-60 read/write profile for 4K random read/write = 350

Hyper-V Requirements

CP-SW-EVAL (Evaluation VHDX)
l 2 Virtual CPUs

l 4 GB RAM

l 80 GB disk space

CP-VA-500 (500 Virtual Appliance VHDX)
l 8 Virtual CPUs

n Underlying CPU is recommended to have a PassMark® of 3000 or higher

l 8 GB RAM

l Disk space:

n 500 GB disk space required for existing deployments (upgrading from 6.5.x)

n 1000 GB disk space recommended for new deployments

l 2 Gigabit virtual switched ports

l Functional IOP rating for a 40-60 read/write profile for 4K random read/write = 75

CP-VA-5K (5K Virtual Appliance VHDX)
l 8 Virtual CPUs

n Underlying is recommended to have a PassMark® of 9600 or higher

l 8 GB RAM

l Disk space:

n 1000 GB disk

l 2 Gigabit virtual switched ports

l Functional IOP rating for a 40-60 read/write profile for 4K random read/write = 105

https://www.cpubenchmark.net/
https://www.cpubenchmark.net/
https://www.cpubenchmark.net/


CP-VA-25K (25K Virtual Appliance VHDX)
l 24 Virtual CPUs

n Underlying CPUs are recommended to have a PassMark® of 9900 or higher

l 64 GB RAM

l Disk space:

n 1800 GB disk

l 2 Gigabit virtual switched ports

l Functional IOP rating for a 40-60 read/write profile for 4K random read/write = 350

KVM Requirements

CP-SW-EVAL (Evaluation RAW Disk Image)
l 2 Virtual CPUs

l 4 GB RAM

l 80 GB disk space

l 2 Gigabit virtual switched ports

CP-VA-500 (500 Virtual Appliance RAW Disk Image)
l 8 Virtual CPUs

n Underlying CPU is recommended to have a PassMark® of 3000 or higher

l 8 GB RAM

l 1000 GB disk space

l 2 Gigabit virtual switched ports

l Functional IOP rating for a 40-60 read/write profile for 4K random read/write = 75

CP-VA-5K (5K Virtual Appliance RAW Disk Image)
l 8 Virtual CPUs

n Underlying is recommended to have a PassMark® of 9600 or higher

l 8 GB RAM

l 1000 GB disk space

l 2 Gigabit virtual switched ports

l Functional IOP rating for a 40-60 read/write profile for 4K random read/write = 105

CP-VA-25K (25K Virtual Appliance RAW Disk Image)
l 24 Virtual CPUs

n Underlying CPUs are recommended to have a PassMark® of 9900 or higher

l 64 GB RAM

l 1800 GB disk space

l 2 Gigabit virtual switched ports

l Functional IOP rating for a 40-60 read/write profile for 4K random read/write = 350

ClearPass 6.6.4 | Release Notes System Requirements for ClearPass 6.6 | 15
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Supported Browsers
For the best user experience, we recommend you update your browser to the latest version available.
Supported browsers for ClearPass are:

l Mozilla Firefox on Windows Vista, Windows 7, Windows 8.x, Windows 10, and Mac OS X.

l Google Chrome for Mac OS X and Windows.

l Apple Safari 3.x and later on Mac OS X.

l Mobile Safari 5.x on iOS.

l Microsoft Internet Explorer 10 and later on Windows 7 and Windows 8.x. When accessing ClearPass Insight
with Internet Explorer (IE), IE 11 or above is required.

l Microsoft Edge on Windows 10.

Users should be aware that the ClearPass OnGuard Dissolvable Agent flow might not work on the Mac OS X 10.6,
10.7, or 10.8 operating systems because Mozilla no longer supports Firefox on these platforms.

The Google Chrome browser no longer supports the Windows XP, Windows Vista, or Mac OS X 10.6, 10.7, or 10.8
operating systems. Chrome will still work on these platforms but will not receive updates or security fixes after April
2016.

ClearPass OnGuard Unified Agent Requirements
Be sure that your client system meets the following requirements before installing the ClearPass OnGuard
Unified Agent:

l 1 GB RAM recommended, 512 MB RAM minimum

l 300 MB Disk Space

l Mac OS X 10.7 - 10.11, MacOS 10.12

l Ubuntu: 12.04 LTS and 14.04 LTS

Windows Vista, Windows 7, Windows 8.x Pro, Windows 10, Windows Server 2008, and Windows Server 2012
are all supported with no service pack requirements. OnGuard does not support Windows 8.x RT or Windows
8.x Phone.

Installing the Unified Agent will remove an existing VIA installation. To continue using VPN functionality, log in to
ClearPass as the administrator, go to Administration > Agents and Software Updates > OnGuard Settings, and
select Install and enable Aruba VPN component from the Installer Mode drop-down list.

OnGuard Supported Antivirus Versions
For OnGuard to work properly, please whitelist the following executable files and installation folders in your antivirus
products:
ClearPassOnGuard.exe
ClearPassAgentController.exe
ClearPassOnGuardAgentService.exe
C:\Program Files (x86)\Aruba Networks\ClearPassOnGuard\
C:\Program Files\Aruba Networks\ClearPassOnGuard\



In current laboratory tests for ClearPass 6.6.4, we use the following antivirus software for our validations. Due
to the large number of products available, this list may change at any time:

l Avast (latest version)

l AVG (latest version)

l COMODO

l Kaspersky: IS-11 and above

l McAfee

l Microsoft Forefront Endpoint Protection-2008

l Microsoft Security Essentials

l Microsoft Windows Firewall

l Trend Micro

l Windows Defender Firewall

Some third-party anti-malware products are not supported by ClearPass OnGuard. For a complete list of supported
third-party products, in Policy Manager go to Administration > Support > Documentation, and then click the
OnGuard Agent Support Charts link.

OnGuard Dissolvable Agent Requirements
This section provides version information for both the Native Dissolvable Agent and the Java-based Dissolvable
Agent. For more information on the Dissolvable Agent, refer to the ClearPass Policy Manager online help.

Users should be aware that the Dissolvable Agent flow might not work on the Mac OS X 10.6, 10.7, or 10.8 operating
systems because Mozilla no longer supports Firefox on these platforms. (#37967)

The Google Chrome browser stopped supporting updates on the Windows XP, Windows Vista, and Mac OS X 10.6,
10.7, or 10.8 operating systems. Chrome will still work on these platforms but will not receive updates or security
fixes after April 2016. The ClearPass OnGuard Dissolvable Agent on these platforms using Chrome is only supported
through Chrome version 48.x. (#34744)

This section includes the following:

l "OnGuard Native Dissolvable Agent Version Information " on page 17

l "OnGuard Java-Based Agent Version Information" on page 20

OnGuard Native Dissolvable Agent Version Information

In current laboratory tests for ClearPass 6.6.4, the browser versions shown in Table 1 were verified for the
ClearPass OnGuard Native Dissolvable Agents. There are considerations to be aware of with some browser
versions. For more information, click the issue ID number next to the browser’s name.

The Native Dissolvable Agent is not currently supported with the Microsoft Edge browser. (#32664)

ClearPass 6.6.4 | Release Notes System Requirements for ClearPass 6.6 | 17
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Operating System Browser

Linux - Ubuntu 14.04 64-bit LTS Firefox 48.x

Linux - Ubuntu 14.04 32-bit LTS Firefox 48.x

Linux - Ubuntu 12.04 64-bit LTS Firefox 48.x

Linux - Ubuntu 12.04 32-bit LTS Firefox 48.x

MacOS 10.12 Safari 10.x

Firefox 51.x (#29609, #38403)

Chrome 56.x (#24518, #24986)

Mac OS X 10.11 Safari 9.x

Firefox 51.x (#29609)

Chrome 55.x (#24518, #24986)

Mac OS X 10.10 Safari 8.x

Firefox 51.x (#29609, #38403)

Chrome 56.x (#24518, #24986)

Mac OS X 10.9 Safari 9.x

Firefox 51.x (#28398, #29609)

Chrome 56.x (#24518, #24986)

Mac OS X 10.8 Safari 5.x (#28398)

Firefox 48.x

Chrome 49.x (#24986)

Mac OS X 10.7 Safari 5.x (#28398)

Firefox 47.x

Chrome 49.x (#24986)

Windows 10 64-bit Chrome 56.x (#24518, #24986)

Firefox 51.x (#36334)

Internet Explorer 11.x

Windows 10 32-bit Chrome 56.x (#24518, #24986)

Firefox 51.x (#36334)

Internet Explorer 11.x (#25827)

Table 1: Native Dissolvable Agent Latest Supported Browser Versions for This Release



Operating System Browser

Windows 8.1 64-bit Chrome 56.x (#24986)

Firefox 51.x (#36334)

Internet Explorer 11.x

Windows 8.1 32-bit Chrome 56.x

Firefox 51.x (#36334)

Internet Explorer 11.x

Windows 8 64-bit Chrome 56.x (#24986)

Firefox 51.x (#36334)

Internet Explorer 10.x

Windows 8 32-bit Chrome 56.x (#24986)

Firefox 51.x (#36334)

Internet Explorer 10.x

Windows 7 64-bit Chrome 56.x (#24518, #24986)

Firefox 51.x (#36334)

Internet Explorer 11.x (#25827)

Windows 7 32-bit Chrome 56.x (#24518, #24986)

Firefox 51.x (#36334)

Internet Explorer 11.x

Windows 2008 64-bit Chrome 49.x (#24986)

Firefox 51.x (#36334)

Internet Explorer 8.x (#24766)

Windows Server 2012 R2 64-bit Chrome 56.x (#24986)

Firefox 51.x (#37939)

Internet Explorer 11.x

Windows Server 2012 64-bit Chrome 56.x (#24986)

Firefox 51.x (#37939)

Internet Explorer 10.x

Windows Vista Chrome 49.x (#24986)

Table 1: Native Dissolvable Agent Latest Supported Browser Versions for This Release (Continued)

ClearPass 6.6.4 | Release Notes System Requirements for ClearPass 6.6 | 19
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Operating System Browser

Firefox 51.x (#29186)

Internet Explorer 9.x (#29186)

Table 1: Native Dissolvable Agent Latest Supported Browser Versions for This Release (Continued)

OnGuard Java-Based Agent Version Information
In current laboratory tests for ClearPass 6.6.4, the browser and Java versions shown in Table 2 were verified for
the ClearPass OnGuard Java-based dissolvable agents. There are considerations to be aware of with some
browser versions. For information, click the issue ID number next to the browser’s name.

The latest Java version is required in order to perform client health checks.

Operating System Browser Java Version

Linux - CentOS Firefox 38.0.1 JRE 1.8 Update 121

Linux - RedHat Firefox 17.0.10 JRE 1.8 Update 121

Linux - SUSE Firefox 31.1.0 JRE 1.8 Update 121

Linux - Ubuntu Firefox 50.0.2 JRE 1.8 Update 121

MacOS 10.12 Firefox 51.x (#27871 ) JRE 1.8 Update 121

Mac OS X 10.11 Safari 9.x (#20191) JRE 1.8 Update 121

Firefox 51.x (#27871) JRE 1.8 Update 121

Mac OS X 10.10 Safari 8.x (#20191) JRE 1.8 Update 121

Firefox 51.x (#27871) JRE 1.8 Update 121

Mac OS X 10.9.5 Safari 9.x (#20191) JRE 1.8 Update 121

Firefox 51.x JRE 1.8 Update 121

Mac OS X 10.8 Safari 6.x (#20191) JRE 1.8 Update 121

Firefox 46.x JRE 1.8 Update 121

Windows 10 64-bit Internet Explorer 11.x (#7165) JRE 1.8 Update 121

Windows 10 32-bit Internet Explorer 11.x (#7165) JRE 1.8 Update 121

Windows 8.1 64-bit Internet Explorer 11.x JRE 1.8 Update 121

Windows 8.1 32-bit Internet Explorer 11.x JRE 1.8 Update 121

Windows 8 64-bit Internet Explorer 10.x (#7165) JRE 1.8 Update 121

Windows 8 32-bit Internet Explorer 10.x JRE 1.8 Update 121

Windows 7 64-bit Internet Explorer 11.x JRE 1.8 Update 121

Table 2: Supported Browser and Java Versions for This Release



Operating System Browser Java Version

Windows 7 32-bit Internet Explorer 11.x JRE 1.8 Update 121

Windows 2008 64-bit Internet Explorer 8.x (#7165) JRE 1.8 Update 121

Windows Server 2012 R2
64-bit

Internet Explorer 11.x (#7165) JRE 1.8 Update 121

Windows Server 2012 64-
bit

Internet Explorer 10.x (#7165) JRE 1.8 Update 121

Windows Vista Internet Explorer 9.x (#7165) JRE 1.8 Update 121

Table 2: Supported Browser and Java Versions for This Release (Continued)

ClearPass Onboard Requirements
Onboard does not support Windows 8.x RT or Windows 8.x Phone.
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Chapter 3
Upgrade and Update Information

This chapter provides instructions for upgrading or updating your ClearPass appliance:.

l The term “upgrade” refers to moving from one major release version to another—for example, from 6.5.x
to 6.6.0.

n To upgrade a cluster to 6.6.0, we recommend using the Cluster Upgrade interface. For more
information, see the Cluster Upgrade and Cluster Update Tools section in the ClearPass Policy Manager
User Guide. For information about known issues with cluster upgrades, please refer to the “Cluster
Upgrade and Update” sections in these Release Notes.

l The term “update” refers to applying a patch release within the same major version—for example, from
6.6.3 to 6.6.4.

n To update a cluster to 6.6.4, we recommend using the Cluster Update interface. For more information,
see the Cluster Upgrade and Cluster Update Tools section in the ClearPass Policy Manager User Guide.
For information about known issues with cluster updates, please refer to the “Cluster Upgrade and
Update” sections in these Release Notes.

This chapter includes the following sections:

l "Upgrading to ClearPass 6.6 from 6.3.6, 6.4.7, or 6.5.x" on page 23

l "Updating Within the Same Major Version" on page 26

Upgrading to ClearPass 6.6 from 6.3.6, 6.4.7, or 6.5.x
An upgrade is the process of moving from one major release version to another—for example, from 6.5.x to
6.6.0. This section describes accessing upgrade images, considerations to be aware of, and instructions for
restoring the log database after the upgrade (optional).

You can upgrade to ClearPass 6.6.0 from ClearPass 6.3.6, 6.4.7, or 6.5.x. Before you proceed with the
upgrade, we recommend that you apply the latest available patch updates to your current release. For
information on the patch update procedure, see "Updating Within the Same Major Version" on page 26.

l For 6.5.x upgrades, versions 6.5.0 (FIPS/Non-FIPS) and 6.5.1 (FIPS only) require applying the ClearPass
6.6.0 Upgrade Preparation Patch before upgrading to 6.6.0 if the upgrade image needs to be manually
imported into the UI or installed through the CLI. This patch is available through the Aruba Support site or
through the Software Updates portal. Version 6.5.2 and later do not require the preparation patch.

l For 6.4.x upgrades, you must update to 6.4.7 followed by applying the ClearPass 6.6.0 Upgrade
Preparation Patch before upgrading to 6.6.0 if the upgrade image needs to be manually imported into
the UI or installed through the CLI. This patch is available through the Aruba Support site or through the
Software Updates portal.

l For 6.3.x upgrades, you must update to 6.3.6 followed by applying the ClearPass 6.6.0 Upgrade
Preparation Patch before upgrading to 6.6.0 if the upgrade image needs to be manually imported into
the UI or installed through the CLI. This patch is available through the Aruba Support site or through the
Software Updates portal.

l For 6.1.x and 6.2.x, direct upgrades are not supported. Customers on 6.1.x or 6.2.x must intermediately
upgrade to 6.3.6, 6.4.7, or 6.5.x first before upgrading to 6.6.0.

l For appliance upgrades from 5.2.0, you must upgrade to 6.3.6, 6.4.7, or 6.5.x before upgrading to 6.6.0.

http://www.arubanetworks.com/techdocs/ClearPass/6.6/PolicyManager/index.htm#CPPM_UserGuide/Cluster Upgrade/upgrade.htm
http://www.arubanetworks.com/techdocs/ClearPass/6.6/PolicyManager/index.htm#CPPM_UserGuide/Cluster Upgrade/upgrade.htm
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l Upgrade images are available within ClearPass Policy Manager from the Software Updates portal at
Administration > Agents and Software Updates > Software Updates.

l Upgrade images and preparation patches are also available for download on the Support site under
ClearPass > Policy Manager.

Before You Upgrade
Before you begin the upgrade process, please review the following important items:

l Plan downtime accordingly. Upgrades can take longer (several hours) depending on the size of your
configuration database. A large number of audit records (hundreds of thousands) due to Mobile Device
Management (MDM) integration can significantly increase upgrade times. Refer to the sample times shown
in Sample Times Required for Upgrade in "Sample Times Required for Upgrade" on page 25.

l Review the hypervisor disk requirements. These are described in "Virtual Appliance Requirements" on page
12 of the “System Requirements for ClearPass 6.6” chapter.

l Any log settings that were modified prior to the upgrade are not retained, and are reset to the default. The
administrator should configure any custom log settings again after the upgrade.

Log Database and Access Tracker records are not restored as part of the upgrade. If required, you can manually
restore them after the upgrade. For more information, please review "After You Upgrade " on page 25.

l Before initiating the Upgrade process in ClearPass, we recommend you set the Auto Backup
Configuration Options to Off (if it was set to other values such as Config or Config|Session). The reason
for disabling this setting is to avoid interference between the Auto Backup process and the Migration
process.

To change this setting:

Navigate to Administration > Cluster Wide Parameters > General > Auto Backup Configuration
Options = Off.

l If you have a custom authentication source configured to use the session log database, additional steps are
required after upgrade. You have such an authentication source configured if you have a source of type
Generic SQL DB in ClearPass Policy Manager > Configuration > Sources with server name localhost
or 127.0.0.1 and with the database name tipsLogDb. In such cases, manually restoring the session log
database is required after the upgrade completes (see "After You Upgrade " on page 25). Please contact
Customer Support for configuration recommendations to move away from using the session log database
as an authentication source.

l MySQL is supported in ClearPass 6.x and greater. Aruba does not ship drivers for MySQL by default.
Customers who require MySQL can download it from the Support site
(http://support.arubanetworks.com). Users should be aware that this patch does not persist across
upgrades.

l VM only: If you have two disks already loaded with previous ClearPass versions—for example, 6.2 on SCSI
0:1 and 6.3 on SCSI 0:2—then drop the inactive disk before upgrading. You must then add a newer disk
based on the 6.6.0 disk requirements. Earlier releases used separate disks to store the current and previous
ClearPass release; newer releases use just a single drive to store both installations. For current
requirements, see "Virtual Appliance Requirements" on page 12.

Never remove SCSI 0:0

http://support.arubanetworks.com/


Sample Times Required for Upgrade

To help you estimate how much time the upgrade might take, Table 1 shows representative numbers for
upgrade times under test conditions. Remember that the figures here are only examples. The actual time
required for your upgrade depends on several factors:

l Your hardware or virtual appliance model. In the case of VM installations, upgrade times vary significantly
based on the IOPS performance of your VM infrastructure.

l The size of the configuration database to be migrated.

l For Insight nodes, the size of the Insight database.

l For subscriber nodes, the bandwidth and latency of the network link between the subscriber and the
publisher.

Hardware
Model

Config
DB Size

Insight
DB Size

Publisher
Upgrade
Time

Subscriber
Upgrade Time

Insight Restoration Time in
Publisher OR Subscriber

CP-500 100 MB 5 GB 50 minutes 50 minutes 20 minutes

200 MB 5 GB 60 minutes 60 minutes 20 minutes

CP-5K 100 MB 5 GB 50 minutes 50 minutes 15 minutes

200 MB 5 GB 60 minutes 60 minutes 15 minutes

CP-25K 200 MB 5 GB 30 minutes 30 minutes 15 minutes

500 MB 10 GB 40 minutes 40 minutes 20 minutes

Table 3: Sample Times Required for Upgrade

After You Upgrade
To reduce downtime, the default upgrade behavior will back up Log Database and Access Tracker records but
will not restore them as part of the upgrade. If required, you can manually restore them after the upgrade
through either the application or the CLI. The session log database contains:

l Access Tracker and Accounting records

l Event Viewer

l ClearPass Guest Application Log

The Insight database is not part of the session log database, and will be migrated as part of the upgrade.

Restoring the Log DB Through the User Interface

To restore the Log DB after upgrade through the UI, restore from the auto-generated upgrade-backup.tar.gz
file (available at Administration > Server Manager > Local Shared Folders).

The restoration process could take several hours, depending on the size of your session log database. All
services are accessible and will handle requests during the restoration, but there will be a performance impact
while the restoration is in progress. We recommend that you perform this operation during a planned change
window.
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The restoration process will continue in the background even if the UI is closed or the session times out. A
“Restore complete” event is logged in the Event Viewer when the restoration is complete.

This process needs to be repeated on each server in the cluster that should retain the session log database.

1. Go to Administration > Server Manager > Server Configuration and click Restore for the server.

2. In the Restore Policy Manager Database window, select the File is on server option, and select the
upgrade-backup.tar.gz file.

3. Also select the following options:

l Restore CPPM session log data (if it exists on the backup)

l Ignore version mismatch and attempt data migration

l Do not back up the existing databases before this operation

4. Uncheck the Restore CPPM configuration data option.

5. Click Start.

Restoring the Log DB Through the CLI

To restore the Log Database after the upgrade process is complete, use the restore command. Go to
Administration > Server Manager > Local Shared Folders and download the upgrade-backup.tar.gz
file. Host the file at an scp or http location accessible from the ClearPass appliance and execute the command
restore <location/upgrade-backup.tar.gz> -l –i –b.

The restoration process could take several hours depending on the size of your session log database. All
services are accessible and handling requests during the restoration, but there will be a performance impact
while the restoration is in progress. We recommend that you perform this operation during a planned change
window.

The restoration process will abort if the CLI session is closed or times out. We recommend that you initiate the
restoration from the User Interface, especially if you have a large number of Access Tracker and Accounting records.

This process needs to be repeated on each server in the cluster that should retain the session log database.

The restore command syntax is as follows:
Usage:

restore user@hostname:/<backup-filename> [-l] [-i] [-b] [-c] [-r] [-n|-N] [-s]

restore http://hostname/<backup-filename>[-l] [-i] [-b] [-c] [-e] [-n|-N] [-s]

restore <backup-filename> [-l] [-i] [-b] [-c] [-r] [-n|-N] [-s]

-b -- do not backup current config before restore

-c -- restore CPPM configuration data

-l -- restore CPPM session log data as well if it exists in the backup

-r -- restore Insight data as well if it exists in the backup

-i -- ignore version mismatch and attempt data migration

-n -- retain local node config like certificates etc. after restore (default)

-N -- do not retain local node config after restore

-s -- restore cluster server/node entries from backup.

The node entries will be in disabled state on restore

Updating Within the Same Major Version
An update is the process of applying a minor patch release within the same major version—for example, from
6.6.3 to 6.6.4. Updates are available from the Software Updates portal in ClearPass Policy Manager. This



section describes how to install a patch update either through the Software Updates portal, as an offline
update, or through the Cluster Update interface.

During an update, the log database is retained. No extra steps are needed to retain the session log history
during an update.

This section includes the following:

l "Installation Instructions Through the Software Updates Portal" on page 27

l "Installation Instructions for an Offline Update" on page 27

l "Installation Instructions Through the Cluster Update Interface" on page 28

Installation Instructions Through the Software Updates Portal

This method may still be used to manually update appliances in a cluster, beginning with the publisher and then each
subscriber; however, we recommend using the Cluster Update interface going forward to automate the process.

If access is allowed to clearpass.arubanetworks.com, ClearPass appliances will show the latest patches on the
Software Updates portal:

1. In ClearPass Policy Manager, go to Administration > Agents and Software Updates > Software
Updates.

2. In the Firmware and Patch Updates area, find the latest patch and click the Download button in its row.

3. After the patch is downloaded, click Install.

4. When the installation is complete, if the status on the Software Updates portal is shown as Needs
Restart, click the Reboot button to restart ClearPass. After the restart, the status for the patch is shown as
Installed.

Installation Instructions for an Offline Update
If you do not have access to clearpass.arubanetworks.com and you need to do an offline update, you may
download the signed patch from the Support site, upload it to the ClearPass appliance, and then install it
through the user interface:

1. Download the appropriate patch update from the Support site (http://support.arubanetworks.com).

2. Open ClearPass Policy Manager and go to Administration > Agents and Software Updates > Software
Updates.

3. At the bottom of the Firmware and Patch Updates area, click Import Updates.

4. Browse to the downloaded patch file and then click Import.

5. When the import is complete, click Install.

6. When the installation is complete, if the status on the Software Updates portal is shown as Needs
Restart, click the Reboot button to restart ClearPass. After the restart, the status for the patch is shown as
Installed.
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Installation Instructions Through the Cluster Update Interface
The Cluster Update interface automates the process of updating a cluster. The publisher is automatically
updated first before any selected subscribers. In large cluster deployments (greater than 6) we recommend
updating the subscribers in batches of no more than five at a time.

Before you begin, if you plan to download the 6.6.3 cumulative patch from the Software Updates portal for
use with the Cluster Update interface on a ClearPass 6.6.0 appliance, you must first install the ClearPass
6.6.0 Cluster Update Interface Patch. This patch is required for ClearPass 6.6.0-based clusters in order to
enable the Cluster Update user interface to recognize ClearPass patches and hotfixes when they have been
downloaded through the Software Updates portal. It only needs to be installed on the publisher. This patch is
NOT needed if the patches or hotfixes are manually imported into the ClearPass appliance.

If you accidentally download the 6.6.3 cumulative patch before installing the ClearPass 6.6.0 Cluster Update
Interface Patch, the Start Update link will be missing from the Cluster Update interface. To resolve this issue,
delete the 6.6.3 cumulative patch, click Check Status Now and then download it again.

To update the cluster:

1. In ClearPass Policy Manager, go to Administration > Support > Agents and Software Updates.

2. Download or import the patch you wish to deploy, and then click the Cluster Update link.

3. In the Update Info area, select the desired patch from the Update Image Name drop-down list.

4. Click the Start Update link. The Start Cluster Update window opens.

5. Select the cluster subscribers to be updated, and then click Update.

For more information about the Cluster Update interface, see the Cluster Upgrade and Cluster Update Tools
section in the ClearPass Policy Manager User Guide. For information about known issues with cluster updates,
please refer to the “Cluster Upgrade and Update” sections in these Release Notes, or contact TAC for technical
assistance.

http://www.arubanetworks.com/techdocs/ClearPass/6.6/PolicyManager/index.htm#CPPM_UserGuide/Cluster Upgrade/upgrade.htm
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Chapter 4
What’s New in This Release

This chapter provides a summary of the new features and changes in the ClearPass 6.6.4 release.

This chapter contains the following sections:

l "Release Overview" on page 29

l "Change of Behaviors in the 6.6.4 Release" on page 29

l "New Features and Enhancements in the 6.6.4 Release" on page 30

l "Issues Resolved in the 6.6.4 Release" on page 32

l "New Known Issues in the 6.6.4 Release" on page 36

Release Overview
ClearPass 6.6.4 is a cumulative patch release that introduces new features and provides fixes for known issues.
The 6.6.4 cumulative patch is available in ClearPass Policy Manager under Administration > Agents and
Software Updates > Software Updates.

Change of Behaviors in the 6.6.4 Release
The following changes to ClearPass behaviors, resources, or support were introduced in the 6.6.4 release. For a
list of behavior changes introduced in previous 6.6.x releases, see the Change of Behaviors in Previous 6.6.x
Releases chapter.

Users should be aware of the following important changes in ClearPass behaviors and resources:

l For deployments that have Palo Alto Networks (PANW) configured as an endpoint, ClearPass now sends the
user’s ClearPass role information to PANW during login. The role is unregistered from PANW when the user
logs out. (#37163, #37204)

l ClearPass now supports Windows Server 2012 and Windows Server 2012 R2 in the ClearPass OnGuard
Unified Agent. (#37121)

l The ClearPass OnGuard Unified Agent and Native Dissolvable Agent for Windows can now be localized in
the French language. (#37506)

l ClearPass now supports Microsoft Hyper-V Server 2016. (#37674)

l ClearPass now supports VMware vSphere Hypervisor (ESXi) 6.5. (#37675)

l ClearPass now supports MAC Notification Traps from HPE ArubaOS-Switches. This automatic notification
can be used to discover new devices connected to an HPE ArubaOS-Switch or to perform an OnConnect
enforcement. (#37180)

l In network discovery, if custom fingerprints are configured, now the custom rules will always be evaluated
before the default rules. (#37545)

l In the ClearPass OnGuard Unified Agent, antivirus detection is now performed every two hours instead of
every minute. (#37630)
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l If MAC authentication is configured against an external MySQL database, parallelism is now enabled on the
MySQL driver, allowing multiple queries to be sent to the MySQL server over multiple connections.
(#35854)

l Non-alphanumeric characters are now accepted at the beginning of passwords. (#37160)

l The underscore character ( _ ) is now supported in hostnames. (#37509)

l Access-requests that contain the following attributes will now be dropped only when ClearPass is in CC
mode: (#37770)

n The response attributes Password-Retry, Reply-message, or Error-Cause.

n Both an EAP-Message and an ARAP-Password, User-Password, or CHAP-Password attribute.

l In network discovery, when endpoints do not have a MAC address, ClearPass will create MAC addresses for
them that include the prefix “xa”. (#37410)

l After running a subnet scan, discovered endpoints that do not have a MAC address will be displayed with a
hyphen in the MAC Address column in the Configuration > Identity > Endpoints list. (#38125)

New Features and Enhancements in the 6.6.4 Release
The following new features were introduced in the ClearPass 6.6.4 release. For a list of features introduced in
previous 6.6.x releases, see "Enhancements in Previous 6.6.x Releases" on page 43.

This section includes:

l "Endpoint Context Servers" on page 30

l "OnGuard" on page 30

l "Policy Manager " on page 31

l "Profiler and Network Discovery" on page 32

Endpoint Context Servers
The following new features are introduced in Endpoint Context Servers in the 6.6.4 release.

l For deployments that have Palo Alto Networks (PANW) configured as an endpoint, ClearPass now sends the
user’s ClearPass role information to PANW during login. The role is unregistered from PANW when the user
logs out. (#37163, #37204)

Users should be aware that this change might cause performance issues for deployments that have PANW
configured as an endpoint. If this is a concern, we recommend that you not apply the 6.6.4 patch and instead wait for
further enhancements in a future patch.

OnGuard
The following new features are introduced in OnGuard in the 6.6.4 release:

l Support was added for the following products: (#36281)

n Avast Pro Antivirus 12.x (Windows)

n Bitdefender Internet Security 21.x (Windows)

n Bitdefender Total Security 21.x (Windows)

n ESET Smart Security 10.x (Windows)

n F-Secure Anti-Virus for Mac 16.x (MacOS)



n McAfee Endpoint Security for Linux Threat Prevention 10.x (Linux)

n SafeGuard 8.x (Windows)

n Trend Micro Internet Security 7.x (MacOS)

n Trend Micro Security for Mac 3.x (MacOS)

n Trend Micro Worry Free Business Security Agent 6.x (Windows)

n VMware Workstation 12.x (Windows)

Support was enhanced for the following products:

n Avast Free Antivirus 12.x (Windows)

n Avast Mac security 12.x (MacOS)

n Avira Free Antivirus 15.x (Windows)

n Bitdefender Antivirus Free Edition 1.x (Windows)

n BitLocker Drive Encryption 6.x (Windows)

n Check Point Endpoint Security Antivirus 8.x (Windows)

n McAfee Endpoint Security Firewall 10.x (Windows)

n Norton AntiVirus 22.x (Windows)

n Norton Security 22.x (Windows)

n System Center Endpoint Protection 4.x (Windows)

n Symantec Endpoint Protection 14.x (Windows)

l ClearPass now supports Windows Server 2012 and Windows Server 2012 R2 in ClearPass OnGuard Agent.
(#37121)

l The ClearPass OnGuard Unified Agent and Native Dissolvable Agent for Windows can now be localized in
the French language. (#37506)

l A new option, Product Evaluation Rule, was added to the Patch Management health class. This option
allows AND/OR conditions between patch management products, enabling ClearPass to set the health
status of the Patch Management health class based on the status of all the configured products. To use this
feature, go to Configuration > Posture > Posture Policies > Posture Plugins > ClearPass Windows
Universal System Health Validator. Enable Patch Management checks for the appropriate operating
system, and configure rules for product evaluation. (#37540)

l The Windows Hotfixes health class now lets you check a group of hotfixes. To use this feature, go to
Configuration > Posture > Posture Policies > Posture Plugins > ClearPass Windows Universal
System Health Validator. Enable Windows Hotfixes checks for the appropriate operating system, and
configure rules for Windows hotfixes groups. The following checks are supported: (#37541)

n All the hotfixes from a group should be present

n Any hotfixes from the group should be present

n All the groups should be Healthy

n Any group should be healthy

Policy Manager
The following new features are introduced in Policy Manager in the 6.6.4 release:

l ClearPass now supports Microsoft Hyper-V Server 2016. (#37674)
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l ClearPass now supports VMware vSphere Hypervisor (ESXi) 6.5. (#37675)

l A new cluster-wide parameter, TACACS Connection Idle Timeout, lets you control connection idle
timeout settings. To use this feature, go to the Administration > Server Manager > Server
Configuration > Cluster-Wide Parameters > General tab and configure the TACACS Connection Idle
Timeout value as needed. The default value is 900 seconds (15 minutes). The minimum allowed value is 60
seconds (one minute) and the maximum allowed value is 172800 seconds (two days). (#37682)

Profiler and Network Discovery
The following new features are introduced in ClearPass Profiler and Network Discovery in the 6.6.4 release:

l ClearPass now supports MAC Notification Traps from HPE ArubaOS-Switches. This automatic notification
can be used to discover new devices connected to an HPE ArubaOS-Switch or to perform an OnConnect
enforcement. (#37180)

l A new cluster-wide parameter lets you specify the interval after which endpoints will be reprofiled. To use
this feature, go to the Administration > Server Manager > Server Configuration > Cluster-Wide
Parameters > Profiler tab and configure the Netflow Reprofile Interval field. The default value is 24
hours. The minimum value is one hour. (#37281)

l If custom fingerprints are configured, now the custom rules will always be evaluated before the default
rules. (#37545)

Issues Resolved in the 6.6.4 Release
The following issues have been fixed in the ClearPass 6.6.4 release. For a list of issues fixed in previous 6.6.x
releases, see "Issues Fixed in Previous 6.6.x Releases" on page 69.

This section includes:

l "APIs" on page 32

l "CLI" on page 33

l "Endpoint Context Servers" on page 33

l "Guest" on page 33

l "Onboard" on page 33

l "OnGuard" on page 34

l "Policy Manager" on page 34

l "Profiler and Network Discovery" on page 35

APIs

Bug ID Description

#37762 Corrected an issue in Insight endpoint API responses where, for role values, a line break would occur in
the string at the characters N, U, or L, resulting in incorrect output. Array parsing is now improved.

Table 4: API Issues Fixed in 6.6.4



CLI

Bug ID Description

#37672 Corrected an issue where, when working in the CLI, using the Ctrl + Alt + Delete keystroke combination
caused the system to reboot.

Table 5: CLI Issues Fixed in 6.6.4

Endpoint Context Servers

Bug ID Description

#36746 Corrected an issue where Aruba access points that were shipped with new HPE-Aruba part numbers
were not categorized as APs by ClearPass and could not be profiled.

#37193 Corrected an issue where, when a Google Admin console was used as the endpoint context server, after
the first poll the refresh token was cleared from the database and subsequent polls failed.

#37712 Corrected an issue where ClearPass did not update the Palo Alto Networks endpoint context server
“UserID Posturl” during a system patch update. Updating the ClearPass version now correctly changes
the PANW Firewall or Panorama UserID Post URL from
“https://{server_ip}/api/?type=user-id&action=set&key={key}&cmd={cmd}”
to
“https://{server_ip}/api/?type=user-id&action=set&key={key}”.

Table 6: Endpoint Context Server Issues Fixed in 6.6.4

Guest

Bug ID Description

#37892 Corrected an issue where 802.1x with multi-factor authentication did not work with Duo.

#38192 The PHP version is now updated to 5.6.30. This includes fixes for CVE-2016-9935.

Table 7: Guest Issues Fixed in 6.6.4

Onboard

Bug ID Description

#37782 Corrected an issue where trying to import an intermediate CA displayed the error message “Call to
undefined function NwaCheckSignature()” if the certificate had already been imported. Now if the user
attempts to import a CA certificate twice, Onboard displays an appropriate error message advising
that “A CA using this certificate already exists.”

#37783 Corrected an issue where Web-based enrollments were not counted toward the Onboard device limit.

#37859 Corrected an issue where a migration failure during the 6.6.2 or 6.6.3 patch could cause Onboard
enrollment failure.

#38246 Corrected an issue where invalid encoding of the signature algorithm field for a Certificate Revocation
List (CRL) caused the entire CRL to be invalid.

Table 8: Onboard Issues Fixed in 6.6.4
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OnGuard

Bug ID Description

#36248 Corrected an issue where the ClearPass Server reachability test passed even if the OnGuard
application was denied at Administration > Server Manager > Server Configuration > Network
> Application Access Control. This fix also corrects an issue where, in some cases, the ClearPass
OnGuard Unified Agent only checked the first two Server IP addresses in the Authentication Server list.

#36515 Corrected an issue where OnGuard incorrectly categorized the network connection type of an F5
VPN client as “Other”. The F5 VPN interface is now correctly detected as “VPN”.

#37009 Corrected an issue where the agent.conf file was sometimes corrupted or empty, causing the
ClearPass OnGuard Unified Agent to hang at the initializing stage.

#37333 Corrected an issue where, on devices using Mac OS X 10.11 or macOS 10.12, the Network tab of the
VIA dialog displayed incorrect remote server hostnames for VIA connection profiles if multiple
connection profiles were configured. Configuration information is now correctly retrieved from the
controller selected for the connection.

#37423 Corrected an issue where, on an Ubuntu operating system, the ClearPass OnGuard Unified Agent
incorrectly detected the status of the “chef-client” service as stopped when it was running.

#37630 Corrected an issue where the ClearPass OnGuard Unified Agent caused spikes in CPU consumption at
one-minute intervals while detecting installed antivirus products. The antivirus detection will now be
performed every two hours instead of every minute.

#38382 Corrected an issue where the ClearPass OnGuard Unified Agent for the Mac OS did not send the VPN
username in the WebAuth request if the OnGuard mode was set to “Check Health - no authentication”.

Table 9: OnGuard Issues Fixed in 6.6.4

Policy Manager

Bug ID Description

#30958 Corrected an issue where ClearPass integration with a Palo Alto Networks (PANW) Panorama server
failed due to a missing Content-Length header. Content-Length is now added by the library while
posting.

#35854 Corrected an issue where, when MAC authentication was configured against an external MySQL
database, some MAC authentication requests were rejected and the error message “No free
connections available” was displayed. Parallelism is now enabled on the MySQL driver, allowing multiple
queries to be sent to the MySQL server over multiple connections.

#36106
#36667
#37733

Corrected an issue where the RADIUS service crashed, causing authentications to fail, if unprintable
characters were present in the State attribute from third-party RADIUS targets.

#36147 Corrected an issue where, when a proxy server was configured, ClearPass license activation over the
proxy server failed. Now after the connection is established between ClearPass and the proxy server, all
packets will go through the proxy server.

#36848 Corrected an issue where, after a cumulative update patch was installed and the system restarted, the
incorrect username “clusteradmin” was shown in the Event Viewer. The System Event Details now
correctly shows the user as “appadmin”.

#36872 Corrected an issue where high CPU usage occurred during the cleanup interval. Bulk Guest user

Table 10: Policy Manager Issues Fixed in 6.6.4



Bug ID Description

#37059 operations such as deletion, insertion and updates are now optimized to avoid interference with request
processing.

#36879 Corrected a TACACS+ issue where the ENABLE authentication failed if the authen_type field
contained an invalid type. ClearPass now uses ASCII for the authen_typewhen this field has an
invalid value.

#36880 Corrected an issue where, in a cluster setup, ClearPass sent multiple reverse DNS queries to DNS
servers.

#37160 Corrected an issue where ClearPass did not accept a password change if the new password began with
special characters. Non-alphanumeric characters are now accepted at the beginning of passwords.

#37173 Corrected an issue where some events were missing from a Syslog export if the value for accounting
input or output octets was greater than the Integer data type’s range.

#37457 Corrected an issue where, on a cluster with an accounting proxy configured, Active Directory
authentications failed and the error message “Winbind reply failed” was displayed when an excessive
number of file handlers caused high CPU consumption.

#37509 Corrected an issue where SSH-related failure events and rekey events were not shown in the Event
Viewer if the hostname contained an underscore character ( _ ). The underscore character is now
supported in hostnames.

#37520 Corrected an issue where a Certificate Revocation List (CRL) update failed and the error message “CRL
updater encountered an internal error” was displayed if the CRL file size was large (greater than 1MB).

#37709 Corrected an issue where the username was not always updated in the Access Tracker after
authentication when an EAP-TLS session was restarted.

#37770 Corrected an issue where dropping access-request messages that contain certain attributes caused
problems in some scenarios.
Now access-requests that contain the following will be dropped only when ClearPass is in CC mode:
l The response attributes Password-Retry, Reply-message, or Error-Cause.
l Both an EAP-Message and an ARAP-Password, User-Password, or CHAP-Password attribute.

#38121 Corrected an issue where Configuration Database replication between the cluster nodes would hang if
both the username and certificate_id values were null in a row in the cpg_onboard_user
table and this row was replicated in the subscriber.

#38237 Corrected an issue where configuring the Disable TLSv1.0 support or Disable TLSv1.1 support
cluster-wide parameters was not applied to subscribers in a cluster, although it was applied to the
publisher.

Table 10: Policy Manager Issues Fixed in 6.6.4 (Continued)

Profiler and Network Discovery

Bug ID Description

#37410 Corrected an issue where discovered endpoints that did not have a MAC address were ignored. Now for
endpoints that do not have a MAC address, ClearPass will create MAC addresses for them that include
the prefix “xa”.

#38125 Users should be aware that after running a subnet scan, discovered endpoints that do not have a MAC
address will be displayed with a hyphen in the MAC Address column in the Configuration > Identity
> Endpoints list.

Table 11: Profiler and Network Discovery Issues Fixed in 6.6.4
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New Known Issues in the 6.6.4 Release
The following known issues were identified in the ClearPass 6.6.4 release. For a list of known issues identified in
previous releases, see "Known Issues Identified in Previous Releases" on page 89.

This section includes:

l "Cluster Upgrade and Update" on page 36

l "Dissolvable Agent" on page 36

l "Onboard" on page 37

l "OnGuard" on page 37

l "Policy Manager" on page 38

Cluster Upgrade and Update

Bug
ID Description

#37192 Symptom: The list of patches available in the Cluster Updates page is not the same as the list of
patches in the Software Updates page.
Scenario: The Software Updates page displays patches that have been both downloaded and installed.
On the Cluster Updates page, the Update Image Name drop-down list incorrectly includes all the
patches that have been downloaded, whether they have been installed or not.
Workaround: The seven-day cleanup interval will remove the non-relevent patches.

#38500 Symptom: After a patch is uploaded and successfully installed through the Cluster Update interface,
the patch file is still available on the Software Updates portal instead of being shown as installed.
Scenario: This only occurs if the patch is manually imported and then installed through the Cluster
Update interface. It does not occur if the patch is downloaded through the Software Updates portal.
Workaround: After the cluster is updated through the Cluster Update interface, click the Check Status
Now button on the Software Updates portal to refresh the status in the Firmware & Patch Updates
list.

Table 12: Cluster Upgrade and Update Known Issues in 6.6.4

Dissolvable Agent

Bug ID Description

#37967 Users should be aware that the ClearPass OnGuard Dissolvable Agent flow might not work in the Firefox
browser on the following operating systems, because Mozilla no longer supports Firefox on these
platforms: Mac OS X 10.6, 10.7, and 10.8.

Table 13: Dissolvable Agent Known Issues in 6.6.4



Onboard

Bug
ID Description

#36485 Symptom: The QuickConnect app crashes during onboarding and displays the error message “Could not
check connection to wireless network: Error querying autoconfig info - code: 5023, msg The group or
resource is not in the correct state to perform the requested operation.”
Scenario: This has been observed on ClearPass 6.6.2 when trying to onboard Windows 8.1 Surface Pro
devices if multiple MAC addresses are associated with a single device.
Workaround: Search for devices with multiple MAC addresses (for example, 00:00:00:BA:60:3C:31).
Delete those devices, and then onboard them again wirelessly. Do not use an external adapter such as
an ethernet connector or dongle to onboard multiple devices.

#38430 Symptom/Scenario: The License Usage count is not updated at Onboard > Management and Control
> Usage.

Table 14: Onboard Known Issues in 6.6.4

OnGuard

Bug ID Description

#37539 Symptom: The ClearPass OnGuard Unified Agent cannot install missing patches using the Microsoft
Windows Update Agent if the patch has an empty value in the KBARTICLEID field.
Scenario: This issue is seen on Windows 10 LSTB 14393 Build 2016.

#37939 Symptom: The Native Dissolvable Agent does not work in the Firefox browser.
Scenario: The Native Dissolvable Agent for Windows does not support the 64-bit version of the Firefox
browser.
Workaround: Use the 32-bit version of Firefox browser instead.

#38208 Symptom: After the ClearPass OnGuard Unified Agent is installed it does not automatically display the
VIA profile download dialog.
Scenario: When a non-administrator user is logged in and tries to install the agent, they are prompted
to provide administrator credentials. When they do, the agent installs, but the VIA profile download
dialog does not open.
Workaround: To download the VIA profile, go to the Details tab. In the Change Detail Type drop-
down list, select Connection Details, and then click the Download button. Enter the server details and
credentials in the Login window.

#38303 Symptom/Scenario: The ClearPass OnGuard Unified Agent does not support updating Symantec
Endpoint Protection 14.x as part of auto-remediation.

#38403 Symptom: The Native Dissolvable Agent does not work in the Firefox browser on macOS.
Scenario: After installing OnGuard through the Firefox browser, the “Install OnGuard” dialog does not
open and the plugin cannot be found. This has been observed in the Firefox browser on Mac OS X
10.10 and macOS 10.12.
Workaround: Use the Safari or Chrome browser instead.

Table 15: OnGuard Known Issues in 6.6.4
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Policy Manager

Bug ID Description

#35167
#35735

Symptom: On HPE-25K and HPE-5K servers, the total memory shown is slightly higher than the total
memory specifications for the VA type. This is consistent in the Dashboard, the CLI, and in Insight.
Scenario: The HPE-5K and HPE-25K servers slightly overestimate the “pages” used to calculate the total
RAM. In testing with a single 8 GB RAM module, it was found that every module overestimated a little bit.
Workaround: The “dmidecode” command will give the correct number of modules and total RAM
installed, and can be used to calculate the RAM; however, this command does not work for some virtual
appliances. Be aware that other commands such as “free -m” significantly underestimate the RAM size.

Table 16: Policy Manager Known Issues in 6.6.4
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Chapter 5
Change of Behaviors in Previous 6.6.x Releases

This chapter provides a summary of changes to behaviors, resources, or support that were introduced in
previous ClearPass 6.6.x releases. For a list of behavior changes introduced in the ClearPass 6.6.4 release, see
the What’s New in This Release chapter.

Previous Behavior Changes
Users should be aware of the following important changes in ClearPass behaviors and resources:

l For accounts that are configured to use only an access code instead of a username and password, the
Finished Creating Guest Accounts results page (create_multi_result.php) now displays the Access Code
field instead of the Username and Password fields. (#36656)

l When an iOS device is reconnecting after onboarding, a count-down timer and the message “Completing
configuration, please wait <#>  seconds...” are now displayed while the change of authorization (CoA) is in
process, alerting the user to stay on the page until the CoA is complete. (#36277)

l IPsec Phase2 now uses the same encryption and hash algorithms that are configured for IKE Phase1 Mode
on the Administration > Server Manager > Server Configuration >  Network tab > Create IPsec
Tunnel form. Users should be aware that if the peer does not support the configured encryption and hash
algorithms, the connection will not succeed. (#34624)

l All attempted upgrade, patch, and hotfix installations are now logged in the Event Viewer, including failed
attempts. (#35400)

l ClearPass will now drop access-request messages that contain the following attributes: (#35712)

n The response attributes Password-Retry, Reply-message, or Error-Cause.

n The EAP-Message attributes ARAP-Password, User-Password, or CHAP-Password.

l ClearPass will now drop the access-request packet that contains the invalid message-authenticator, and log
the corresponding error message in Event Viewer. (#35761)

l SSH logins that fail due to a password mismatch are now logged in the Event Viewer. (#37536)

l In Insight reports, a dynamic search for endpoint IP addresses sometimes took several minutes or failed to
complete. The autocomplete function is now removed from report filters and alert filters. Users should
enter the full IP address in the search field. (#36641)

l The ClearPass OnGuard Unified Agent for Windows used the same Event ID number for both Healthy status
and Unhealthy status in the Windows Event Viewer logs. Two separate Event ID numbers are now used:
(#35746)

n Healthy events ID is now 1029

n Unhealthy events ID is now 1030

l Users should be aware that IPsec pre-shared keys are now limited to 128 characters. (#35786)

l ClearPass 6.6 is the last release that will support Java for the Windows or Mac OS X ClearPass OnGuard
Dissolvable Agent. ClearPass 6.6.3 (cumulative patch 3) will contain the last updates to the Java-based
Dissolvable Agent. No further updates will be provided.

l If you plan to download the 6.6.4 cumulative patch from the Software Updates portal for use with the
Cluster Update interface on a ClearPass 6.6.0 appliance, you must first install the ClearPass 6.6.0
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Cluster Update Interface Patch. This patch is required for ClearPass 6.6.0-based clusters in order to
enable the Cluster Update user interface to recognize ClearPass patches and hotfixes when they have
been downloaded through the Software Updates portal. It only needs to be installed on the publisher.
This patch is NOT needed if the patches or hotfixes are manually imported into the ClearPass appliance.
(#34962)

n If you accidentally download the 6.6.4 cumulative patch before installing the ClearPass 6.6.0 Cluster
Update Interface Patch, the Start Update link will be missing from the Cluster Update interface. To
resolve this issue, delete the 6.6.4 cumulative patch, click Check Status Now and then download the
cumulative patch again.

l Some IPsec connection encryption algorithms are no longer supported. Existing systems that have these
algorithms configured will be updated to currently supported algorithms:

n ClearPass no longer supports using the 3DES encryption algorithm for IPsec connections. Existing
systems that have 3DES configured will be updated to AES-128.

n ClearPass no longer supports using AES-192 for IPsec connections. Existing systems that have AES-192
configured will be updated to AES-128.

n ClearPass no longer supports using Diffie-Hellman (DH) Group 1 or 2 for IPsec connections. Existing
systems that have DH Group 1 or 2 configured will be updated to DH Group 5.

n ClearPass no longer supports using IKEv1 in Aggressive Mode for IPsec connections. Existing systems
that have Aggressive Mode configured will be updated to Main Mode.

l The system requirements for the CP-VA-500 virtual appliances have changed. For details, see "Virtual
Appliance Requirements" on page 12.

l All VMware ESXi virtual machines now use hardware version 8.

l VMware ESX 4.0 is no longer supported.

l Changes to the TAG mappings tables to improve performance and scalability may impact SQL filters in use
by custom authentication sources. The following tables have been removed and a more efficient method
has been implemented. If you are currently using these tables, we recommend that you contact Aruba
support prior to upgrade:

n TIPS_AUTH_LOCAL_USER_TAG_MAPPINGS

n TIPS_GUEST_USER_TAG_MAPPINGS

n TIPS_NAD_CLIENT_TAG_MAPPINGS

n TIPS_ENDPOINT_TAG_MAPPINGS

n TIPS_TAG_VALUES

l The Configuration > Posture > Posture Servers page and the Administration > Dictionaries >
Posture page have been removed.

l ClearPass VMs are now shipped as a single virtual machine installation image per hypervisor type: either
VMware ESXi or Microsoft Hyper-V image. During installation, a new menu option lets the administrator
select the type of image they want to install — either CP-SW-EVAL, CP-VA-500, CP-VA-5K, or CP-VA-25K. For
more information, refer to the Installing or Upgrading to ClearPass 6.6 on a Virtual Appliance Tech Note.
(#28018)

l ClearPass 6.6.0 introduces a re-designed ClearPass Insight. Not all pre-6.6.0 features are currently available,
but will be added in future releases. In the new Insight, several data columns have been replaced which may
impact Syslog filters after upgrade. For example, if the Authentication columns were used, you need to
manually update the Syslog filter to use the new Endpoint columns. A notification or error is not displayed
during upgrade, but is displayed if you open the Syslog filters and attempt to save again.



l The Aruba Linux Cryptographic Module, which is based upon OpenSSL 1.0.2h as of 6.6.1, no longer
supports Diffie-Hellman parameters shorter than 1024 bits. This might impact third-party applications that
have not updated their software to protect against the Logjam vulnerability.
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Chapter 6
Enhancements in Previous 6.6.x Releases

This chapter provides a brief summary of the features and enhancements introduced in previous ClearPass
6.6.x releases. For a list of enhancements introduced in the ClearPass 6.6.4 release, see the What’s New in This
Release chapter.

This chapter includes:

l "APIs" on page 43

l "CLI" on page 44

l "Cluster Upgrade and Update " on page 44

l "Endpoint Context Servers" on page 45

l "Guest" on page 46

l "Insight" on page 49

l "Onboard" on page 51

l "OnConnect Enforcement" on page 52

l "OnGuard" on page 53

l "Policy Manager" on page 57

l "Profiler and Network Discovery" on page 66

l "QuickConnect " on page 67

APIs

Features Added in 6.6.3
ClearPass now includes the following REST APIs: (#35135, #35206, #35207, #35211, #35212, #35213,
#35214, #35577, #35622, #37225)

l AccessControl

l ClusterWideParameter

l Service

l ServerSnmp

l LocalUserPasswordPolicy

l AdminUserPasswordPolicy

l EndpointContextServer

l ServerVersion

l ServerFips

l RandomPassword
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CLI

Features Added in 6.6.3
l The ability to lock out the CLI based upon SSH public key authentication failures is now supported. To use

this feature, first go to Administration > Server Manager > Server Configuration and select Enable
Ingress Events Processing on the System tab. On the Services Control tab, start the Ingress logger
service and the Ingress logrepo service. Then in the CLI, configure: (#35398)

n ssh lockout count — The number of failed password attempts allowed before the account is locked
(for example, ssh lockout count 5).

n ssh lockout duration — The amount of time in minutes that the account will remain locked after the
maximum failed SSH login attempts (for example, ssh lockout duration 15).

n ssh lockout mode — Set this to advanced. In this mode, the account will be locked after the maximum
failed SSH password or public key login attempts.

l If access to ClearPass via SSH (CLI) is attempted with unsupported protocol versions or with unsupported
encryption or cryptographic hash algorithms, an alert is now logged in the Event Viewer. This feature
requires the Enable Ingress Events Processing option and services to be enabled for the server at
Administration > Server Manager > Server Configuration. (#35402)

l Two new CLI commands, show ports and configure port, were added for displaying and filtering
incoming or outgoing traffic on the particular port. The show ports command shows the status of all the
ports, and the configure port command is used to configure the filtering of a given port. (#35801)

l ClearPass will now log Event Viewer entries for CLI session (SSH) idle timeout scenarios. This feature
requires Ingress Event Engine options and services to be enabled. (#36320)

Features Added in 6.6.1
Support was added for a timed SSH lockout feature. This provides the ability to lock the CLI account for a
specified duration after a maximum number of consecutive password failures. This feature can only be
configured in the CLI for this release. (#34852)

l Use the ssh lockout count X command, where X is the number of failed authentication attempts,
before a lockout. The default is five attempts.

l Use the ssh lockout duration X command, where X is the number of minutes from 1-10080, to
specify the duration of the lockout after the count has been exceeded. The default is 15 minutes.

l Use the ssh lockout reset command to unlock the appadmin account. This can always be done
through console.

Cluster Upgrade and Update

Features Added in 6.6.0
The Cluster Upgrade Tool, which automates the process of upgrading a ClearPass cluster, is now natively
available within Policy Manager’s Administration module, and includes additional enhancements: (#28327,
#28454)

l In addition to the interface for upgrading a cluster, the Cluster Upgrade Tool now also provides an interface
for cluster updates. The administrator can use it to update subscribers with cumulative patch updates
within a release train (for example, from 6.6.0 to 6.6.1), or apply other available software updates. The
process for updates is similar to the process for upgrades.



l The administrator can install software upgrades or updates to all subscribers in a cluster or specify only
certain subscribers.

l On the Administration > Agents & Software Updates > Software Updates portal, two new links in the
upper-right corner, Cluster Upgrade and Cluster Update, let you open the appropriate page. These links
become available when the publisher is upgraded to ClearPass 6.6.

l On the publisher, after updates are downloaded on the Software Updates portal, they are available for
selection in a drop-down list in the Cluster Update interface. You can use either the Cluster Update link
or the Install button for a patch to open the Cluster Update interface.

l Starting with the 6.6.0 release, the Cluster Upgrade Tool documentation is no longer separate. Cluster
Upgrade Tool issues are now included in the ClearPass Release Notes. The information that was provided in
the Cluster Upgrade Tool Tech Note in earlier versions is now included in Appendix B, “Cluster Upgrade and
Cluster Update Tools,” in the ClearPass Policy Manager User Guide, and can be accessed from the online
help link on the Cluster Upgrade interface or the Cluster Update interface.

Endpoint Context Servers

Features Added in 6.6.3
The Aruba Activate Connector has been enhanced to support API calls to download larger numbers of
endpoints (for example, 50K) by using pagination. (#35871)

Features Added in 6.6.1
l For AirWatch integrations where polling for full endpoint details is not needed, that secondary poll can now

be disabled. To use this feature, go to the Administration > External Servers > Endpoint Context
Servers > Add > Server tab. In the Security Details field, use the Enable to fetch Endpoint Security
Info option: (#32578)

n To disable the secondary poll, leave this check box unselected. The MDM connector will only make an API
call to list the devices. It will not make a secondary API call for details of each device, so polling time will
be reduced. The secondary poll is disabled by default.

n To enable the secondary poll, select this check box. The MDM connector will make the API call for each
device's details, and the polling time will be the same as it was in earlier ClearPass releases.

l Namespace and context attributes are now commonly accessible. This enables the Post-Auth module to
receive HTTP-action content either partly filled or fully filled (previously, no values were received if any were
missing). The user can now modify HTTP-action content by adding or removing parameters from the user
interface without having to depend on Post-Auth changes. To use this feature, go to Administration >
Dictionaries > Context Server Actions. To create a new custom action you may either click Add or make
a copy of an existing action and then click its row in the list. On the Content tab of the Endpoint Context
Server Details form, modify parameters in the Content field to create the custom context server action.
(#33934)

l In a SOTI MDM environment, ClearPass now marks a device as unmanaged if the SOTI supplicant is
removed from the device. (#34107)

Features Added in 6.6.0
l The following Context Server Actions are now supported to improve joint functionality with MobileIron:

(#28144)
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n Delete only corporate information stored and remove device from MobileIron EMM management –
Retire/Enterprise Wipe (UUID or Device MAC Address)

n Send wake-up to device, request check-in – Wake-up Device (UUID or Device Mac Address)

n Remove label and corresponding policies

n Apply label to identify when devices have attached to corporate Wi-Fi and apply corresponding policies

n Send SMS message to cellular devices (UUID)

n Send Push Notification (UUID)

l The Check Point® login and logout actions have been enhanced with new URLs and updated content and
attributes. The Check Point login action has also been separated into Check Point Login – AD User for
active directory users and Check Point Login – Guest User for guests. To view or configure the updated
Check Point login and logout actions, go to Administration > Dictionaries > Context Server Actions.
(#28145)

l ClearPass supports Juniper Networks SRX servers as endpoint context servers. This allows a ClearPass
appliance to enable communication between the ClearPass appliance and the Juniper SRX server. (#28455)

l ClearPass natively supports Endpoint Context Server Action for Infoblox, enhancing its IP address
management service by providing username context. (#29559)

Guest

Features Added in 6.6.3
l Support was added for MS-CHAP authentication with Xirrus controllers. To use this feature, on either the

Configuration > Pages > Guest Self-Registrations form or the Configuration > Pages > Web Logins
form, select Xirrus in the Vendor Settings field and then specify MS-CHAP with shared secret in the
Password Encryption field. (#36615)

l In multi-factor authentication (MFA) workflows, auto-enrolling new users is now an opt-in choice instead of
the default for some providers. To use this feature, if you select Facial Network, ImageWare Systems, or
Kasada as the provider in Multi-Factor Authentication configurations, select the Enroll check box to
allow auto-enrolling usernames with the provider. (#36657)

l Multi-factor authentication (MFA) workflows no longer require device-level checking at every
authentication. Instead, a Grace Period field in Multi-Factor Authentication configurations lets you
specify an interval between MFA checks. To use this feature, enter a number of hours after the secondary
authentication before authentication would be required again. As long as the device name and username
are still the same, the user can skip the secondary check if they log in again before the interval expires. If
you wish to require authentication every time, the Grace Period field can be left empty. The default
interval is 24 hours. (#36659)

l ClearPass now supports Kasada Authenticator as a multi-factor authentication vendor. (#36660)

l The list of public profile attributes that are retrieved by default for social logins is increased. ClearPass now
automatically detects all major attributes for Facebook and LinkedIn social logins. (#37226)

Features Added in 6.6.2
l Support was added for configuring a source address Numbering Plan Indicator (NPI ) and for null

termination of C-Octet Strings on SMPP SMS servers. To use this feature, go to ClearPass Guest
> Configuration > SMS Services > Gateways > Create new SMS gateway and select SMPP v3.4 as
the SMS Gateway. (#35357)



l In social logins, support was added for login with Clever. Using an OAuth2-based Single Sign-On workflow
with access to Student Information Systems (SIS) identity sources, this option offers schools enhanced
access control, preserving bandwidth. (#35641)

l The FIAS Micros transaction processor includes several new enhancements: (#36029)

n Timestamps used in the FIAS protocol are now relative to the ClearPass system’s time. If the hotel
Property Management System (PMS) and ClearPass are in different time zones, the time zone can be
overridden in the Transaction Processor Configuration form at ClearPass Guest > Configuration
> Hotspot Manager > Transaction Processors.

n FIAS transaction processors can now be configured to send a periodic keepalive command. A keepalive
may be needed in scenarios where room updates are infrequent, or if other networking devices such as
switches or firewalls can otherwise drop connections. The FIAS transaction processor has two options for
keepalive commands: Link Start (LS) and Link Active (LA). Only the LS command will receive a
response from the PMS software. To use this feature, create a new transaction processor with a
FIAS gateway and configure the Keep Alive field on the Transaction Processor Configuration form.

n The room transaction details shown on the Occupied Room List page are now displayed in real time.

n The Occupied Room List page also includes a summary of current information regarding the
connection to the PMS software. You can see current connection status, recent commands received, and
any pending or queued payment requests.

n A new transaction processor action is available to overcome out-of-sync room information. If room data
appears to be stale, a Re-Synchronize Rooms link is available on the Transaction Processors page.
Users should be aware that choosing this option will cause all current room data and any pending
payment requests to be lost.

Features Added in 6.6.1
l When enabling SSO for ClearPass Guest, you can now distinguish between guest Web logins and guest

operator logins. The new GuestOperators option for operator logins is available at Policy Manager >
Configuration > Identity > Single Sign-On (SSO). (#34680)

n If only the GuestOperators option is selected, SSO will be enabled for operator logins only, and Web
logins will use normal non-SSO authentication.

n If only the Guest option is selected, SSO will be enabled for Web logins only, and operator logins will use
normal non-SSO authentication.

n If both the GuestOperator and the Guest options are selected, then operator logins and Web logins
will both use SSO authentication.

l Email notifications for account expiration may now be sent as many as 30 days prior to the expiration date.
To use this feature, go to Configuration > Guest Manager, enable Expiration Warning Options, and
enter a number from 1 to 30 in the new Account Expiry Notification field. The default value is 1 day,
matching the behavior in previous releases. (#34474)

l You can now extend a guest account's expiration window each time the password is changed. This allows an
account's lifetime to be automatically renewed in cases where it would otherwise expire before the next
required password change. To use this feature, go to Configuration > Pages > Guest Self-Registrations
and edit a registration page. In the Self-Service Portal form, the Change Password area includes the new
Extend Expiration field. (#34477)

l Pages rendered with the stock skin now declare their language in the HTML header. (#34840)
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Features Added in 6.6.0
l ClearPass Guest now supports SMPP v3.4 as an SMS gateway. This option is available at Configuration

> SMS Services > Gateways in the SMS Gateway field. (#9747)

l The expire_timezone field is now stored as a persistent guest field. Receipts and edits made after an
account is created are now displayed in the account’s local time zone. (#26032)

l Hotspot Manager now includes the following enhancements for customizing Payment Management System
(PMS) plans based on data about the hotel guest: (#27691, #28539, #28540)

n Hotel hotspot plans can be created so that guest accounts expire on the expected day of departure. On
the hotspot plan configuration form, the Time Tracking field includes a new option, Checkout date -
Expiration will be midnight the day of the checkout (Hotel PMS only).

n Hotel hotspot plans can be created so that new devices can use a plan that is already created and paid
for. On the hotspot plan configuration form, the Time Tracking field includes a new option, Already
paid - Select for other devices to share a paid plan (Hotel PMS only).

l A new option in Social Logins configurations, Friends, allows retrieval of the guest’s friends list when
Facebook is selected as the provider. Permission must also be granted by the guest, and only friends who
also use your application ID can be retrieved. (#27836)

l A new option in Social Logins configurations, Google Groups, allows retrieval of Google Group
membership information when Google is selected as the provider. If this option is selected, the Admin SDK
Refresh Token and Authorization Code must also be regenerated. (#27882)

l A new Terms and Conditions Web page template has been added to the list of templates at
Configuration > Pages > Web Pages. This page can be customized and used to present your terms and
conditions of use to guests, and is referenced by the Terms Of Use URL field on the Configuration
> Guest Manager form. (#28156)

l ClearPass now provides multi-factor authentication for guest logins. Multi-factor authentication lets you
require multiple factors, or proofs of identity, when authenticating a user. To configure multi-factor
authentication (MFA) in ClearPass, you first create an account with an MFA provider and create the users for
the guest account. You then set up either a captive portal login or an Onboard login. The list of MFA
providers currently supported in ClearPass includes Duo Security Two Factor Authentication, Facial Network
ZOOM Multi-Factor Authentication, Imageware Systems GoMobile Interactive, and SMS Verification Codes.
Multi-factor authentication can be configured in ClearPass Guest at Configuration > Pages > Web
Logins, and at Onboard > Deployment & Provisioning > Provisioning Settings > Web Login. For
more information, see “About Multi-Factor Authentication” in the ClearPass Guest User Guide. (#28452,
#30199, #30420, #32711)

When you configure the multiple factors, or proofs of identity, for authenticating a user, usually at least two
of the following categories are required:

n Knowledge: A secret the user knows, such as their password or PIN.

n Possession: Something the user has, such as a security token generator or a certificate. This requirement
can also be met by having the user answer a registered phone number or email address to retrieve a
temporary code.

n Inherence: A physical characteristic of the user, such as their voice, face, or fingerprint.

Policy configurations can define how often multi-factor authentication will be required, or conditions that
will trigger it:

n Time-based policy: Policy might require MFA on a daily or weekly basis, or if the user has not logged in
from the device for a certain number of days, or if the device was unhealthy in the past 30 days.



n Posture-based policy: Policy might require MFA if the device’s posture changes to unhealthy, or if the
posture of any of the user’s other devices changes to unhealthy, or if a company alert or security check is
issued.

n Policy based on other conditions: Policy might require MFA if the user has never logged in from the
location before, or has failed authentication three times, or if a third-party application or system triggers
MFA.

l A new option, Arbitrary Sort, is available in the API Framework Plugin configuration. This option lets you
override default sort-field settings and specify any field as the sort column through the API. (#29462)

l The page loading time is faster for admin pages with HTML editing areas that include content item drop-
down lists. (#31087)

l Social login support was added for Microsoft Azure Active Directory. (#32338)

l Support was added for Norwegian translations in many guest-facing pages. (#33470)

Insight

Features Added in 6.6.3
l A new Onboard Enrollment report lets you view information about the onboarded devices. To use this

report, go to Insight > Reports > Create New Report. In the Category drop-down list select Onboard,
and then select the Onboard Enrollment option.  (#29300)

l The Onboard Certificate Report template now shows a Revoked Devices count and a pie chart for
Revoked Onboard Device Distribution. (#33676)

l The count of unique devices and the total number of devices onboarded per user are now available in the
Onboard Enrollment report template (#35765)

l The Insight database now includes the Framed-IPv6-Address attribute value (the supplicant IPv6 address) to
support filtering and reports based on Framed-IPv6-Address. (#36311)

Features Added in 6.6.2
l A new Guest - Expired report lets you view information about expired guest accounts. To use this report,

go to Insight > Reports > Create New Report. In the Category drop-down list select Guest
Authentication, and then select the Guest - Expired option. (#34943)

l Support was added to Insight reports and searches for filtering by endpoint IP address and by username. A
new widget is also added to the accounting reports to provide an overview of authentications per domain.
(#35381)

Features Added in 6.6.1
l Insight’s OnGuard Posture reports now include a Hostname column. In scenarios where two MAC

addresses might be recorded for a single host if the user makes a wired or wireless connection, the machine
hostname can uniquely identify the endpoint. (#29075)

l A new Endpoint Overview report lets you view information for endpoints that were added to the network
but not yet authenticated. To use this report, go to Insight > Reports > Create New Report. In the
Category drop-down list select Endpoint, and then select the Endpoint Overview option. (#31753)
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l Insight alerts for failed authentications can now be filtered by Network Access Device. To use this feature,
go to Insight > Alerts > Configuration > Create New Alert. Set the Category to Authentication
> Failed Authentication, and then select NAD IP in the Filter drop-down list. (#33814)

l A new Social Login report lets you view information for social media. To use this report, go to Insight
> Reports > Create New Report. In the Category drop-down list select Guest Authentication, and
then select the Guest - Social Login option. (#34135)

Features Added in 6.6.0
l ClearPass Insight has a new user-friendly interface. In addition to a new look and feel and added Dashboard

elements, the new Insight UI provides improved, easy-to-use reporting and alerts features. Search and
performance are enhanced, data and analytics are more powerful, and pre-configured reports and alerts are
available. (#28449, #29238, #29270, #29339, #29420, #31409, #31410, #31411)

The new Insight UI includes:

n Counts summary — Counts for Total Auth, Failed Auth, Unique Endpoints, Unique Users, and
Alerts Created are displayed at the top of each page.

n Dashboard section — This item in the left navigation opens the Dashboard home page, which displays
several report widgets. Subheadings in the left navigation let you display pages for any of the following
categories: Authentication, Endpoints, Guest, Network, Posture, System, or System Monitor.
Whether you are on the Dashboard home page or one of its subheadings, controls in each widget let you
create a report or alert for it. You can also customize the Dashboard home page by adding or removing
widgets. The default look-back window for the data in each widget is 24 hours. An exception to this is the
System Monitor widget, which shows data for the previous two hours.

n Reports section — This item in the left navigation opens the Reports home page, which displays the
“news feed” activity summaries for Yesterday, Today, and Tomorrow, the list of Created Reports,
and the Create New Report button. You can click the name of a report in the list to view it in a new tab,
or click the Configuration subheading in the left navigation to edit a report. Creating a new report is
simple and easy, with a wizard to walk you through each step. Report categories available in this release
are authentication, endpoint, guest authentication, network, OnGuard (Linux, Mac, and Windows),
Onboard, RADIUS authentication, system, and TACACS.

n Alerts section — This item in the left navigation opens the Alerts home page, which displays the list of
created alerts and the Create New Alert button. You can click the name of an alert in the list to view it
in a new tab, or click the Configuration subheading in the left navigation to edit an alert. Alert
categories available in this release are authentication, system, and TACACS.

n Administration section — This item in the left navigation opens the Insight Administration home
page, where you can work with file transfer settings and database settings.

n Search field — Allows searching by username (Username or Auth_username), endpoint (Host, MAC, or
Host IP), ClearPass appliance (ClearPass Server IP or name), or network device (NAD IP, NAD Name, or
NAD MAC). The Search field can auto-complete

n Workflow — The new workflow for creating or editing a report or alert is simple and intuitive.

n Differentiated user access — Insight now supports multi-level administrator access:

n Each of the Insight modules (Dashboard, Reports, Alerts, Administration) can have three privilege
levels or no privilege: read, read/write, or read/write/delete.

n A login area on each page of the Insight user interface lets the user log in as an administrator or super
administrator.



n In the case of no privilege, the link on the left navigation won’t be visible for a user who does not have
the appropriate privilege.

n Users can be assigned Insight privileges from two locations: Guest > Administration > Operator
Logins > Profiles, and Policy Manager > Users and Privileges > Admin Privileges.

Insight is not enabled by default. To enable Insight, go to the server configuration page at https://<Your-
ClearPass-IP>/. On the System tab, select the appropriate option in the Insight Setting field.

l The Insight OnGuard reports now include Posture Evaluation Results as part of Raw data. The following
health classes indicate which checks failed for these health classes: (#29783)

n AntiSpyware

n AntiVirus

n Disk Encryption

n File Check

n Firewall

n Installed Applications

n Network Connections

n P2P

n Patch Management

n Processes

n Registry Keys

n Services

n USB Devices

n Virtual Machines

n Windows Hotfixes

l Support for Domain Name was added to the inbound legacy API and the OAuth2-based API. (#30469)

Onboard

Features Added in 6.6.2
l Support was added for using Onboard as a Registration Authority (RA). When this option is used, instead of

issuing certificates, Onboard will proxy a certificate request to another Certificate Authority (CA) via SCEP.
The issued certificate is included in the certificate list. To use this feature, go to ClearPass Guest
> Onboard > Certificate Authorities > Create new certificate authority and select Registration
Authority in the Mode field. After you configure the SCEP-RA certificate, you can specify the CA to use for
TLS client certificates independently of the CA used for enrollment: At Guest > Onboard > Deployment
and Provisioning > Provisioning Settings, the General tab now includes a TLS Certificate Authority
field. Both the TLS Certificate Authority and the Certificate Authority fields include the SCEP-RA
option. This functionality has been validated with Microsoft Active Directory Certificate Services (ADCS) and
ClearPass Onboard CAs. (#35579)

Features Added in 6.6.0
l Onboard certificate signing requests now track the time the request was received. On the Onboard

> Management and Control > View by Certificate list view, this information is included in the details
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provided by the View request link, and can also be displayed by configuring the view’s columns to include
Request Received At. (#27053)

l The logic Onboard uses to send required RADIUS certificates is updated. To avoid the need to reprovision
when the RADIUS certificate expires, only the chain will be sent instead of the certificate itself. (#28715)

l Support was added for the EAP-SIM authentication protocol for both iOS and Android devices. This can be
configured at Onboard > Configuration > Network Settings on the Protocols tab. (#30134)

l Support was added for properly filling the “Configure Certificate Selection” option available in Windows 8
and higher. This enables usage of the correct client certificate for EAP-TLS even when multiple 802.1X-
eligible certificates are present in the client. (#32554)

l A new option in Onboard allows QuickConnect to install certificates in the system store for Android. The
Onboard > Network Settings > Authentication tab now includes an Android Authentication area
with a Certificate Store field. The options available for this field, Private or System, specify the certificate
store where the client certificate will be provisioned when configuring an Android device. When certificates
are installed in the system store, they will be available for use by other applications. Additional security
prompts might be required during provisioning.(#32700)

l Support was added for renewal of SCEP certificates in Onboard. (#33234)

OnConnect Enforcement

Features Added in 6.6.3
During OnConnect Enforcement, the domain name and the machine name are now fetched along with the
logged-in username. The domain name can be used as an attribute for the enforcement policy. (#34953)

Features Added in 6.6.2
l OnConnect Enforcement is no longer in feature-preview mode and can now be used in a ClearPass cluster.

OnConnect can be enabled on a per-appliance basis and roles can be assigned per zone. In each zone, one
primary master and one secondary master must be designated. If the primary master fails for any reason,
the secondary master takes over until the designated primary master is back on line. Only the primary
master in each zone will trigger OnConnect Enforcement. To use this feature, go to Administration
> Server Manager > Server Configuration and select a server in the list. In the OnConnect Setting
field, select the Enable OnConnect check box, and then select either Primary master or Secondary
master in the drop-down list. (#34418, #34419)

l Network Access Devices (NADs) can now be assigned to a zone, allowing the SNMP service to poll or query
only the NADs that are in its zone. As part of this feature, the Zone drop-down list at Configuration
> Network > Devices is renamed Policy Manager Zone and is moved to the SNMP Read Settings tab
instead of the OnConnect Enforcement tab. (#34421, #35767)

l Support was added for querying and selecting port names for the Network Access Device for OnConnect
Enforcement. To use this feature, go to Configuration > Network > Devices and enable SNMP Read and
OnConnect Enforcement for a device. On the OnConnect Enforcement tab click Query Ports, select the
ports to use, and click Add to Port Names. Alternatively, port names may be entered as comma-separated
values. (#34424)

Features Added in 6.6.1
ClearPass 6.6.1 includes a new feature called ClearPass OnConnect Enforcement. This feature enables
ClearPass to detect and apply enforcement to endpoints connected to wired switches without the need to



enable AAA methods such as 802.1x or MAC Authentication. Using standards-based SNMP, wired switches can
notify ClearPass when a new device has connected. Then using the native profiling capabilities of ClearPass, it
can match the learned MAC address against profiled information to apply a policy using SNMP. OnConnect
Enforcement can also use information from Windows Management Instrumentation (WMI) to identify the user
in the case of a domain-joined computer in order to apply identity-aware enforcement policies. This also allows
enforcement in non-AAA environments without the need for an agent, such as OnGuard, on the endpoint.
(#34416, #34422)

Prerequisites:

l Configure SNMP v2c or v3 MIB access on the wired switch.

l Configure SNMP traps from the wired switch to the ClearPass appliance.

l Define a Network Access Device with SNMP information and physical ports to be used with OnConnect
Enforcement (at Configuration > Network > Devices).

l Configure Windows Management Instrumentation details in the Profile settings (at Configuration >
Profile Settings > WMI Configuration).

l Configure a service using the ClearPass OnConnect Enforcement template (at Configuration > Services >
Add, select ClearPass OnConnect Enforcement in the Type drop-down list).

Sample Workflow:

1. Log in to a domain-joined endpoint.

2. Connect the endpoint to the port configured for OnConnect Enforcement.

3. The switch will send an SNMP trap to ClearPass with the endpoint MAC details.

4. ClearPass will learn of the endpoint IP and device details through profiling (for example, DHCP).

5. Using WMI, ClearPass will then initiate a scan against the endpoint to identify the logged-in user.

6. Based upon the user information, the endpoint can be placed into an appropriate VLAN or have its port
bounced to apply a different policy.

OnConnect Enforcement is in feature-preview mode for ClearPass 6.6.1. It is made available for use in proof-of-
concept environments and only tested with a limited number of Cisco and HPE ArubaOS- Switch platforms with
domain-joined clients in this release. Support for additional third-party vendors and workflows will be added in
subsequent releases.

OnGuard
l Support was added for the following products: (#32719, #33905, #33906, #35597, #35706, #36280,

#36362, #37091, #37529)

n AhnLab V3 Endpoint Security 9.x (Windows)

n AhnLab V3 Internet Security 9.0 antivirus

n Avast Free Antivirus 12.x (Windows)

n Avast Free Antivirus 11.x (Windows)

n Avast Pro Antivirus 11.x (Windows)

n Avast Internet Security 12.x (Windows)

n AVG AntiVirus 2016.x (Windows)

n AVG AntiVirus Free Edition 16.x (Windows)
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n Avira Free Antivirus 15.x (Windows)

n Bitdefender Endpoint Security for Mac 4.x (Mac OS X)

n Check Point Endpoint Security 8.x (Mac OS X)

n Check Point Endpoint Security [Firewall] 8.x (Mac OS X)

n Check Point Endpoint Security 7.x.

n HP Drive Encryption 8.x (Windows)

n Kaspersky Anti-Virus 16.x (Mac OS X)

n Kaspersky Anti-Virus 16.x (Windows)

n Kaspersky Internet Security 16.x (Mac OS X)

n Kaspersky Internet Security 16.x (Windows)

n Kaspersky Total Security 16.x (Windows)

n MacKeeper 3.X (Mac OS X)

n McAfee Endpoint Security for Mac 10.x (Mac OS X)

n McAfee Endpoint Security Threat Prevention 10.x (Windows)

n McAfee ePolicy Orchestrator Agent 5.0.2

n McAfee Personal Firewall 16.x (Windows)

n McAfee VirusScan 19.x (Windows)

n McAfee VirusScan 18.x (Windows)

n Oracle VM VirtualBox 5.x (Windows)

n Security and Patch Manager 10.x (Windows)

n Symantec Endpoint Protection 14.x

n Symantec Hosted Endpoint Protection 3.x (Windows)

n Symantec Hosted Endpoint Protection 2.x (Windows)

n Trend Micro Internet Security 6.x (Mac OS X)

Support was enhanced for the following products:

n Avast Endpoint Protection Suite 8.x (Windows)

n Avast Internet Security 12 (Windows)

n Avira Free Antivirus 15.x (Windows)

n Casper Suite 9.x (Mac OS X)

n ESET Cyber Security 6.x (Mac OS X)

n ESET Cyber Security 6.x (Windows)

n ESET Endpoint Antivirus 6.x (Mac OS X)

n ESET Endpoint Antivirus 6.x (Windows)

n ESET Endpoint Antivirus 5.x (Windows)

n ESET Endpoint Security 6.x (Windows)

n ESET Endpoint Security (Windows)

n Kaspersky Anti-Virus on Mac 15.x (Mac OS X)



n Kaspersky Endpoint Security 10.x (Mac OS X)

n Kaspersky Endpoint Security 10.x (Windows)

n McAfee Host Intrusion Prevention 8.x (Windows)

n McAfee Virus Enterprise 8.8.06000 (Windows)

n McAfee VirusScan Enterprise 8.x (Windows)

n Malwarebytes Anti-Malware 2.x (Windows)

n Microsoft Windows Firewall 10.x (Windows)

n Norton 360 22.x (Windows)

n Norton Security 22.x (Windows)

n Norton Security with Backup 22.x (Windows)

n Sophos Anti-Virus 9.x (Mac OS X)

n Symantec Endpoint Encryption 11.x (Windows)

n Symantec Hosted Endpoint Protection 3.x (Windows)

n System Center Endpoint Protection (Windows)

n System Center Endpoint Protection for Mac 4.x (Mac OS X)

n Webroot AntiVirus 9.x (Windows)

Features Added in 6.6.3
l A new attribute, Host:OSName, is now available for service rules, and allows you to select a WebAuth

Service based on an operating system name — for example, “Host:OSName CONTAINS Windows 8.1”. To
use this feature, go to Policy Manager > Configuration > Services > Add. (#35531)

l Support was added for the LiveUpdate method for McAfee Endpoint Security Threat Prevention 10.x.
(#36520)

Features Added in 6.6.2
l A new enforcement profile, Agent Script Enforcement, was added. It allows admins to execute external

scripts or programs on endpoints by using the ClearPass OnGuard Unified Agent as part of agent
enforcement. With this profile, OnGuard can execute external scripts or programs stored in the local
endpoint or on an external http/https server. The Agent Script Enforcement profiles you create are available
in WEBAUTH (SNMP/Agent/CLI/CoA) type enforcement policies. To use this feature, go to Configuration >
Enforcement > Profiles > Add and select Agent Script Enforcement in the Template drop-down list.
(#34136, #34532)

This feature allows Multiple Agent Script Enforcement policies to be defined. These policies can then be
mapped against different System Posture Tokens (SPT) or Application Posture Tokens (APT). An APT is
another term for a Health Class. Below is an example of multiple Agent Script Enforcement profiles that can
be defined in a single policy.

If Condition = Posture:WindowsUniversal:Services NOT_EQUALS HEALTHY

Then Actions = agent-script-remediate-services

If Condition = Tips:Posture NOT_EQUALS HEALTHY (0)

Then Actions = agent-script-remediate-client
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Admin users can configure various attributes for the script to be executed, such as Path Of The Script,
Command To Execute, Wait Time (Seconds) Before Executing Script, SHA256 Checksum, and more.
The SHA256 Checksum attribute can take multiple checksums separated by commas.

Users should be aware of the following limitations:

n The Agent Script Enforcement profile is currently supported only with the OnGuard Unified Agent for
Windows.

n The ClearPass OnGuard Unified Agent supports downloading scripts only from http and
unauthenticated https URLs. For https URLs, OnGuard will skip server certificate verification.

l Support was added for AND/OR combinations in the Services health class for Windows in the ClearPass
Windows Universal System Health Validator. This allows checking for services that might go by different
names on different systems. To use this feature, go to Configuration > Posture > Posture Policies
> Posture Plugins > ClearPass Windows Universal System Health Validator. (#34633)

l A new attribute, Bounce Delay (in seconds), was added to the Agent Enforcement profile. If this attribute
is configured, the interface will be bounced after the specified delay. To use this feature, go to
Configuration > Enforcement > Profiles > Add. Select the Agent Enforcement template, and on the
Attributes tab configure the Bounce Delay (in seconds) attribute. (#35130)

l The VIA component of the Windows ClearPass OnGuard Unified Agent is now updated to Windows VIA
2.3.3. For information about the features and enhancements available in VIA 2.3.3, refer to the Aruba VIA
2.3.3 Windows Edition Release Notes available on support.arubanetworks.com at Documentation
> Software User & Reference Guides > Aruba VIA > Release Notes > Windows. (#35418)

l The VIA component of the Linux ClearPass OnGuard Unified Agent is now updated to Linux VIA 3.0.0. For
information about the features and enhancements available in VIA 3.0.0, refer to the Aruba VIA 3.0.0 Linux
Edition Release Notes available on http://support.arubanetworks.com at Documentation > Software
User & Reference Guides > Aruba VIA > Release Notes > Linux. (#35839)

Features Added in 6.6.1
In the posture policies configuration for Windows Hotfixes health classes, you can now quickly view
information about superseded updates without having to scroll through the list of updates. To use this
feature, go to Configuration > Posture > Posture Policies > Add. On the Posture Plugins tab, select
ClearPass Windows Universal System Health Validator and click its Configure button. Select the
appropriate Windows operating system and then select Windows Hotfixes. Select the check box to enable
checks for the operating system, filter the Available Hotfixes list, and highlight an update. In the information
for the selected hotfix that is displayed below the list, updates that supersede it and updates that are
superseded by it are displayed near the top. (#34402)

Features Added in 6.6.0
l The Install Level Check Type option offered in the Patch Management health class allows OnGuard to

check Mac OS X client devices for missing updates. When auto-remediation is enabled, OnGuard installs the
missing updates automatically. (#23834)

l The ClearPass Native Dissolvable Agent now supports Auto-Upgrade. When a new version becomes
available on the ClearPass appliance, the Native Dissolvable Agent will upgrade automatically and run health
checks after the upgrade is installed. (#25061)

https://support.arubanetworks.com/Documentation/tabid/77/DMXModule/512/Command/Core_Download/Default.aspx?EntryId=22183
https://support.arubanetworks.com/Documentation/tabid/77/DMXModule/512/Command/Core_Download/Default.aspx?EntryId=22183
http://support.arubanetworks.com/default.aspx
https://support.arubanetworks.com/Documentation/tabid/77/DMXModule/512/Command/Core_Download/Default.aspx?EntryId=22090
https://support.arubanetworks.com/Documentation/tabid/77/DMXModule/512/Command/Core_Download/Default.aspx?EntryId=22090
http://support.arubanetworks.com/default.aspx


l Two new fields were added for health classes. Perl regular expressions are supported for both of the
following fields: (#25819, #31886)

n The Enable Regular Expression field was added to the Installed Applications health class. If this
field is enabled, the policy server treats the application name as a regular expression when comparing
application names. This option can be used for Windows and Mac OS X.

n The Enter Regex pattern for Registry value field was added to the Registry Keys health class. If a
Regex pattern is specified, the policy server will use the regular expression for comparing registry key
values.

l ClearPass now computes OnGuard licenses based on devices/endpoints instead of MAC addresses.
(#27748)

l The ClearPass OnGuard Unified Agent on Windows now supports running in Service mode; it performs
health checks even if the user is not logged in. To use this feature, go to Administration > Agents and
Software Updates > OnGuard Settings and click Global Agent Settings. Select the new parameter
Run OnGuard As, and specify the value as either Agent, Service, or BothAgentAndService. For creating
different policies for OnGuard mode, two new attributes, Host::AgentType and
Host::HealthCheckLevel, are available in service rules. (#29673)

l On the Administration > Agents and Software Updates > OnGuard Settings page, a new Native
Dissolvable Agent Customization area allows administrators to select which interfaces are to be allowed
for the Native Dissolvable Agent. The Native Dissolvable Agent will only perform health checks for interfaces
that are specified in the Native Dissolvable Agent Customization area. Options include Wired,
Wireless, VPN, and Other. This ensures that, if both wired and wireless interfaces are connected, the
OnGuard Agent will send health requests through the correct interface. (#30333)

l System tray icons for the ClearPass OnGuard Unified Agent running in VIA + OnGuard mode now show the
status of both VIA and OnGuard components. OnGuard standalone system tray icons have also been
updated. (#31074)

l The OnGuard Agent support charts that used to be accessed through the online help are now directly
available in the user interface at Administration > Support Documentation. Click the OnGuard Agent
Support Charts link on that page to open a list of platform-specific links providing complete information
regarding supported antivirus, anti-spyware, firewall, disk encryption, peer-to-peer, patch management, and
virtual machine software. (#32722)

Policy Manager

Features Added in 6.6.3
l ClearPass now lets you customize username and password prompts for TACACS+ sessions. To use this

feature, go to the Administration > Server Manager > Server Configuration > Cluster-Wide
Parameters > General tab and modify the default text in the TACACS User Prompt Text and TACACS
Password Prompt Text fields. (#33139)

l A new cluster-wide parameter lets you enable or disable TLS v1.1. To use this feature, go to the
Administration > Server Manager > Server Configuration > Cluster-Wide Parameters tab and
configure the Disable TLSv1.1 support parameter. (#33399)

l The Event Viewer now shows logging for IPsec connection status. Detailed information is now shown
whenever an IPSec tunnel is brought up or down. (#35216)
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l ClearPass now introduces a Common Criteria (CC) Mode, which limits certain functions in order to adhere to
Common Criteria protection profiles. These include: (#35218, #35219, #35711, #35714, #35861, #35905,
#36122)

n Only CA-issued certificates can be used for ClearPass Server Certificates.

n All X.509 v3 trusted CA certificates must satisfy the basic constraints.

n No self-signed certificates will be allowed as Trusted Certificates.

n All HTTPS communication to external services using X.509 v3 certificates must pass basic constraints
checks.

n An EAP-NAK will be sent in the access-challenge if the supplicant sends an EAP-MD5 response in the EAP-
Message.

n EAP-TLS authentication is limited to only use the following ciphers:

n TLS_RSA_WITH_AES_128_CBC_SHA (0x002f)

n TLS_RSA_WITH_AES_256_CBC_SHA (0x0035)

n TLS_RSA_WITH_AES_128_CBC_SHA256 (0x003c)

n TLS_RSA_WITH_AES_256_CBC_SHA256 (0x003d)

n TLS_DHE_RSA_WITH_AES_128_CBC_SHA (0x0033)

n TLS_DHE_RSA_WITH_AES_256_CBC_SHA (0x0039)

n TLS_DHE_RSA_WITH_AES_128_CBC_SHA256 (0x0067)

n TLS_DHE_RSA_WITH_AES_256_CBC_SHA256 (0x006b)

n TLS_ECDHE_ECDSA_WITH_AES_128_CBC_SHA256 (0xc023)

n TLS_ECDHE_ECDSA_WITH_AES_256_CBC_SHA384 (0xc024)

n TLS_ECDHE_ECDSA_WITH_AES_128_GCM_SHA256 (0xc02b)

n TLS_ECDHE_ECDSA_WITH_AES_256_GCM_SHA384 (0xc02c)

To enable CC mode, you must first enable FIPS mode and then go to Administration > Server Manager
> Server Configuration > Cluster-Wide Parameters > Mode and set Common Criteria Mode to
True. This option will be greyed out if FIPS is not first enabled.

l ClearPass can now optionally be enabled to validate that the cRLSign bit has been set when using
certification-based authentication with IPsec connections. If Strict CRL Policy is enabled at
Administration > Server Manager > Server Configuration > Service Parameters > ClearPass IPsec
service, then the connection will not succeed if the certificate of the CRL response has no cRLSign bit set.
(#35220)

l An option to configure the peer's certificate subject DN as "Peer Certificate Subject DN" is now provided for
IPsec certificate-based connections. This is not a mandatory value; it can be empty. When a value is
provided, only peers presenting certificates with a subject DN that exactly matches the configured subject
DN will succeed. (#35322)

l Traffic selector-based rules can now be configured when you create an IPsec tunnel. A new Traffic
Selectors tab provides configuration options for Encrypt Rules, Bypass Rules, and Drop Rules. These
let you specify the packets to encrypt and allow through the tunnel, the packets that can bypass the tunnel
in cleartext, and the packets to be dropped. For each type of rule, you can specify the protocol and port.
Configuring rules is optional. If no rules are configured, all traffic is encrypted by default. To use this feature,
go to Administration > Server Manager > Server Configuration and select a server in the list. On the
Network tab, click Create IPsec Tunnel. (#35397)



l If access to ClearPass through the Web UI is attempted with unsupported SSL protocol versions or with
unsupported ciphers, an alert is now logged in the Event Viewer. This feature requires the Enable Ingress
Events Processing option and services to be enabled for the server at Administration > Server
Manager > Server Configuration. (#35403)

l At Administration > Server Manager > Server Configuration > Cluster-Wide Parameters, the
Login Banner Text field now accepts large character counts (greater than 40,000). (#35692)

l ClearPass will now send an Access-Reject containing an EAP-Message attribute encapsulating the EAP-Failure
(for example, NAK) when a fatal error occurs. (#35711)

Features Added in 6.6.2
l Support was added for SNMP version 3 Trap Receivers. To use this feature, go to Administration >

External Servers > SNMP Trap Receivers > Add and select one of the V3 options in the SNMP Version
drop-down list. Support was also added for SNMPv3 Traps and SNMPv3 Informs. SNMP V3 requires an
authentication key and private key to encrypt the Inform and Trap notifications. The protocol for
authentication can be MD5 or SHA hashing. The supported encryption algorithms are AES (128 bit) and
DES. SNMPv3 requires an SNMP Engine ID, and the default value for this ID has been set to
6620000004030662. This value can be changed in the Engine ID field at Administration > Server
Manager > Server Configuration > System Monitoring. To receive traps, the same value must be
configured at the trap receiver side. (#34449, #35815)

l Checks to validate OCSP URI entries are now supported. To use this feature, go to Administration >
Server Manager > Server Configuration > Service Parameters and select ClearPass IPsec service.
(#34740)

l SSL ciphersuite versions are now updated. The updated ciphersuites match those in ArubaOS, and are
consistent between FIPS and non-FIPS deployments. Currently supported ciphersuites are listed below; all
others are disabled. For information about a ciphersuite’s definition, refer to its corresponding RFC.
(#34843)

The following ciphersuites are supported:

n TLS_RSA_WITH_AES_128_CBC_SHA (RFC 3268)

n TLS_RSA_WITH_AES_256_CBC_SHA (RFC 3268)

n TLS_RSA_WITH_AES_128_CBC_SHA256 (RFC 5246)

n TLS_RSA_WITH_AES_256_CBC_SHA256 (RFC 5246)

n TLS_DHE_RSA_WITH_AES_128_CBC_SHA (RFC 3268)

n TLS_DHE_RSA_WITH_AES_256_CBC_SHA (RFC 3268)

n TLS_DHE_RSA_WITH_AES_128_CBC_ SHA256 (RFC 5246)

n TLS_DHE_RSA_WITH_AES_256_CBC_ SHA256 (RFC 5246)

n TLS_ECDHE_RSA_WITH_AES_128_CBC_SHA (RFC 4492)

n TLS_ECDHE_RSA_WITH_AES_256_CBC_SHA (RFC 4492)

n TLS_ECDHE_RSA_WITH_AES_128_GCM_SHA256 (RFC 5289)

n TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384 (RFC 5289)

n TLS_ECDHE_ECDSA_WITH_AES_128_CBC_SHA (RFC 4492)

n TLS_ECDHE_ECDSA_WITH_AES_256_CBC_SHA (RFC 4492)

n TLS_ECDHE_ECDSA_WITH_AES_128_CBC_SHA256 (RFC 5289)
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n TLS_ECDHE_ECDSA_WITH_AES_256_CBC_SHA384 (RFC 5289)

n TLS_ECDHE_ECDSA_WITH_AES_128_GCM_SHA256 (RFC 5289)

n TLS_ECDHE_ECDSA_WITH_AES_256_GCM_SHA384 (RFC 5289)

l The Apache SSLHonorCipherOrder Directive is now enabled. When a cipher is selected during a TLS
handshake, the preferred cipher available in ClearPass is used. (#34844)

l Additional log entries are now included for password policy violations and changes for both admin users
and local users at Monitoring > Event Viewer and Monitoring > Audit Viewer. Entries are included for
users whose accounts are locked due to account settings validations, and for users whose accounts are
enabled again after being locked out. To find these entries in the Event Viewer, you can filter for User
Account Settings in the Source column, or for Admin User Enable or Local User Enable in the
Category column. (#35399, #35401)

l All attempted upgrade, patch, and hotfix installations are now logged in the Event Viewer, including failed
attempts. (#35400)

l Diffie-Hellman (DH) Groups 19 (ECP_256) and 20 (ECP_384) are now included in the list of supported Diffie-
Hellman algorithms for IPsec connections. (#35485)

l Elliptic Curve Digital Signature Algorithm (ECDSA) certificates are now supported for IPsec connections.
(#35623)

Features Added in 6.6.1
l Admin users and local users can now be disabled when they exceed an allowed number of failed login

attempts. For example, if the allowed number is five, the user will be disabled after the fifth failed attempt.
The number of attempts you can specify can be from 1 to 100. When the configured number of failed login
attempts is exceeded for an admin or local user account and the account is disabled, you can reset the failed
attempts count to zero and re-enable all the account’s users. To use this feature: (#30517, #34538,
#30521, #34555)

n For local users, go to Configuration > Identity > Local Users > Account Settings > Disable
Accounts. To disable accounts, enter the number of allowed attempts in the Failed attempts count
field. To reset accounts, click the Reset button.

n For admin users, go to Administration > Users and Privileges > Account Settings > Disable
Accounts. To disable accounts, enter the number of allowed attempts in the Failed attempts count
field. To reset accounts, click the Reset button.

l Support was added for the Framed-IPv6-Address RADIUS attribute (IETF 168). The data type of this
attribute is IPv6Address. (#31912)

l Support was added for disabling the TACACS password-change option. A new cluster-wide parameter,
Disable Change Password for TACACS, is available on the Administration > Server Manager >
Server Configuration > Cluster-Wide Parameters > General tab. (#33424)

l Support was added to validate whether the OCSP extended key usage extension “keyPurpose” is set or not
during EAP-TLS authentication. If the value of the parameter is TRUE, EAP-TLS authentication will fail unless
the OCSP signing certificate also has OCSP “keyPurpose” set. If the value of the parameter is FALSE, the
OCSP signing certificate does not need to include “keyPurpose”. The default value is FALSE. To use this
feature, go to Administration > Server Manager > Server Configuration > Service Parameters tab.
(#33637)

l Support was added for configuring IKEv1 and IKEv2 SA lifetimes. To use this feature, go to Administration
> Server Manager > Server Configuration and click a server in the list. On the Network tab select
Create IPsec Tunnel. The form includes the IKE Version, IKE Lifetime, and Lifetime fields, with default



values populated. The Lifetime value (for Phase2 session keys) should always be less than or equal to the
IKE Lifetime value (for Phase1 session keys). (#34040)

l ClearPass now supports OCSP-based and CRL-based validations for IPsec connections that use certificates
for authentication. A Certificate Revocation List (CRL) will automatically be used if one is defined. To
configure an OCSP URL, go to Administration > Server Manager > Server Configuration and click a
server in the list. On the Service Parameters tab select ClearPass IPsec service and then configure a
value for OCSP URI. The certificate status is checked against the OCSP URL present in the certificate or the
configured OCSP URL. (#34137)

l Post-Auth-Session-Restriction configuration is more flexible and granular. Customers can restrict or blacklist
clients based on bandwidth consumed as well as on session duration, whichever is exceeded first. The
blacklisting hold-off period can also be configured (replacing the previous 24-hour limit). To use this feature,
go to Configuration > Enforcement > Profiles > Add. On the Profile tab, select the Session
Restrictions Enforcement template. (#34554)

Features Added in 6.6.0
l The Access Tracker now displays the results of unhealthy endpoints. Go to Monitoring > Live Monitoring

> Access Tracker, double-click on a request, and then click the Output tab. A new section, Posture
Evaluation Result, indicates which checks failed for the following health classes: (#12089, #29782,
#29783, #31887)

n AntiSpyware

n AntiVirus

n Disk Encryption

n File Check

n Firewall

n Installed Applications

n Network Connections

n P2P

n Patch Management

n Processes

n Registry Keys

n Services

n USB Devices

n Virtual Machines

n Windows Hotfixes

l ClearPass 6.6 is now able to extract the auth-session-id from CiscoAVPair VSA to use in Change of
Authorization (CoA). The username value is now used as the key when creating or querying a session in a
multi-master session cache. This makes it possible to send a CoA when the Calling-Station-ID value includes
the IP address format. To use this feature, in Policy Manager go to Configuration > Enforcement
> Profiles, copy the default [Cisco - Terminate Session] profile, and modify it to include the Cisco-AVPair
attribute. For more information on configuration, testing, and troubleshooting, refer to the Policy Manager
6.6 User Guide. (#17812)

l Cisco ASA requires the audit Session ID in the RADIUS Change of Authorization (CoA) message. ClearPass
extracts the audit-session-id from the VPN RADIUS authentication message. There are new properties to
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cache the Cisco-AVPair with the value that contains the audit-session-id. These properties can be used to
cache any custom attribute that contains the particular value. (#24403)

l Various new options such as protocol filters and port filters were added to the packet capture diagnostic
tool in the admin UI and the CLI. (#26091)

l The Trapeze RADIUS dictionary was updated. (#26478)

l Syslog support was added for Apache and Samba logs. Data in Apache access and error logs and SAMBA
windbindd logs can now be streamed to external syslog servers for third-party monitoring. To use this
feature, go to Administration > Server Manager > Log Configuration > System Level tab and enable
the Apache web server and Domain service log services. (#27123, #28347, #31316)

l Endpoint fingerprints functionality is updated to allow the administrator to either override the fingerprint
or add a new rule based on the learned attributes, creating a new entry in the Fingerprint dictionary. This
allows unknown endpoints to be categorized as desired with a new custom fingerprint. The device MAC
vendor is added by default when a new rule is created. (#27659)

l The new Ingress Event Engine enables ClearPass to process Syslog events from third-party devices to make
policy changes in realtime. For example: (#28446, #29415, #30254, #32451)

n A third-party device could signal to a ClearPass appliance to quarantine or block a user if the contents
indicate the presence of malware.

n Syslog dictionaries from leading vendors such as Palo Alto Networks, Checkpoint, Juniper Networks, and
Fortinet are included by default.

n Administrators may also create custom dictionaries on their own.

n An Event Requests filter is also included in the data filters at Monitoring > Live Monitoring >
Access Tracker > Select Filter, letting you filter for all event-based records.

n The Batch Processing Interval service parameter is available on the Service Parameters tab at
Administration > Server Manager > Server Configuration when Async network services is
selected for a server. This parameter lets you control the batch processing interval of Ingress Event
processing. The default interval value is 30 seconds. The allowed values are 10-300 seconds. Users
should be aware that, in order for changes to this service parameter to take effect, Async network
services must be restarted.

l Network Discovery is a new feature that facilitates the addition of network devices. It uses a configured
“seed network device” (typically a switch/router/controller) to discover endpoints and network devices. The
seed device is queried using configured SNMP credentials (see Configuration > Profile Settings > SNMP
Configuration). Network Discovery scans are initiated from Monitoring > Network Discovery > Start
Network Discovery Scan. The following information is read from the seed device: (#28448)

n SNMP information: The system name, vendor, system location, system contact, and system description
are captured from accessible network access devices.

n Connected endpoints: Information about endpoints connected to the network device (typically MAC
addresses of endpoints connected to switch ports). These are added as discovered endpoints.

n ARP table: Provides information about MAC > IP associations for endpoints that were seen by this device
recently. These endpoints are probed further in an attempt to profile them using all supported
mechanisms.

n Neighbor network devices: Other network devices connected to the seed device, as determined by
neighbor discovery protocols like Cisco Discovery Protocol (CDP) and Link Layer Discovery Protocol
(LLDP) (if enabled in your network).



Each of the discovered neighbor network devices is further queried as a seed device; this is repeated for
multiple levels in your network up to a specified scan depth parameter (maximum 3 levels).

Network devices discovered through a scan are available for review at Monitoring > Network Discovery
> View Discovered Devices. Discovered devices can be imported and added to Network Devices.

l Support for port bounce was added to Mobility Access Switches as part of their 7.4.0.3 release to facilitate
VLAN changes and profiling. To enable this support, the ClearPass RADIUS dictionary is updated to support
VSA 40 (Aruba-Port-Bounce-Host). The default Aruba Terminate Session attribute now includes this
entry. (#28532)

l The structure for endpoint attributes is now simplified to achieve better performance. The tips_
endpoints table has a new column attributes::JSONB. The attributes column holds information for an
endpoint in JSON structure. (#28642)

l ClearPass 6.6 provides a new option to disable log database backups during major upgrades. This reduces
the time to upgrade a node, especially with large log database sizes. Enable this option if you do not plan to
restore the log database post-upgrade. (#28841)

l The system morph-vm command is now supported for non-evaluation VM versions. It has been modified
to allow conversions from a lower capacity VM to a higher capacity VM only, using the new single virtual
machine installation image, in case the wrong VM is installed. Additional enhancements are described below:
(#28862, #30762)

n The restore step after rebooting was eliminated. This significantly reduces the overall time for the morph
operation, and the cluster setup is retained.

n Node service parameters whose defaults and range are set based on the model number are now
automatically reset in the local database when morphing a publisher, and on the remote publisher when
morphing a subscriber.

n During the first boot and morph command, additional warning messages are provided if system
requirements are not met.

For information about how to morph a VM more than once, see the “Installing or Upgrading to 6.6 on a
Virtual Appliance” Tech Note.

l A new service parameter, Additional time before session deletion from multi-master cache, was
added to the list of policy server parameters available at Administration > Server Manager > Server
Configuration. When configured, the policy server will wait the additional configured number of seconds
before deleting an entry from the multi-master cache. The default value is zero. This feature is useful in
wireless roaming situations where a client may roam from one controller to another and ClearPass may
receive an Accounting-Stop and Start in rapid succession, which can result in ClearPass mistaking which NAD
the client is attached to. (#29015)

l Thepg_stat_statements extension is now added to the ClearPass log collection. This feature tracks
the queries executed in the database, and provides daily log with PostgreSQL stats for debugging. It is
available under the system-load-monitor directory as part of collect logs. (#29115)

l The Infoblox RADIUS dictionary was added. (#29406)

l REST API support was added for the following ClearPass entities: (#29458)

n AdminUser

n AuthMethod

n AdminPrivilege

n Endpoint

n Insight/Endpoint
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n LocalUser

n NetworkDevice

n NetworkDeviceGroup

n ProxyTarget

n Role

n StaticHostList

l A new cluster-wide parameter, cli session idle timeout, lets clients configure the idle time
allowed during a CLI session before a session timeout. Any changes made to the idle time duration will go
into effect when a new session is opened. This option is available at Administration > Server Manager >
Server Configuration > Cluster-Wide Parameters > General tab. (#29797)

l SNMP support has been enhanced to include the hrProcessorTable. (#29857)

l A new RADIUS service parameter, Check the validity of intermediary certificates in the chain using
OCSP, was added to enhance certificate security. This feature is disabled by default. Enabling this feature
will put greater load on the system and is not intended for all customer use cases. (#30077)

l Support was added for disabling TLS 1.0 in the Web UI and the RADIUS server. A new cluster-wide
parameter, DisableTLSv1.0 support, is available on the Administration > Server Manager > Server
Configuration > Cluster-Wide Parameters > General tab. (#30078)

l The SNMP private management information base (MIB) in ClearPass now includes service start, stop, and
restart Traps, providing more granular control for handling these service actions. (#30186)

l ClearPass 6.6 adds the ability to profile endpoints based on commands executed over an authenticated
SSH or WMI session. Multiple SSH/WMI credentials can be configured per subnet under Configuration >
Profile Settings > SSH/WMI Configuration. When a new endpoint IP address is detected through one of
the endpoint discovery mechanisms (subnet scans, SNMP based ARP table read), the endpoint is probed to
determine if SSH (TCP port 22) or WMI (TCP port 135) is open. If a port is open, an attempt is made to
establish a session using configured credentials. If a session is established successfully, commands are
executed over the session to determine the endpoint’s device type. ClearPass 6.6 includes fingerprints to
profile endpoints based on device type determined from a SSH/WMI session. (#30260, #30319)

l ClearPass now supports public key-based SSH logins on a per-appliance basis. A new SSH Public Keys
option is available at Administration > Server Manager > Server Configuration > Network.
(#30286).

l A timeout option is now available in LDAP bind operations for AD/LDAP authentication sources. The value
for the Server Timeout option is configured on the General tab at Configuration > Authentication >
Sources ( LDAP/AD type ). (#30330)

l You can now provide port information when you specify a server name at Administration > External
Servers > Endpoint Context Servers. Port information should be provided in the format
“hostname:port”. (#30407)

l All references to HP are now renamed to HPE or Hewlett Packard Enterprise. (#30435, #30436, #30437,
#31830)

l At Configuration > Services > Reorder Services, reordering is now easier: Simply click a service to select
it, and then click again on the new position you want to move it to. (#30446)

l In previous versions of Policy Manager, users had to add or modify Admin access privileges by importing
XML files. ClearPass Policy Manager 6.6 provides a way to modify Admin access privileges in Policy Manager
and Insight via the Web UI. (#30449)



l All endpoints discovered on the network as part of profiling/network discovery are now added as Endpoint
entries even if Profiler cannot fingerprint the device. (#30466)

l Several enhancements were made in the areas of advanced password policy options for the local user
database. To use this feature, go to Configuration > Identity > Local Users > Password Policy. The
following options are available: (#30514, #30515, #30529, #30530, #30531, #30533)

n Disable account if Date exceeds: Local users are disabled at midnight when the current date exceeds
the configured date.

n Disable account if Days exceed: Local users are disabled when the specified number of days has
passed since the account was enabled.

n Disable user account after n days if password is not changed: The user’s account is disabled if
they do not change their password after the specified number of days.

n Password must be different from the previous n versions: The number of previous passwords
(including the default password) to compare to the new password the user enters. Values of 1 through
99 may be specified.

n Display reminder message after n days: Number of days after which a reminder to change the
password is displayed to the user. Values of 1 through 365 may be specified. This option is only for
displaying the reminder; it does not include the new-password prompt. This option is applicable only for
TACACS+ authentication.

n Check to force change password on next TACACS+ login: The local user must change their
password immediately after their next TACACS login. This option is available when you select an account
in the list at Configuration > Identity > Local Users.

l Any changes to attributes on the Modify Endpoint Context Server form are now reflected automatically.
(#30582)

l ClearPass 6.6 introduces a new feature that adds the ability to profile endpoints on the network based on
open TCP ports. The list of TCP ports to be probed during endpoint profiling is controlled by a new cluster-
wide parameter called Profiler Scan Ports. (#30844)

l All endpoints discovered from Network Devices with SNMP read enabled and via network discovery scan
are now automatically added as endpoints with Status=UNKNOWN. (#30845)

l A new service parameter, Connection Timeout, was added under Async Network Service to control
HTTP connection timeout scenarios when connecting to external servers in Generic HTTP Enforcement.
(#30941)

l If location details from Insight are available, they are now displayed at Configuration > Identity >
Endpoints on the Endpoint tab of the Edit Endpoint window. Location information includes the NAD and
port values for wired devices, and the access point and network SSID for wireless devices. (#30992)

l Thetips_audit table in the configuration database can now be accessed by the appexternal DB user.
This table contains audit records for Policy Manager configuration changes. (#31229)

l The Aruba RADIUS dictionary was updated. (#31436)

l New field groups are added to Insight Logs for Posture. APT (Application posture token) is used as part of
posture. Also a few fields have been removed from the Insight Logs authentication table and moved to the
endpoints table. New field groups have been created exclusively for Posture-related details. The new field
groups added to Insight Logs are as follows: (#31458)

n Posture Summary

n Posture Firewall Summary

n Posture AntiVirus Summary

ClearPass 6.6.4 | Release Notes Enhancements in Previous 6.6.x Releases | 65



66 | Enhancements in Previous 6.6.x Releases ClearPass 6.6.4 | Release Notes

n Posture Antispyware Summary

n Posture DiskEncryption Summary

n Posture Windows HotFixes Summary

Migration is not supported from versions of ClearPass prior to 6.6 if the Posture-related fields are
configured in Insight logs that were available in the authentication table.

Syslog filters with the old authentication columns configured from Insight logs are being disabled. Customers need to
manually update the syslog filters to use the new endpoint column. Notifications to this effect are displayed in
migration screens. Notifications are not displayed during the upgrade.

l Device name, device category, and device OS family profiling information can now be used with endpoint
context servers. (#31596, #31608)

Profiler and Network Discovery

Features Added in 6.6.3
l Support was added for Profiler rules based on Host:Services (operator contains substring) as identified by

Nmap. (#36167)

l ClearPass can now act as a flow collector to identify endpoint open port information for profiling.
Supported versions are NetFlow V5, V9 and IP Flow Information Export (IPFIX). (#36285)

l Support has been added to fetch service and process information using Windows Management
Instrumentation (WMI) from domain-joined Windows Devices. Active and inactive services and processes
can now be viewed in either Policy Manager or Insight. To use this feature: (#36427, #36491, #36492)

n First, go to the Administration > Server Manager > Server Configuration > Cluster-Wide
Parameters > Profiler tab, and set the Parameter Value to TRUE for the new Enable Endpoint
Posture scan using WMI parameter. This step enables fetching the information about the services
and processes running on the endpoint during a subnet scan, network discovery, or OnConnect
Enforcement.

n The fetched information can then be viewed in the user interface. To view it in Policy Manager, go to the
Configuration > Identity > Endpoints > Edit Endpoint > Fingerprints tab and review the Active
Services, Inactive Services, and Processes information. To view it in Insight, enter the MAC address in
the search field and then review the Active Services List, Inactive Services List, and Processes
information in the OnGuard widget.

Features Added in 6.6.2
l Support was added for using Nmap port scans to detect services running on a host. This information is used

to determine the device profile. Nmap port scanning is not enabled by default. To use this feature, go to
Administration > Server Manager > Server Configuration > Cluster-Wide Parameters and, on the
Profiler tab, set the Enable Endpoint Port Scans using Nmap parameter to TRUE. To see the services
and open ports information returned by the scan, go to Configuration > Identity > Endpoints, select an
endpoint in the list, and select the Fingerprints tab. (#35181, #35875)

Features Added in 6.6.1
l Address Resolution Protocol (ARP) probing can now be enabled for network discovery scans. Network

discovery uses Simple Network Management Protocol (SNMP) to read a variety of Management
Information Bases (MIB) from a Network Access Device. When this option is enabled, the scan will now also



probe all ARP entries available. To use this feature, go to Monitoring > Profiler and Discovery >
Network Discovery > Start Network Discovery Scan and select the check box in the Probe ARP
entries field. Users should be aware that when ARP probing is enabled, network discovery scans will take
longer. (#34169)

QuickConnect

Features Added in 6.6.0
l The Windows QuickConnect client can now be configured to bypass the proxy server configured on the

client during the Onboard enrollment process. The Bypass Proxy option is available at Onboard
> Deployment and Provisioning > Provisioning Settings > Onboard Client. (#28015)
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Chapter 7
Issues Fixed in Previous 6.6.x Releases

The following issues were fixed in previous 6.6.x releases. For a list of issues resolved in the 6.6.4 release, see
"What’s New in This Release" on page 29.

This chapter includes:

l "Fixed in 6.6.3" on page 69

l "Fixed in 6.6.2" on page 73

l "Fixed in 6.6.1" on page 78

l "Fixed in 6.6.0" on page 81

Fixed in 6.6.3
The following issues were fixed in the 6.6.3 release.

Guest

Bug ID Description

#36503 Hotel hotspot registration did not work if the hotel guest’s name included an apostrophe character ( ‘ ).

#36614 After updating to 6.6.2, SOAP API calls failed and the error “failed to load external entity” was shown in
the Application Log.

#36616 Hotspot invoice number sequences for online transactions were not retained during ClearPass
upgrades.

#36621 For social logins configurations, the Clever API account did not have privileges to access the full profile.
Now for social logins that use Clever, the account type is correctly set in the social_vip attribute.

#37062 The PHP version is now updated to 5.6.28.

#37224 The special value “_admin” was not recognized as a valid email address for sending guest account
expiration warnings.

#37228 AirPlay authorization did not work for some devices if they were added through a bulk upload using
comma-separated values (CSV).

#37154 Guest account expiration warning messages were not sent unless the ClearPass Guest Services
plugin configuration had been updated.

#37156 If an SMS message included special characters and an email address, some of the special characters
and the “@” character in the email address were removed from the received message. Support is now
added for configuring the character set used to communicate with an SMPP server. To use this feature,
go to Guest > Configuration > SMS Services > Gateways > Create new SMS gateway. In the SMS
Gateway field select SMPP v3.4, and then use the Message Encoding field to specify the message
encoding to use when sending messages to the SMPP provider.

Table 17: Guest Issues Fixed in 6.6.3
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Bug ID Description

#37335 Social logins failed with the error "Your username could not be determined" for the following vendors:
Bitbucket, Disqus, Fitbit, Tumblr, VK, and Xing.

#37337 Self-registrations that allow a timezone to be selected were setting the wrong value if the expire_time
date picker was used.

Table 17: Guest Issues Fixed in 6.6.3 (Continued)

Insight

Bug ID Description

#35738 Corrected an issue where the System Monitor widget on the Insight Dashboard did not display any data.

#36641 In Insight reports, a dynamic search for endpoint IP addresses sometimes took several minutes or failed
to complete. The autocomplete function is now removed from report filters and alert filters. Users
should enter the full IP address in the search field.

Table 18: Insight Issues Fixed in 6.6.3

Onboard

Bug ID Description

#36530 At Onboard > Certificate Authorities > Create new certificate authority, the error message
“NwaMdpsCertificate with id %2 not found” was displayed if either of the Elliptic Curve Digital
Signature Algorithm (ECDSA) options was selected in the Key Type field (either X9.62/SECG curve
over a 256 bit prime field or NIST/SECG curve over a 384 bit prime field).

#36594 If an Onboard Certificate Authority (CA) was successfully created as a Registration Authority type (RA)
that used an intermediate certificate, attempting to edit it after creation changed its status to “Chain
Incomplete” and it could not be used.

#36689
#36922

Corrected an issue where the Onboard license usage count was not updated for devices whose
certificate key was created by the
server, so the number of records shown in Onboard > Management and Control > View by
Certificate, Onboard Usage, and Policy Manager > Administration > Server Manager >
Licensing > License Summary > Used Count was incorrect.

#36701 When enrollments created by the standalone SCEP server were migrated to 6.6, serial numbers for
external device records were not correctly migrated. This resulted in a number of records in the
Onboard > Management and Control > View by Device list having no Device Name displayed.

#36853 In ClearPass 6.6.2, the SCEP server was unable to handle long input (1024 characters). This caused
Airwatch SCEP integration with ClearPass to fail, and the error message “Cannot parse SCEP message:
E1: scep.c:792: error while reading msg” was shown in the Application Log at ClearPass Guest
> Administration > Support.

#36871 Attempting to import an intermediate Certificate Authority (CA) failed and the error message “Fatal
Application Error: Cannot pass parameter 1 by reference” was displayed.

#36958 Onboard certificate migration failed if some fields contained embedded null characters.

#37153 The Onboard Registration Authority CA did not accept responses from an upstream SCEP server if the
server returned multiple CA certificates.

Table 19: Onboard Issues Fixed in 6.6.3



OnGuard

Bug ID Description

#35530 ClearPass was not able to select the correct WebAuth service based on the Host:OSType attribute. This
applied to the Persistent and Native agents only; this attribute is not applicable to the Java-based
Dissolvable Agent.

#35745 Trying to uninstall the ClearPass OnGuard Unified Agent failed if the Windows Event Viewer was open.

#35950 When a quarantine message was configured in the HTML with an anchor tag, the ClearPass OnGuard
Unified Agent for Mac OS X did not display the message as a hyperlink, and displayed the tag instead.
Anchor tags are now supported for quarantine messages.

#36023 The VIA component of the ClearPass OnGuard Unified Agent for Mac is now updated to Mac VIA 3.0.1.
For information about the features and enhancements available in Mac VIA 3.0.1, refer to the Aruba VIA
3.0.1 Mac Edition Release Notes available on the Support site (support.arubanetworks.com) at
Documentation > Software User & Reference Guides > Aruba VIA > Release Notes > macOS.

#36514 Auto-update of the ClearPass OnGuard Unified Agent for Windows sometimes failed for non-
administrator users.

Table 20: OnGuard Issues Fixed in 6.6.3

Policy Manager

Bug ID Description

#35190
#35192

Duplicate updates were sent to Palo Alto Networks if client authentication occurred on two different
appliances within a one-hour interval.

#35573 ClearPass sometimes dropped packets and displayed the error message “nf_conntrack: table full,
dropping packet.” The size of the connection tracking table is now increased from the previous default
value of 65,563 to the following values:
l CP-VA-500 = 262,144 (256 K)
l CP-VA-5K = 262,144 (256 K)
l CP-VA-25k = 524,288 (512 K)
l CP-HW-500 = 262,144 (256 K)
l CP-HW-25K = 524,288 (512 K)
l CP-HW-5k = 262,144 (256 K)

#35732 The Policy Manager Dashboard did not display graphs in the System CPU Utilization widget or the
Request Processing Time widget due to a time zone issue. ClearPass is now updated to use the latest
time zone information.

#35733 Users should be aware that, for used disk space calculations, the displayed values shown in the user
interface at Monitoring > Live Monitoring > System Monitor do not match the free disk space values
shown in the CLI or through the snmpwalk application.
Disk usage can be monitored three different ways: 
l Through the System Monitor page. The value displayed on this page shows used space.
l Through the CLI show sysinfo command. The value displayed this way shows the free space.
l Through snmpwalk. The value displayed this way also shows the free space.
When the used space displayed in the System Monitor is subtracted from the total disk size, it does not
equal the free space indicated by the CLI and SNMP methods. This is because the used space value does
not take into consideration the blocks of disk space that are reserved for the root user, but the free
space value does include this.

#35737 Admin users were not able to copy a network device from the table summary at Policy Manager >

Table 21: Policy Manager Issues Fixed in 6.6.3
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Bug ID Description

Configuration > Network > Devices.

#35743 RADIUS authentications failed if the service name was more than 63 characters long. At Policy
Manager > Configuration > Services > Add, the length of the entry in the Name field for a
RADIUS Proxy type is now limited to 63 characters.

#35787 Updating a password for a PSK-based IPsec tunnel caused the tunnel connection to fail.

#35862 TACACS authentications failed and the error message “(error=28) Timeout was reached” was displayed.
This was due to an out-of-memory condition that occurred if the TCP protocol was configured and
messages could not be delivered.

#35867 A successfully established IPsec tunnel was incorrectly described as failed on the Monitoring > Event
Viewer > System Event Details form. ClearPass now correctly displays the status details for an IPsec
tunnel connection.

#35930
#36301

ClearPass periodically stopped sending updates to Palo Alto Networks (PANW) firewall. Data is now sent
as a payload instead of URL-encoded. This change allows a larger Host Intrusion Prevention (HIP) update
to be posted to PANW and the register update to be skipped in case device profile information is
missing.
If the Palo Alto Networks integration was already configured prior to upgrading to ClearPass 6.6.3, a
minor modification needs to be made to the UserID Post URL. Go to Administration > External
Servers > Endpoint Context Servers and select any applicable Palo Alto Networks firewalls. Remove
the &cmd={cmd} from the the UserID Post URL so that it only shows the following:
https://{server_ip}/api/?type=user-id&action=set&key={key}

#35982 For an IPsec tunnel established with ClearPass, the Windows 2008 server might time out and abruptly
terminate the connection if there is no traffic over the tunnel for more than five minutes.
Users should be aware that this is the expected behavior with Windows 2008. To avoid it, under HKEY_
LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\IPSec use the registry setting SAIdleTime to
define the allowed idle-time duration.

#36051
#36323

After updating to 6.6.1 or 6.6.2, the serial console was not accessible on hardware versions of ClearPass.

#36059 After the zone was changed for a Network Access Device (NAD) the Monitoring > Audit Viewer form
correctly showed the modification but it also incorrectly showed the community string as having been
changed.

#36062 A deleted CRL was cached and still showed in the revocation list. Users should be aware, however, that
deleting a CRL will restart the IPsec service.

#36141 Fingerprints were not updated during a cumulative patch update, and a status check had to be
performed after the update in order to get the most recent fingerprint versions. The latest fingerprints
are now included in the patch update process.

#36150 The RADIUS server was not able to process requests for some time (as much as an hour) after a
configuration change and displayed the error message “Client couldn’t complete EAP transaction.”

#36194 Corrected a cluster join issue where trying to add a new node to an existing cluster failed and displayed
the error message “Setting up subscriber failed”. This was caused by manual deletion of the default zone
in the cluster. As part of the fix, manual deletion of the default zone in a cluster is now blocked. This is
because the newly added nodes in the cluster are assigned to the default zone, so the default zone must
be retained.

#36197 ClearPass was able to accept weak ciphers in an IPsec connection. Now the peers must support all the

Table 21: Policy Manager Issues Fixed in 6.6.3 (Continued)



Bug ID Description

configured algorithms in order for an IPsec connection to succeed.

#36237 MSCHAPv2 authentications against Active Directory sometimes failed with an “AD status: Access
denied” error.

#36294 In EAP authentication, the RADIUS service frequently crashed and restarted if the inner identity had a
null value.

#36398 Trying to parse a samba configuration file failed if any line in the file was long (greater than 1024
characters). The maximum read line length is now increased to 4096.

#36401 The Access Tracker took a long time to show individual records the first time it was accessed after login.

#36487 ClearPass added extra Message-Authenticators in the RADIUS packet if an external RADIUS server was
used as the authentication source.

#36535 Timestamps on Ingress Events engine requests were logged in the database in Universal Time Code
(UTC) instead of the local system’s time zone.

#36557 After updating to 6.6.2, a modification to an enforcement policy or profile displayed an error message if
migration of the agent profile was not successful.

#36626 The cpass-radius-service crashed and restarted if a username was not present in the Access-Request
and both the Inner-Identity and Outer-Identity were different.

#36775 Offline license activation failed in ClearPass 6.6.x versions.

#36843 Corrected an issue where the IPsec tunnel frequently disconnected.

#36859 ClearPass is now updated with the latest Universal Time Code (UTC) time zone information for all
countries.

#37089 Events were not displayed in the Event Viewer if SSH connections to ClearPass appliances were
attempted using unsupported keyed-hash message authentication code (HMAC).

#37543 If the Palo Alto Networks Panorama server had multiple firewalls listed under it, ClearPass tried to send
the update to multiple targets in single post.

Table 21: Policy Manager Issues Fixed in 6.6.3 (Continued)

Fixed in 6.6.2
The following issues were fixed in the 6.6.2 release.

CLI

Bug ID Description

#35166 CLI logs sometimes grew too large, causing a CP-HW-500 server to crash. Pre-checks are now added to
prevent this scenario.

Table 22: CLI Issues Fixed in 6.6.2

ClearPass 6.6.4 | Release Notes Issues Fixed in Previous 6.6.x Releases | 73



74 | Issues Fixed in Previous 6.6.x Releases ClearPass 6.6.4 | Release Notes

Cluster Upgrade and Update

Bug ID Description

#34962 ClearPass patches downloaded from the Software Updates portal were shown on the Administration
> Agents and Software Updates > Software Updates > Cluster Update interface but could not be
installed.

#35318 Cluster-wide patch or skin installations were not removed from the log files.

Table 23: Cluster Upgrade and Update Issues Fixed in 6.6.2

Guest

Bug ID Description

#35327 In custom fields, the allowed generators for Initial Value were missing GeneratorFromSession.

#35580 Corrected an issue where, when trying to filter for a guest account, an invalid Role ID data could cause
database query errors in ClearPass Guest.

#35639 Expired accounts were not caught if the Pre-Authentication was set to Local.

#35863 The PHP version is now updated to 5.6.25.

#36002 After upgrading to 6.6, exporting guest accounts in Comma-Separated Value (CSV) format failed with
database errors due to issues with the way the guest account Create Time attribute was stored.

#36005 If multi-factor authentication was configured with a device-first workflow, first-time authentications
asked for the account password at two different times.

#36006 Certain configuration forms could not be viewed by read-only operators even though they had
permission to view them, and the users were logged out.

#36008 The “Created” time was incorrectly displayed as “1969-12-31 16:00” when importing a Guest user
accounts list from a Comma-Separated Value (CSV) file. Data imported in CSV files now supports field
formats similar to those in the GUI forms, and no longer needs to be uploaded in its native format.

Table 24: Guest Issues Fixed in 6.6.2

Onboard

Bug ID Description

#35451 Devices running Windows 8 or higher could not connect to the secure SSID after onboarding if the TLS
client certificate private key was configured to be generated by Onboard.

#36001 Corrected an issue where the Onboard license count was not being updated.

Table 25: Onboard Issues Fixed in 6.6.2



OnGuard

Bug ID Description

#34400 The ClearPass OnGuard Unified Agent for Windows failed to read the Windows Hotfix list and displayed
the error ”WBEM_E_SHUTTING_DOWN (0x80041033 or -2147217357)”.

#34594 The spelling of “ClearPass Agent Controller Service” is now corrected in the Windows OnGuard Unified
Agent logs.

#35145 The ClearPass OnGuard Unified Agent checked for Windows Updates every hour even if Windows
Security Health Validator was not configured.

#35147 The ClearPass OnGuard Unified Agent sometimes took a long time to collect health information on a
Windows 8 Operating System.

#35188 The Windows OnGuard Unified Agent did not prompt for a password if a wrong password was entered
or if authentication failed.

#35595 The ClearPass OnGuard Unified Agent failed to read the DAT file time and DAT file version of Norton
Security with Backup 22.7.0.76 AntiVirus.

#35620 A RADIUS disconnect or Change of Authorization (CoA) was not triggered after quitting or exiting the
ClearPass OnGuard Unified Agent. Now, if a post-authentication enforcement profile is configured to
disconnect OnGuard when the OnGuard session ends, ClearPass sends a CoA and disconnects the
client when OnGuard is down for more than five minutes.

Table 26: OnGuard Issues Fixed in 6.6.2

Policy Manager

Bug ID Description

#28534 Corrected an issue where IPsec did not work unless ClearPass was restarted.

#30937 On the Software Updates portal, an Uninstall button was available for cumulative and point patch
updates. The Uninstall button is now available only for skin files.

#33359 In some situations (for example, VIA authentication), the controller set the value of the Calling-Station-Id
attribute to 000000000000 and ClearPass treated it as a valid MAC address, which caused VIA + Health
check to not work. Now if the client’s MAC address is all zeros, it is considered an invalid address, and
the RADIUS server does not add any computed attributes for the MAC address. The authentication
should succeed. Instead of the MAC address, the username must be treated as a session entry in the
Multi-Master Cache.

#34134 In the Fingerprints dictionary, a forward slash ( / ) was not an allowed character when adding or
updating values for a device Category, Family, or Name, and the error message “’Category contains
special characters other than -, _, {}, [], (), period and space” was displayed. The forward slash is now
one of the allowed special characters.

#34338 After upgrading to ClearPass 6.6.0, some custom admin privileges did not work and ClearPass screens
were blank for users with custom admin privileges that included the Monitoring > Live Monitoring >
Endpoint Profiler attribute.

#34409 The TipsAPI for the GuestUser entity missed <EntityMaxRecordCount> in the response. Two other
attributes, “sendEmail” and “sendSms”, are now added to the <GuestUser> element in 6.6.0. Users
should be aware that ClearPass 6.6 is the last release that will support certain TipsAPI (XML), Guest
SOAP APIs, and Guest XML-RPC APIs. ClearPass 6.6 now includes a variety of RESTful APIs to replace

Table 27: Policy Manager Issues Fixed in 6.6.2
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Bug ID Description

these legacy APIs. We recommend that you migrate to the appropriate RESTful API as soon as possible.
For more information, see"ClearPass 6.6 Deprecation Notice" on page 11.

#34823
#34946

After upgrading to 6.6, the Event Viewer showed error messages such as “Battery put failed err:Post”,
”Profiler ip<address> unstable”, or “High iowait(25)”. The Event Viewer now only generates these
warnings if an operation fails three times in a row within 15 minutes.

#34845 ClearPass was unable to complete an Active Directory (AD) connection using TLS 1.2. The TLS 1.2
protocol is now supported for AD-over-SSL connections.

#34853 Multiple values were not allowed for the List data type in the 6.6.0 release. The Allow Multiple field is
now restored to the Add Attribute and Edit Attribute forms for List attributes.

#34890 If an attribute name was edited at Administration > Dictionaries > Attributes, the name was not
updated in Enforcement Profiles.

#34925 The Apache Struts version is now upgraded to 2.3.29 GA.

#35031 When trying to authenticate with an HTTP authorization source configured for a service, authentication
failed and the alert “RADIUS: Service Categorization failed\nCannot send request to Policy server” was
displayed. Unsupported JSON objects are now handled correctly.

#35062 Authentication failures occurred if the RADIUS server or policy server processes reached the maximum
allowed number of open files, especially if a large number of authentication or authorization sources
were configured (65+). The “max open file handlers limit” (ulimit -n) is now increased to 100,000 for
RADIUS server and policy server processes.

#35075 The Apache Tomcat version is now upgraded to 7.0.70.

#35109 Support for DES and IDEA cipher suites is now removed.

#35113 Corrected an issue where a Network Administrator could create a local user with Super Administrator
privileges.
Administrators can only create new admin users with privileges that are the same as or lower than their
own.
Administrators can only create new admin privileges that are the same as or lower than their own.
The default Network Administrator privilege has read-only access to certain configuration pages, such
as:
l Local Users
l Service configuration
l Start-Here
l Role-mapping
l Enforcement Policy
l Enforcement Profile

#35193 In rare cases, local users were disabled even though the correct username and password were used. A
local user’s failed login attempts are now counted only for the PASSWORD_MISMATCH, PASSWORD_
NOT_AVAILABLE, and USER_AUTHENTICATION_FAILED error codes.

#35202 Exceeding the default threshold values for CPU load averages caused the monitoring server to trigger
”System Error” SNMP alerts. The default settings for the CPU load-average service parameters are now
dynamic based on the number of CPU cores. This ensures that alerts are based on appropriate
thresholds for each system’s CPU usage limits.

#35216 The Event Viewer did not show audit logs for IPsec connections. Detailed information is now shown
whenever an IPsec tunnel is brought up or down.

Table 27: Policy Manager Issues Fixed in 6.6.2 (Continued)



Bug ID Description

#35222
#34694

After upgrading to 6.6.0, the Event Viewer showed a “High iowait” error. The CPU and memory statistics
were collected every 15 minutes and the value of memory and iowait at that instant was compared to
the configured threshold. ClearPass now collects CPU and memory statistics every five seconds and
computes the average for iowait and free memory over a ten minute period. The average value is
compared to the threshold to generate alerts.

#35236 A RADIUS server or HTTPS server certificate could be installed even though the signature byte of the
certificate hash had been modified.

#35238 An IPsec tunnel was established even if OCSP or Certificate Revocation List (CRL) validation failed. Strict
CRL policy can now be enabled or disabled. To use this feature, go to Administration > Server
Manager > Server Configuration > Service Parameters and select ClearPass IPsec service. In the
Strict CRL Policy field, select yes (the default value is no). When this option is enabled, a fresh CRL
must be available in order for a peer connection to succeed. Whenever the Strict CRL Policy value is
modified, existing IPsec tunnels that use Public Key Authentication will be brought down and then
brought up again.

#35254
#35458

Corrected an issue where Checkpoint integration failed. All Checkpoint action attributes are now
correctly substituted.

#35259 JQuery libraries are now updated to 1.11.1 for Policy Manager and 2.1.4 for Insight.

#35291 An IPsec connection could not be established between ClearPass and a Windows 2008 server using PSK
and IKEv1.

#35459
#35460
#35461
#35524

Users should be aware of the following support changes for IPsec connections. These encryption
algorithm changes apply to both FIPS mode and non-FIPS mode:
l ClearPass no longer supports using the 3DES encryption algorithm for IPsec connections. Existing

systems that have 3DES configured will be updated to AES-128.
l ClearPass no longer supports using AES-192 for IPsec connections. Existing systems that have AES-

192 configured will be updated to AES-128.
l ClearPass no longer supports using Diffie-Hellman (DH) Group 1 or 2 for IPsec connections. Existing

systems that have DH Group 1 or 2 configured will be updated to DH Group 5.
l ClearPass no longer supports using IKEv1 in Aggressive Mode for IPsec connections. Existing

systems that have Aggressive Mode configured will be updated to Main Mode.

#35495 In ClearPass 6.6.0 and 6.6.1, the configuration database used date and time in the UTC (GMT) time zone
instead of using the system’s configured time zone, and the date and time were also displayed in UTC in
the [Time Source] authentication source and external SQL queries. ClearPass 6.6.2 now behaves like
ClearPass 6.5 and earlier versions, where the configuration database and [Time Source] use the
system’s configured time zone.

#35500 During ClearPass license activation, some workflows did not perform certificate validation for the
Activation Server Certificate.

#35532 The Ingress Events service did not run as expected after a system update.

#35715 The accounting records calculation for input and output octet bytes was incorrect if the Acct-Output-
Gigawords attribute was also present.

#35747 Corrected an issue where acct_start and interim_update accounting information was not
updated. The accounting event’s timestamp now records the time filed in milliseconds.

#35758 After installing a patch update on the Software Updates portal, the Reboot button did not initiate a
system restart.

#35812 The Install Update window on the Software Updates portal did not include an Uninstall button for
Guest skins that were installed before ClearPass 6.6.1.

Table 27: Policy Manager Issues Fixed in 6.6.2 (Continued)
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Fixed in 6.6.1
The following issues were fixed in the 6.6.1 release.

Guest

Bug ID Description

#33620 For self-registrations configured to interact with a FIAS-based hotel Property Management System
(PMS), a room page was not created when the transaction processor was changed from non-PMS to
PMS.

#34174
#34642
#34968

The PHP version is now updated to 5.6.23. This includes fixes for CVE-2013-7456, CVE-2016-3074,
CVE-2016-5093, CVE-2016-5094, and CVE-2016-5096.

#34464 Corrected an issue with guest self-registration pages where, when a new account was successfully
created, the application logs showed the error “  relation "tips_guest_user_tag_mappings" does not
exist”.

#34468
#34475

Extension installations did not honor the configured list of trusted certificates. In certain circumstances
this could have led to the extension installation failing with an "unknown issuer certificate" error.

#34479 Corrected an issue with Guest Self-Registrations configuration where, after enabling sponsorship
confirmation, editing and saving Login Delay or NAS Vendor Settings disabled the sponsorship
confirmation.

#34483 In Configuration > Receipts > Digital Pass Templates, uploading a certificate along with a
passphrase failed with the error message “Unable to handle request at this time”.

#34735 ClearPass Guest could not send emails over TLS to servers with custom certificates.

#34794 The shortcut to include guest pages and content URLs was missing from some HTML configuration
areas.

#34810 Deleting a Web page or a pass template displayed the error message “Row query failed: ERROR:
column o.object_id does not exist”.

#34818 When a device’s locale settings used a comma separator in currency, there were problems posting
charges to the guest’s account and some room charge communications had formatting errors.

Table 28: Guest Issues Fixed in 6.6.1

Insight

Bug ID Description

#33255 In the Auth Trend report, the guest authentication counts shown for certain days in the 1 month
section did not match the authentication counts shown for the same days in the 1 week section. The
weekly graph widget is now removed.

#33585 While creating a report with the Notify by Email or Notify by SMS fields selected but where the email
or phone number for the notification were not provided, the report could be saved and no error
message was displayed about the missing information.

#34097
#34533

A user with the Super Administrator role could not log in to Insight with their Active Directory (AD)
credentials if the Full Access option was configured in the operator profile.

Table 29: Insight Issues Fixed in 6.6.1



Onboard

Bug ID Description

#33822
#34465

If a device limit was set, Onboard enrollment failed with the error “Fatal Application Error: Call to
undefined method....”

#34466 On the View by Username and View by Device pages, devices could not be deleted and the
message “Error: 500” was displayed.

#34467 After upgrading to ClearPass 6.6.0, selecting Onboard > Management and Control > View by
Username displayed the error message “Row query failed: ERROR: column "object_id" does not exist”.

#34469 Corrected an issue where device expiration notifications were not sent.

#34471 When upgrading to ClearPass 6.6.0, Onboard configurations that used an ECDSA CA certificate could
not be migrated and caused the upgrade to fail.

#34473 When upgrading from ClearPass 6.5.5 to 6.6.0, Onboard migration failed.

#34476 At Onboard > Management and Control > Usage, the License Usage description incorrectly stated
that a rolling average was used. It is now correctly described as a count.

#34478 If a custom trusted certificate was specified during Onboard enrollment, the error message “OnBoard
server returned HTTP Status code - 500” was displayed and onboarding failed.

#34480 After saving settings migrated from earlier versions, a user logging in to Onboard was redirected to
securelogin.arubanetworks.com instead of to the Onboard workflow.

#34481 In the Self-Service Portal, devices were correctly displayed in the list but the options row was not
visible, so users could not delete a device or perform other actions even if they had full-access
permissions.

Table 30: Onboard Issues Fixed in 6.6.1

OnGuard

Bug ID Description

#26085 Editing the ClearPass Linux Universal System Health Validator plugin cleared the default services
configuration data.

#26276 On Mac OS X 10.10, the ClearPass OnGuard Unified Agent ‘s VIA component failed to download the
connection profile when the tunnel was established, and the log window showed the error
“Configuration download... failed”.

#27602 The ClearPass OnGuard Unified Agent failed to return health-check data over a VPN tunnel if the agent
was installed on a client running MAC OS X 10.10 and used Kaspersky AntiVirus software.

#30573 The ClearPass OnGuard Unified Agent now supports Encrypted Locations checks for FileVault 10.11 on
Mac OS X 10.11.

#33862 The ClearPass OnGuard Unified Agent categorized Check Point VPN Adapter as WIRED or OTHER.

#33865 The ClearPass OnGuard Unified Agent did not use the value of LogoutBounceDelay if the OnGuard
Agent was closed or killed.

#34144 On Mac OS X, if a VPN was connected when the ClearPass OnGuard Unified Agent was uninstalled, the
VPN interface was not removed and the client remained connected to the VPN interface.

Table 31: OnGuard Issues Fixed in 6.6.1
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Policy Manager

Bug ID Description

#28399 In OnGuard Settings, it was not clear which IP address was applied to the ClearPass OnGuard Unified
Agent. At Administration > Agents and Software Updates > OnGuard Settings > Policy Manager
Zones, the Default ClearPass Server IPs field for a Policy Manager zone now shows the correct IPs
when both the data and management ports are configured.

#32088 Network discovery sometimes did not add some devices to the endpoints table if they did not return a
MAC address.

#32759 During a bulk import of Network Access Devices (1000+), a backend process sometimes took a long
time to complete even though the user interface indicated the import had completed.

#33312 If authentication latency to Active Directory was greater than 30 ms, a specific process thread used by
the TACACS service to internally communicate with the authentication service might have been
overwhelmed using the default static value. A new option, TACACS+ HTTP Thread Pool Size, lets you
adjust the maximum number of simultaneous requests as needed within a range of 5 to 200. This option
is available at Administration > Server Manager > Server Configuration > <server name> >
Service Parameters > Tacacs server.

#33353 The postauth do_expire action blacklisted users based on exceeded session counts and agent
connection checks. Users monitored under session restriction are now blacklisted only if the bandwidth
usage or session duration exceeds the configured limit, if any, and not in any other case.

#33472 The libssh2 version is now upgraded to libssh2-1.4.2-2.el6_7.1.x86_64. This includes fixes for
CVE-2016-0787.

#33551 The RADIUS service stopped if a 24th authentication source was added to a service using a static host
list. The warning message “No. of Authentication Sources cannot exceed 23" is now displayed if the user
attempts to add more than 23 authentication sources.

#33635 After morphing a virtual machine (VM), the total disk space shown in the Monitoring > Live Monitoring
> System Monitor dashboard in Policy Manager was incorrect. This value is now consistent in the CLI
and the System Monitor dashboard in both Policy Manager and Insight.

#33725 Corrected an issue where low disk alerts and low memory alerts were not logged.

#33736 After morphing a virtual machine (VM), the total memory shown in the System Monitor dashboard in
both Policy Manager and Insight was incorrect. The value is now consistent in the CLI and System
Monitor dashboard in both Policy Manager and Insight.

#33741 After adding additional memory in a virtual machine (VM) image, the total memory shown in the
Monitoring > Live Monitoring > System Monitor dashboard in Policy Manager was incorrect.

#33843 Corrected an issue where a memory leak was triggered when a RADIUS server configuration was
reloaded.

#33926 The PostgreSQL version is now upgraded to 9.4.8. This includes fixes for CVE-2016-0773.

#33928
#33958
#33959
#34021
#34243

This release includes fixes for CVE-2016-2118, CVE-2016-2034, and CVE-2016-2107.

#33956 Sending Syslog messages to multiple TCP-enabled Syslog servers did not work. ClearPass now allows

Table 32: Policy Manager Issues Fixed in 6.6.1



Bug ID Description

sending Syslog messages to any number of TCP or UDP-enabled Syslog servers.

#33964 Session Log syslog filters (if configured) caused high consumption of CPU and System resources. Query
generation is now optimized to fix this issue. Users should be aware that some attributes or rows might
be missed if tables are not updated.

#34014 The Access Tracker did not show the TACACS Authentication request details if its corresponding
Authorization requests did not contain any details.

#34057 On ClearPass ESXi 6.0 (and later) virtual machines, an operating system process repeatedly tried to
respawn a process for ttyS but failed because serial ports were not present.

#34129 Corrected an issue where a high volume of authentication requests and EMM/MDM updates resulted in
periodic authentication failures.

#34130 Updating usernames through a policy did not update them properly in the Multi-Master Cache, which
caused Change of Authorization (CoA) to fail with HPE ArubaOS-Switches running 16.02. The Policy
Server now posts the updated username to the Multi-Master Cache, and the value is properly sent in the
CoA request.

#34153 When creating a new 802.1X service using a template, the service configuration failed and displayed the
error message “Error in processing request. Please retry”.

#34223 TACACS authentications failed if there were null parameter values, and displayed the message “Internal
error in performing authentication”.

#34447 A new root certificate for the Activate server could not be validated. The CN=GeoTrust Primary
Certification Authority – G3 root certificate is now added to the default trust list.

#34615 Corrected an issue where the NETBIOS name was not appended in the user ID updates sent to Palo Alto
Networks (PANW) if UserPrincipleNamewas used to authenticate the user and modified using the
RADIUS username enforcement profile.

#34639
#34824

When the endpoint profile fingerprint file was updated, the error message “Failed to update fingerprints
from ClearPass Portal (Online)” was displayed in Insight Alerts.

#34662 Configuring ClearPass as a TACACS authentication server created a loop and caused high CPU
utilization (99%) on the Network Access Device if the device continuously sent an empty password.

#34728 With simultaneous-limit checking enabled, ClearPass disconnected a user as having exceeded the
configured number of simultaneous sessions even though the user had fewer active sessions than the
limit.

Table 32: Policy Manager Issues Fixed in 6.6.1 (Continued)

Fixed in 6.6.0
The following issues were fixed in the 6.6.0 release.

CLI

Bug ID Description

#29929 Users should be aware that ClearPass no longer supports the following CLI commands:
l service activate
l service deactivate

Table 33: CLI Issues Fixed in 6.6.0
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Dissolvable Agent

Bug ID Description

#29513 The native dissolvable agent did not work properly on Chrome 42.x or higher, and the guest page
failed to detect whether the ClearPass OnGuard Unified Agent was installed. The ClearPass OnGuard
native dissolvable agent (WebAgent) is now supported on Chrome Browser 42 and higher versions.

Table 34: Dissolvable Agent Issues Fixed in 6.6.0

Endpoint Context Servers

Bug ID Description

#27704 Endpoint attributes were not deleted if a device was reset in Aruba Activate. Endpoint attributes are now
deleted from the ClearPass appliance when the corresponding attributes are deleted in the MDM
context server.

#31242 Endpoints from MobileIron were not discovered if any of the attribute values were empty.

Table 35: Endpoint Context Server Issues Fixed in 6.6.0

Guest

Bug ID Description

#18700 An out-of-date message could be displayed in the List Accounts view.

#27847 Corrected a potential Cross-Site Scripting (XSS) issue when using the nwa_mdps_config smarty
function.

#28480 The SMS provider selection could not be overridden in a self-registration.

#28877 Corrected some issues with performance when there is a large number of accounts. Tag lookup
performance is now greatly improved in guest management queries.

#28974 Corrected some issues with syntax checking for template scripts.

#29027 The application would hang if an overly restrictive password configuration was chosen.

#30154 Date pickers were not rendered correctly when using the Galleria skin.

#30304 Deleting a guest account sometimes took as long as five minutes. This was observed on a CP-HW-5K
system after upgrading to 6.5, following an upgrade path of 6.1.4 > 6.2.6 > 6.5.2.

#30840 The “Permit login on validation error - validation errors will be logged” option is now removed from
Security Hash drop-down list on the Configuration > Pages > Web Logins form or the Guest Self-
Registrations > Advanced editor form. If you had this option set, please re-save the configuration
with a valid option.

#30842 Corrected some visual issues with the color picker controls that could occur with certain skins.

#31335 For Web logins configured to require a Universal Access Method (UAM) challenge, the challenge was
not sent.

#31386 Forcing a default destination in a Cisco Wi-Fi environment did not redirect to the specified address.

Table 36: Guest Issues Fixed in 6.6.0



Bug ID Description

#31450 The MAC address was not normalized during import. MAC devices imported into Guest now format the
MAC to the system standard.

#31664 Emails were generated incorrectly of the No Skin option was configured.
Users should be aware that emails sent with one of the No Skin options might not display correctly in all
email clients.

#31745 With a Ruckus controller configured, ClearPass did not send the proper POST URL information to the
client for captive portal authentication. Login configuration parameters for Ruckus Wireless have been
adjusted.

#31934 Partial configuration backups could fail if not all selections were made in the list of items to back up.

#32292 Users should be aware that the default privileges for the Help Desk operator profile have been
changed in this release. The Manage Customization and Manage Print Templates privileges are
now set to Read Only instead of Full. System administrators should review their Help Desk operator
profile and update the privileges accordingly.

#32735 The _browser=1URL parameter was not compatible with some social login providers.
If you have configured social logins, please review any URL access control lists within the application
configuration. URLs prior to ClearPass 6.6 required the ?_browser=1 parameter to be appended.
That argument must now be removed.

#33071 HTTP User Agent profiling was not collected for Guest Web pages other than Web login pages. Guest
Web pages now correctly populate attributes and record client profile information.

#33329 The PHP version is now updated to 5.6.19. This includes fixes for CVE-2015-3152, CVE-2015-2325, CVE-
2015-2326, CVE-2015-3414, CVE-2015-3415, CVE-2015-3416, CVE-2015-1351, and CVE-2015-1352.

#33650 When using XML-RPC, API responses were in the ISO-8859-1 character set instead of UTF-8. All XML-
RPC responses are now encoded in UTF-8.

Table 36: Guest Issues Fixed in 6.6.0 (Continued)

Insight

Bug ID Description

#30384 If there was a session timeout while logging in to Insight, the login failed and the message “Bad Request
- The browser (or proxy) sent a request that this server could not understand” was displayed. Session
timeouts now redirect the user to the login page to reauthenticate.

#31227 The disk usage displayed in Policy Manager at Monitoring > System Monitor > Disk Usage did not
match the disk usage displayed in Insight at System Monitor > Disk Usage.

#32345 If an alert was configured with the time interval in hours, the alerts were not generated.

#32494 In OnGuard CSV reports that include Unicode characters, some characters might not be retained. Users
should be aware that, in order to view all characters correctly, the CSV report must first be imported into
Excel.

#32945 An Endpoints report failed and displayed error messages such as “Errors: ‘ascii’ codec can’t decode byte
0xe2 in position 0: ordinal not in range(128).

Table 37: Insight Issues Fixed in 6.6.0
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Onboard

Bug ID Description

#27590 A superfluous reconnect message was displayed when enrolling a Chromebook.

#28114 Filtering by username on the View by Username list view did not return any results. The filter is now
modified to match any part of the username.

#28242 EC certificates did not work on Windows 7. The keyUsage Onboard generates for TLS Client
certificates is now modified to improve compatibility, in particular for Windows 7 clients using EC key
types.

#30907 Onboard logic is now altered to deal with Android 6 devices not providing their MAC address.
Users should be aware that the MAC address is not provided by Android 6 and later devices. Instead, it
must be provided in the captive portal redirect. When an Aruba controller is used, we strongly
recommend that you enable the URL hash to prevent tampering.

#31041 The list of iOS trusted certificates in Onboard is updated.

#31387 Onboard was unable to re-connect iOS clients after provisioning on a subscriber.

Table 38: Onboard Issues Fixed in 6.6.0

OnGuard

Bug ID Description

#31114 The ClearPass OnGuard Unified Agent stalled in “connecting” mode when the user was switched during
a health check.

#31201 For Windows 8 clients, the ClearPass OnGuard Unified Agent was not able to read last scanned time for
Symantec Hosted Endpoint Protection.

#31581 OnGuard WebAuth requests were not evenly distributed among cluster nodes if OnGuard Load
Balancing was enabled in the OnGuard Global Agent Settings. Load balancing is now improved to
more efficiently distribute OnGuard WebAuth Requests across the cluster.

#31619 On Mac OS X, the ClearPass OnGuard Unified Agent could not read the RTP status of ESET Cyber
Security 6.1.12.0.

#31993 The ClearPass OnGuard Unified Agent reported an incorrect status for the McAfee Host Intrusion
Prevention Firewall.

#32024 The ClearPass OnGuard Unified Agent did not perform health checks if there were new-line characters
in the Override Server IPs field.

#33388 The ClearPass OnGuard Unified Agent sometimes categorized the Aruba Virtual Adapter #2 network
adapter as OTHER instead of VPN.

Table 39: OnGuard Issues Fixed in 6.6.0



Policy Manager

Bug ID Description

#21593 Corrected an issue where a customer’s ClearPass appliance was using port 4949 and port 8443. All
access to TCP ports 4949 and 8443 is now blocked.

#23923 Bulk deletion of endpoints from the user interface might have resulted in inconsistencies between
endpoint-related tables. Now when 50 or more endpoint profiles are deleted at one time, the profile
attributes for these endpoints are retained in the Profile table. Retention of these profile attributes does
not interfere with authentication.

#27363 If the default role-mapping policy [Guest Roles] was renamed, the guest roles in ClearPass Guest were
not populated. Now a name change is not allowed in the > Policy Name field on the Policy tab at
Policy Manager > Configuration > Identity > Role Mappings > [Guest Roles].

#27737 Session Restriction Enforcement was not converted to Session Notification if Session check User name
was configured.

#27800 The value for the endpoint status was not displayed in Insight reports if the status was changed using
POST Auth enforcement. Endpoint status change operations through Post Authentication enforcement
are now propagated to Insight.

#27885 The Administration > Server Manager > Licensing page continued to display a message that the
Onboard license count had been exceeded even after the actual license count was reduced to within
limits.

#27908 When upgrading from 6.4.0 or 6.4.1 through the CLI, you had to first download and install a 6.4.0 CLI
updates patch and then update to 6.4.2 or later before upgrading to 6.6.

#27922 In some upgrade cases, the services did not come up properly on subscribers, resulting in
Webauth/TACACS authentication failures, and the Access Tracker > Session Details form showed the
internal error message “Failed to authenticate user”.

#28049 The RADIUS server’s authentication and accounting ports could not be changed. The ClearPass RADIUS
server's authentication port and accounting port can now be set to custom values. To use this option, go
to Administration > Server Manager > Server Configuration, click the Service Parameters tab, and
select the RADIUS Server service.

#28457 OCSP checks are now supported when using smart card certificates for 802.1X authentication.

#28693 When zones were created with certain special characters, the CPU Usage and CPU Load graphs were
not displayed on the Monitoring > Live Monitoring > System Monitor page.
Users should be aware that only the following special characters are allowed in zone names:
- . { } [ ] ( ) and spaces.
Do not use the following unsupported characters in zone names:
` ~ ! @ # $ % ^ & * + = \ | " ' < > , ? /

#28743 An excessive number of account lockouts occurred for users authenticating against Active Directory
after changing their password. ClearPass now always uses the Name field value from the EAP
MS-CHAPv2 packet to calculate the challenge. The RADIUS service parameter Re-attempt AD login
with different Username formats has also been removed.

#28787 No information was displayed for VPN clients on the Accounting Record Details form at Monitoring
> Live Monitoring > Accounting.

#28991 Endpoint context server updates failed after Palo Alto Networks firewall was upgraded to PAN-OS 7.0.

#29038 The “Subject-serialNumber” attribute could not be used in the LDAP filter for authorization. The

Table 40: Policy Manager Issues Fixed in 6.6.0
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Bug ID Description

“Subject-serialNumber” attribute is now incorporated into the certificate namespace.

#29169 A RADIUS service failure occurred when using the ClearPass Upgrade Tool. During the domain join
operation or domain service start-up after the upgrade process, if the Alt Name or Domain SID is null,
ClearPass will ignore them and proceed with the domain join and service start.

#29196 RADIUS CoA could not be done if the machine and user authentication were configured in HP switches.

#29464 Changing the appadmin password in Post Auth Enforcement Profile checks caused disconnect failures
via RADIUS Change of Authorization (CoA).

#29662 The OpenSSL version is now upgraded to 1.0.1p. This includes fixes for CVE-2015-1793.

#29876 The Curl version is now upgraded to 7.19.7-46.1. This includes Curl bug fixes and enhancements, and
fixes for CVE-2014-3613, CVE-2014-3707, CVE-2014-8150, CVE-2015-3143, and CVE-2015-3148.

#29914 Corrected an issue where performing Guest application authentication against the Active Directory
failed.

#30075 On the Monitoring > Live Monitoring > OnGuard Activity page, the online/offline Status sort option
did not work.

#30221 Installing a patch update might fail if the boot partition did not meet the free space requirements
required by the update.

#30280 When using the DHCP SPAN port, ClearPass Profiler was unable to profile devices if the spn packets had
an 802.1q header.

#30293 Role mapping failed after updating from 6.5.0 to 6.5.2 for devices enrolled in JAMF, making clients
unable to connect. This was caused by endpoint update issues from JAMF if one of the endpoints had an
empty attribute value.

#30318 A RADIUS server authentication source failed with Aruba Application service types. A validation error is
now displayed if a RADIUS Server authentication source is part of a non-RADIUS-based service.

#30444 Under Administration > Dictionaries > Attributes, attributes of different entity types but using the
same name could not be imported.

#30510 ClearPass user interface displayed the error message “No licenses configured”, and the “system
refresh-license” command had to be entered in the CLI to correct it.

#30556 At Administration > Server Manager > Server Configuration, DNS information was not saved after
editing.

#30564 CoA and Profiling API access is now restricted to Administrator and API Administrator accounts.

#30595 Adding new devices to in the Configuration > Network > Device Groups list caused existing devices
to be deleted.

#30641 ClearPass now supports migration of multivalue non-string attributes.

#30731 The Endpoint Profiler table and pie chart did not update with the correct values if the user selected the
Choose View option.

#30984 Guest account attributes could have been overwritten when using the expired_notify_status field.

Table 40: Policy Manager Issues Fixed in 6.6.0 (Continued)
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#30995 Updating information in Insight failed if a cluster password was configured with 20 or more characters.

#31111 It was sometimes necessary to clear the router ARP entry in order for VIP to work correctly after a
network flap.

#31126 The ClearPass appliance failed to fetch endpoint attributes for random user authentications.

#31202 The publisher database was left in an inconsistent state after a subscriber attempted a promote
operation. This occurred when the switch to publisher API call as part of a promote publisher operation
failed.

#31247 The jQuery version is now upgraded to 1.11.1.

#31277 Corrected an issue where the ClearPass RADIUS server stopped responding. Information-level logs are
now included that print the number of requests in the processing tree in order to determine
configuration reloading time.

#31291 On the Administration > Server Manager > Server Configuration > Service Parameters tab, the
default values did not match the parameter values. The values are now set to the same as the default
values for each hardware platform.

#31534 Access was not restricted to some pages of the admin UI. Support is now added to control API URLs.
This includes:
l A new resource, "ClearPass API," was added at Server Configuration > node > Network >

Application Access Control.
l By default, access to /api* urls is allowed for all IP addresses.
l Users can modify the setting to allow or deny additional IP addresses.

#31661 NAD clients were sometimes removed from the NAD group.

#31673 Corrected an issue where a SQL Injection attack could occur on callback URL for a Google MDM
Connector.

#31953 When the subscribers were not reachable, parallel execution of the cron job to check whether the
standby had failed over caused an out-of-memory condition on the publisher.

#31968 Under certain traffic loads, the internal communications between various processes used with
TACACS+ authentication could get overwhelmed, which would cause sporadic authentication failures.
This issue was not seen in bursts of requests, only in long, sustained requests.

#32002 The output/input bytes calculation was incorrect if the number of output/input bytes was more than
2^32-1.
The Acct-Output-Gigawords/Acct-Input-Gigawords attribute value is now included in the input/outputs
bytes calculation in the Dashboard utilization tab and insight.

#32007 If guest usernames were created using both uppercase and lowercase characters, the guest’s
expiration time was not updated via Post Auth.

#32028 SNMP alerts were issued from all the nodes if a change was made on any one node of the cluster.
System monitoring configuration updates are now specific to the local node.

#32130 Users should be aware that the following two pages are deprecated from the user interface:
Configuration > Posture > Posture Servers and Administration > Dictionaries > Posture.

#32201 The Apache Commons Collections .jar file is now updated to version 3.2.2.

Table 40: Policy Manager Issues Fixed in 6.6.0 (Continued)
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Bug ID Description

#32599 Corrected an issue where Insight NetEvents without accounting session IDs created an unnecessary
load on an appliance.

#32617 Some subscribers in a cluster displayed the error message “Certificate verifications against this CA will
fail till the CRL is updated or removed” before the scheduled update time. The calculation for the check
to download the new CRL file is updated to the current time plus 16 minutes, allowing the script to run
and download new files every 15 minutes without encountering a CRL expiry error.

#32621 Multiple instances of the AppsUpdater script could run simultaneously, generating a high CPU load.

#32656 When using TACACS, the “change password” prompt was displayed even though the username field
was empty.

#32604 Cluster operations were blocked by certificate revocation list (CRL) updates running in the background.

#32678 Users should be aware that, on the Internet Explorer 11 browser, graphs and charts are best viewed in
the Edge document mode.

#32787 On the Chrome 48.x browser, adding an enforcement profile at Configuration > Enforcement
> Policies also added a null enforcement profile.

#33003 Corrected an issue where the RADIUS server could crash when processing badly formatted usernames.

#33025 One of the nodes of a cluster failed to upgrade from 6.3.4 to 6.5.0. During system upgrade, under rare
circumstances route-eth*was empty, causing the upgrade process to fail. Fixed the system
upgrade issue to any empty route-eth* and rule-eth* files for IPv4 and IPv6 in the current
partition.

#33031 If the domain Fully-Qualified Domain Name (FQDN) was provided instead of the DC FQDN, the attempt
to join the domain failed with the error message, “<name> failed to join the domain <DOMAIN NAME>
with domain controller as <domain name>”. The ad net join command is now enhanced to include
a detailed description for the domain controller FQDN input field.

#33042 Users were denied ClearPass admin access due to a space between the IP address and subnet mask,
which resulted in an invalid host name. Validations have been added for IP address and subnet mask
entries on the Application Access Control screen to check for spaces in the host name, which can
prevent users from gaining ClearPass admin access.

#33084 glibc is now updated to the latest version. This includes fixes for CVE-2015-7547 in relation to the glibc
stack-based buffer overflow in getaddrinfo().

#33098 After upgrading to 6.5.5, the error message “Error in processing request. Please retry” was displayed
because of an incompatible certificate.

#33138 The RADIUS Change of Authorization (CoA) could not be sent if the IP range was given in the Network
Device.

#33145 An authentication error occurred if an IP address value at Configuration > Network > Devices was
configured in IP/32 format (for example, 192.168.1.1/32).

#33190 The OnGuard Clients Summary widget on the Policy Manager Dashboard displayed incorrect data
when endpoint attributes were updated manually.

#33748 Users should be aware that ESX 4.x is not supported.

Table 40: Policy Manager Issues Fixed in 6.6.0 (Continued)



ClearPass 6.6.4 | Release Notes Known Issues Identified in Previous Releases | 89

Chapter 8
Known Issues Identified in Previous Releases

The following known issues for this release were identified in previous releases. Workarounds are included
when possible. For a list of known issues identified in the ClearPass 6.6.4 release, see the What’s New in This
Release chapter.

This chapter includes:

l "CLI" on page 89

l "Cluster Upgrade and Update" on page 89

l "Dissolvable Agent" on page 91

l "Guest" on page 93

l "Insight" on page 93

l "Onboard" on page 95

l "OnConnect Enforcement" on page 96

l "OnGuard" on page 97

l "Policy Manager" on page 101

l "Profiler and Network Discovery" on page 107

l "QuickConnect" on page 108

CLI

Bug
ID Description

#35750 Symptom/Scenario:On a CP-HW-25K / JW772A or CP-HWDL360-25K / JX920A, the total system memory
is shown as 65.9 GB instead of 64 GB.

Table 41: Known Issues in CLI

Cluster Upgrade and Update

Bug
ID Description

#29710 Symptom: Upgrading with the Cluster Upgrade Tool fails if the cluster password includes special
characters such as the “at” symbol (@), colon (:), or slash (/).
Scenario: This occurs on all versions of the Cluster Upgrade Tool.
Workaround: Before installing the upgrade patch, if the cluster password contains special characters,
please change it temporarily to only use alpha-numeric characters (letters and numbers). The cluster
password can be changed back to the old password after the cluster upgrade completes.

#33668 Users should be aware that, when performing upgrades with the Upgrade Tool, there are some
limitations regarding identification of cluster node status.

Table 42: Known Issues in Cluster Upgrade and Update
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Bug
ID Description

l If a cluster node goes out of sync or is dropped during upgrade, migration, or a cluster join operation,
the Cluster Upgrade Tool cannot detect the status of that node. After the cause of the failure is
identified, the failed node must be manually rejoined to the cluster.

l If any nodes in the cluster are out of sync or force-dropped before the upgrade is started, the Cluster
Upgrade Tool cannot detect the status of those nodes. Before starting the upgrade, confirm that all
nodes are in proper sync.

l During a cluster add or rejoin operation, failure alerts might be displayed if the Cluster Upgrade Tool
installs dependent patches before the cluster operation is complete. The upgrades can be initiated
through the Cluster Upgrade Tool when the nodes are back in proper sync.

#33669 Users should be aware that there are some Cluster Update Tool scenarios where view, logs, or status
update information is not shown. These do not affect functionality.
l If a patch update (either a point patch or a cumulative patch) requires an admin-server or async-netd

service restart, the INFO logs information on the Update tab might be incomplete.
l If a patch is updated through the Software Updates portal instead of through the Cluster Updates

interface, no status or installation log information is displayed for it in the Cluster Update interface.
The Start Update option is also still shown for that node, unless there is a manual admin-server
restart, or unless there is a cluster operation that triggers a status check of installed patches.

l If a node is dropped from the cluster or rejoined to the cluster, the Update Status, View Logs, and Last
Step information is cleared for that node.

#33670 Users should be aware that, in cluster setups, skin updates cannot be done in batches. Skin updates must
either be done for all the cluster nodes at once, or be manually done on each node.

#35734 Users should be aware that, after a patch update is installed through the Administration > Agents and
Software Updates > Software Updates > Cluster Update portal, the “Installed” status is not displayed
on the Software Updates portal. To check the status of a patch that was installed through the Cluster
Update portal, you must select and view the patch in the Cluster Update portal.

#36089 Symptom: Patches that have been downloaded but not installed will disappear from the Software
Updates portal after upgrading to ClearPass 6.6.2 using the Cluster Update interface. These
downloaded patches, however, will be visible from the Cluster Update interface.
Scenario: This can occur after updating to the 6.6.2 cumulative patch.
Workaround: If they are still not installed, these patches will be removed during the periodic cleanup that
occurs every seven days.

#36112 Symptom: After a patch is uploaded and successfully installed through the Cluster Update interface,
the patch file is still available on the Software Updates portal.
Scenario: This only occurs if the patch is manually imported and then installed through the Cluster
Update interface. It does not occur if the patch is downloaded through the Software Updates portal.

#36114 Symptom: If the Check Status Now link is clicked in the Software Updates portal while a cluster update
to 6.6.2 is in progress, the 6.6.2 patch is not shown in the Update Info > Update Image Name list in the
Cluster Update interface, even though the patch updates correctly. This occurs if the appliance was
upgraded in this order: 6.6.0 > 6.6.1 > 6.6.2.
Workaround: We recommend that you do not click the Check Status Now link in the Software Updates
portal while performing the 6.6.2 update.



Dissolvable Agent

Bug ID Description

#7165 To have health data collection work correctly in 64-bit Windows 7, please use the JRE version provided by
ClearPass. It can be downloaded from the following URL: https://<CPPM-IP-
Address>/agent/html/help.html

#18031 Symptom: The OnGuard Web Agent does not work with Chrome on Mac OS X with Java 7 or 8 installed.
Workaround: The Java plugin is now deprecated in Chrome 42.x and above. This is an issue with
Chrome, not with ClearPass.
Use the Firefox, Internet Explorer, or Safari browser instead.

#18035 Symptom: The OnGuard Web Agent applet fails to launch on Mac OS X 10.9.
Scenario: New security restrictions in Mac OS X 10.9 and Safari 7 prevent the launch of the OnGuard
Web Agent.
Workaround: Go to Safari menu > Preferences > Security > Allow. Allow plugins should already be
selected. Click Manage Website Settings, look for your portal Web site IP/name, and select Run in
Unsafe Mode.

#18230 Symptom/Scenario: The ClearPass OnGuard Dissolvable Agent might not work properly if the client
machine runs two different Java versions—for example, Java 6 and Java 7.
Workaround: Uninstall the old Java component if it exists and keep the latest Java version.

#20191 The OnGuard applet needs to run in Safari's “Unsafe mode” to perform health checks. To enable this, go
to Safari > Preferences > Security > Manage Website Settings > Java > [Select IP/hostname of
ClearPass server], and select “Run in Unsafe Mode” in the drop-down list.

#20514 Client health checks might not work if the client is not running the latest Java version.

#23253 Symptom/Scenario: Launching the Web Agent applet using some Java versions (7u55 and above)
displays the security warning “This web site is requesting access and control of the Java application
shown above. Allow access only if you trust the web site...”
Workaround: Click Allow to let the health checks proceed.

#24518 Symptom: The first time a run or scan operation is initiated in the Native Dissolvable Agent flow, an
“External protocol request” message is displayed, and if the user clicks the “Do Nothing” option, the
message stays on the screen.
Scenario: This occurs on the Chrome browser on both Windows and Mac OS X.
Workaround: This message is produced by the Chrome browser and can be ignored. Click Launch
Application in the External protocol request message.

#24762 Symptom: When launching the OnGuard Dissolvable Agent, Mac OS X displays the message “You are
opening the application ‘ClearPass OnGuard WebAgent’ for the first time. Are you sure you want to open
this application?”
Scenario: This is the normal, default behavior of Mac OS X, and is not an issue in OnGuard.

#24766 Symptom/Scenario: The Native Dissolvable Agent fails to download from Internet Explorer on Windows
2008 or Windows XP if the “Do not save encrypted pages to disk” check box is enabled.
Workaround: Go to Internet Options > Advanced. Uncheck (disable) the check box for the “Do not
save encrypted pages to disk” option.

#24768 Symptom: The Native Dissolvable Agent does not work well in Internet Explorer on Windows XP.
Scenario: The agent works after downloading it and allowing pop-ups, but no remediation results are
displayed and, after clicking Launch ClearPass Application, a series of messages is displayed in a loop.
Workaround: Windows XP is an unsupported operating system. Use a later Windows version or the
Chrome or Firefox browser instead.

#24792 Symptom/Scenario: The Native Dissolvable Agent flow will not work properly on IE if ActiveX Filtering is
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enabled on IE settings.
Workaround: For Native Dissolvable Agent to work properly on Internet Explorer, ActiveX Filter should
be disabled.

#24862 Symptom/Scenario: The Native Dissolvable Agent uses ActiveX on IE on Windows OS. Based on IE
Security Settings, the browser may ask the user to run or allow “ClearPass OnGuard Web Agent Control”.
Workaround: For the Native Dissolvable Agent to work properly on Internet Explorer, the user should
allow “ClearPass OnGuard Web Agent Control” ActiveX Control to run.

#27117 Symptom: On Mac OS X, the Native Dissolvable Agent might not work properly on Google Chrome or
Firefox if Avast Mac Security 2015 Antivirus is installed.

#27756 Symptom/Scenario: The Native Dissolvable Agent can not be installed on Mac OS X 10.6.
Workaround: On Mac OS X 10.6, admin/root permission is required to install the Native Dissolvable
Agent. After installation, the admin user should execute the following command:
sudo chmod –R 777 ~/Library/Application\

Support/ClearPassOnGuardWebAgent/

#27871 Symptom: The Java dissolvable agent does not detect AVG 2014.
Scenario: This occurs on Mac OS 10.10 with the Java dissolvable agent. The native dissolvable agent is
able to detect it.

#28398 Symptom: The native dissolvable agent does not automatically relaunch the applet.
Scenario: This can occur on Mac OS or on Ubuntu after upgrading from 6.5.0 to 6.5.1. This is not seen on
a clean upgrade; however, in scenarios where there is a machine shut-down and reboot or switch, this
might be seen until a proper network connection is restored.
Workaround: If this occurs, launch manually if auto-launch does not help.

#29127 Symptom: The OnGuard Java-based Dissolvable Agent is not supported on the Chrome 42.x or higher
browser.
Scenario: The Java plugin is now deprecated in Chrome. This is an issue with Chrome, not with
ClearPass.
Workaround: Use the Firefox, Internet Explorer, or Safari browser.

#29186 Symptom/Scenario: The Native Dissolvable Agent sometimes does not run on Windows Vista, Windows
2008 R2, or Windows 8.
Workaround: Right-click the OnGuard application to open Properties, and then unblock the .exe file.

#29609 Symptom/Scenario: The ClearPass OnGuard Native Dissolvable Agent for Mac OS X does not support
status checks for the “Software Updates” patch management application.

#32664 Symptom: The Native Dissolvable Agent is not supported on the Microsoft Edge browser.
Scenario: The Microsoft Edge browser is not able to detect whether the Native Dissolvable Agent is
installed or not, and displays a message to download the agent even if the agent is already installed.
Workaround: Use the Firefox, Chrome, or Internet Explorer browsers instead.

Table 43: Known Issues in the Dissolvable Agent (Continued)
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Bug ID Description

#9967 Symptom/Scenario: Unicode SMS messages (UTF-16 encoded) are limited to 70 Unicode characters.
The ClearPass Guest user interface still displays 160 characters as the limit. Sending a Unicode SMS
message over 70 characters may fail if the SMS service provider does not support multi-part SMS
messages.
Workaround: If you plan to use Unicode SMS messages, check your SMS receipt carefully to ensure it
is not over 70 characters in length.

#25137 Please review your operator privileges for new features that may need to be enabled.

Table 44: Known Issues in Guest

Insight

Bug ID Description

#12159 Symptom/Scenario: Insight reports do not show license changes immediately. The changes might
take up to 24 hours, depending on when the changes are made.

#31048 Symptom/Scenario: When the Internet Explorer browser is refreshed, icons on the Insight Dashboard
are displayed as text.
Workaround: Navigate to any other page in Insight and then come back to the Dashboard page.

#32276 Symptom/Scenario: The secure flag is not set for Insight sessions.

#32316 Symptom/Scenario: Users should be aware that posture data in the Insight database from Insight
versions earlier than 6.6 cannot be migrated due to database changes.

#32317 Symptom/Scenario: Users should be aware that report configurations from Insight versions earlier
than 6.6 are not carried forward after migration or upgrade.

#32318 Symptom/Scenario: Users should be aware that alerts configurations from Insight versions earlier
than 6.6 are not carried forward after migration or upgrade.

#32430 Symptom: There is a discrepancy between the data shown in some of the Insight Dashboard’s widgets
and the data displayed in reports and other widgets.
Scenario: If the time zone is changed, Insight graphs in hourly widgets might show discrepancies for
data from the past 24 hours. For example, the Authentication Trend widget might show only six
entries while the Access Tracker correctly shows seven entries for the same date and the Auth
Overview report shows the proper data and trend.

#32455 Symptom/Scenario: Graphs in the PDF report do not expand over the entire width of the PDF.

#32624 If the report period is more than one month, the PDF report does not show the X,Y data table below the
graphs.

#32786 Users should be aware that, in order to generate reports and alerts, one of the Insight nodes must be
enabled as the Insight master. This is configured in Policy Manager at Administration > Server
Manager > Server Configuration on the System tab.

#32901 Users should be aware that the RADIUS Accounting ID must be unique in Insight.

#33178
#33183

Users should be aware that, in Insight reports, filter entities such as Auth Service and Auth Source are
fetched from tipsDB, and only the latest name in the database will be fetched in the prepopulated field
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for the selection. This means that if a service name or source name has been changed, only the latest
name will be fetched, so reports can only be configured with those latest changes. All previously
stored names will be discarded.

#33208 Symptom/Scenario: In a setup with a loaded insightDb, Search does not give an autocompletion-
based search.
Workaround: The user must provide a full phrase to search and then select the appropriate category
from the drop-down list.

#33227 Users should be aware that, if SFTP is configured in Insight and the SFTP server is a Windows server,
the remote directory must be provided with the relative path and not the absolute path.
If the SFTP/SCP server is on Linux, however, the absolute path must be provided.

#33243 Symptom/Scenario: SCP for reports does not work when configured for an SCP server in Windows;
however, SFTP does work for Windows.

#33244 Symptom/Scenario: Generated reports displayed in the Calendar widget are not available to view or
download if the Insight Master is switched.

#33245 Symptom: Reports, alerts and admin settings can only be configured using the Insight master.
Scenario: In a cluster of nodes with multiple nodes enabled with Insight, the Insight master is the only
node allowed to configure reports, alerts, and admin settings. On the Insight slave nodes, only the
Dashboard page is available to view.

#33265 Users should be aware that Insight only supports the English language.

#33448 Symptom/Scenario: An Insight report might be aborted due to timeout if all the available columns are
selected for CSV export when the Insight database has millions of records.

#33582 Symptom: Deselecting Notify by Email or Notify by SMS check box is not saved.
Scenario: On reports and alerts, if a Notify by Email or Notify by SMS check box is deselected,
saving appears to work but the check boxes are still selected when the report is reopened.
Workaround: To remove the notification settings, first deselect the check box, and then clear the
associated notification text field. Save the report or alert.

#33608 Symptom/Scenario: In the Insight Dashboard, hovering the mouse pointer over a MAC address in a
widget visibly changes the pointer to a click pointer, but no action occurs if the pointer is clicked.

#33770 Symptom/Scenario: Endpoint reports will be empty if they are generated soon after upgrading or
migrating from versions lower than 6.6. This report is generated properly only after the corresponding
endpoints are authenticated in the 6.6.0 version.

#33771 Symptom/Scenario: Insight reports that use custom templates and their corresponding generated
reports are not carried forward from versions lower than 6.6.0.

#33776 Symptom/Scenario: A delay in the WAN or a slow network might cause problems with the way the
Insight page layout is displayed.
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#33825 Symptom/Scenario: Guest MAC/Device Authentication is not reflected on the Guest Authentication
Trend graph.
Workaround: The information is available in the Authentication Trend Graph.

#35947 Symptom: Disabled reports are enabled after they are edited and saved.
Scenario: For a disabled report with no repeat configured, editing the report triggers running the
report with the updated configuration. For a disabled report with scheduling configured, the report is
enabled and a run is scheduled for the report with the updated configuration. Both scenarios result in
the report being enabled when it is saved after editing.
Workaround: None. This is expected behavior, since a report is usually edited in order to use it.

Table 45: Known Issues in Insight (Continued)
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Bug
ID Description

#9897 Symptom: ClearPass Onboard does not update the Policy Manager endpoints table with an endpoint
record when provisioning an iOS 5 device.
Scenario: This is because the iOS 5 device does not report its MAC address to ClearPass Onboard during
device provisioning.

#10667 Symptom/Scenario: When using Onboard to provision a OS X system with a system profile, an
administrator user must select the appropriate certificate when connecting to the provisioned network
for the first time. The administrator should also ensure that the system's network settings are configured
to automatically prefer connecting to the provisioned network, if the intent is for non-administrator users
to always use that network.
Workaround: The process to provision an OS X system with a system profile is:
1. The administrator should log in to the OS X system and connect to the provisioning SSID. Do not select

the “Remember this network” option.
2. Use Onboard to provision the device with an EAP-TLS profile, ignoring the username/password

prompt.
3. Connect to the provisioned network, selecting EAP-TLS as the mode and selecting the provisioned

certificate, but ignoring the username field.
4. When the system connects and authorizes to the network, use Network Preferences to place the EAP-

TLS network first in the priority list.
5. After the administrator logs out, users logging in are connected by EAP-TLS and cannot modify those

settings.

#20983 Symptom: HTC Android asks the user to enter a certificate name to be installed when onboarding.
Scenario: HTC Androids running Android version less than Android 4.3 and greater than Android
2.3 ask the user to enter a name for the certificate to be installed while onboarding.
Authentication will fail if the user does not enter the exact certificate name as QuickConnect application
instructs in a message prior to the certificate installation dialog.
Workaround: None. This issue is due to a limitation in the Android phone’s firmware.

#23287 Symptom: Embedding Admin credentials for onboarding does not work in Windows 8 and above. The
system hangs and there is no error message.
Scenario: When onboarding Windows systems with Windows 8 and above, if operations requiring admin
privileges are configured, then the end user doing the onboarding needs to have admin privileges on the
system. These operations include installing applications, configuring wired networks, installing
certificates in the machine certificate store, and so on. Embedding admin credentials along with the
QuickConnect wizard for this purpose does not work for Windows 8 and above.
Workaround: There is no workaround. This is a Windows system limitation.
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#23699 Symptom: Mac OS X disconnects before it completes a certificate renewal.
Scenario: On Mac OS X, automatic certificate renewal through the “Update” option on Apple’s interface
does not work. This occurs on provisioned (wireless) networks.
Workaround: This is an issue with OS X limitations, and is not an Onboard issue. Users should be aware
that when their certificate is about to expire, they should renew the certificate through Onboard instead
of using Apple’s automatic certificate renewal.

#25711 iOS always displays SHA-1 for the signing algorithm regardless of the actual algorithm used. This is an
issue with iOS, not Onboard.

Table 46: Known Issues in Onboard (Continued)

OnConnect Enforcement

Bug ID Description

#34964 Symptom: When a domain user attempts to log in on a wired interface, OnConnect Enforcement
places the endpoint in the wrong VLAN.
Scenario: This happens if a user attempts to log in to a domain account several seconds after the
device is connected to a wired OnConnect Enforcement-enabled port. In this scenario, OnConnect
Enforcement is triggered prior to login and uses only the MAC address, leaving the username empty.
Workaround: After the domain user login, unplug the Ethernet cable. Wait for a few seconds and then
connect the Ethernet cable again. OnConnect Enforcement will be triggered again and the appropriate
connection restored.

#34999 Symptom: An empty username is returned for an OnConnect Enforcement request and the alert
“WebAuthService Username is empty in the request” is displayed.
Scenario: This occurs in the following scenarios:
l The host is not a Windows device and a Windows Management Instrumentation-based (WMI)

logged-in user query fails as expected.
l The IP address for the MAC address of a connected endpoint cannot be determined. The IP

address is typically updated based on DHCP traffic received by the Device Profiler. In this scenario,
possible workarounds are to configure a short session timeout (> 3 minutes) to force a re-
authentication, or for the user to manually disconnect and reconnect the endpoint to the network.
These will resolve transient errors due to timeouts or due to delays in resolving the MAC-to-IP
association.

l A WMI-based query to the host fails on a Windows device. This typically occurs if a firewall blocks
access to WMI ports on the device, or if a WMI login to the device fails using credentials configured
in Profile Settings.

#36119 Symptom/Scenario: After a port configuration is changed, ClearPass does not detect the updated
switchport configuration when a new SNMP Trap is received.
Workaround: To have ClearPass detect the recent port configuration, do one of the following:
l Wait for the periodic device polling interval to elapse after the port configuration changes are

made. To verify the length of this interval, go to the Administration > Server Manager > Server
Configuration > Service Parameters tab and select ClearPass network services. The interval is
displayed in the Device Info Poll Interval field.

l Alternatively, at Configuration > Network > Devices > Edit Device Details, make any minor
change and then click Save to refresh the Network Access Device (NAD).

#36230 Symptom/Scenario: On the Administration > Server Manager > Server Configuration > System
Monitoring tab, if the default value for the Engine Id field is replaced with an empty value, SNMP v3
Informs and Traps do not work.

Table 47: Known Issues in OnConnect Enforcement



OnGuard
Memory utilization for ClearPass OnGuard depends on the Health Classes configured and the type of Windows OS;
however, the minimum requirement for ClearPass OnGuard running on a Windows platform is 90 MB.

Bug
ID Description

#12342 The OnGuard agent fails to collect health on Windows 8 if VMware Server 2.0.2.X is installed.

#13164 Symptom: The hardware installation pop-up dialog appears to stop installing the ClearPass OnGuard
Unified Agent for VIA+OnGuard mode. A warning message similar to “The software you are installing...
has not passed Windows Logo testing” might be displayed during installation.
Scenario: This might occur during the installation of the ClearPass OnGuard Unified Agent on Windows
XP and Windows 2003 SP2.
Workaround: Users should click Continue Anyway to proceed.

#13363 Symptom: On Mac OS X, the current version of the ClearPass OnGuard Unified Agent VPN component
does not show some VPN-related information—for example, tunnel IP assigned by the controller, packet
count, or diagnostic details.
Scenario: This occurs on Mac OS X. It does not occur on Windows OS.

#13929 At times, OnGuard may fail to detect peer-to-peer applications, such as /uTorrent, on Windows  2008  R2.

#13935 OnGuard does not support enabling or disabling the Windows Update Agent Patch Management
Application.

#13970 After anti-virus software is installed, the system must be rebooted before using ClearPass OnGuard.

#14196 ClearPass OnGuard will not be able get the correct status of 'Software Update' PM application on Mac OS
X, if “Check for updates” and “Download updates automatically” are not toggled at least once.

#14673 The OnGuard Agent for Mac OS X does not support bouncing of a VPN Interface other than the Aruba
VPN Interface (version 6.1).

#14760 In some cases, OnGuard fails to connect to the ClearPass appliance from a wired interface if the VPN is
connected from a trusted network.

#14842 Installing the ClearPass OnGuard Unified Agent removes an existing VIA installation. To continue to use
VPN functionality, go to Administration > Agents and Software Updates > OnGuard Settings and
select Install and enable Aruba VPN component from the drop-down list.

#14996 If McAfee VE is running on Windows XP, the ClearPass OnGuard Unified Agent VPN will not work.

#15072 VIA connection profile details are not carried forward after upgrading from VIA 2.0 to ClearPass OnGuard
Unified Agent 6.1.1.

#15097 The ClearPass OnGuard Unified Agent does not support installation of a VPN component on Mac OS X
10.6.

#15156 VPN configuration is not retained after upgrading to the ClearPass OnGuard Unified Agent using MSI
Installer on a 64-bit Windows system.

#15233 On Win 7 (64 Bit), upgrading an existing VIA 2.1.1.X to the ClearPass OnGuard Unified Agent can lead to
an inconsistent state. Users should first uninstall VIA and then proceed with the ClearPass OnGuard
Unified Agent installation.

#15351 Symptom: The state of the Real_Time Scanning button in the Trend Micro Titanium Internet Security for
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Mac OS X is not updated.
Scenario: This is observed when the ClearPass Unified OnGuard Agent has Real Time Protection (RTP).
Workaround: Close the UI using Command +Q and restart.

#15586 Symptom: The ClearPass OnGuard 6.2 dissolvable agent does not support the following new health
classes on Mac OS X: Processes, Patch Management, Peer-To-Peer, Services, USB Devices, and Disk
Encryption. The dissolvable agent (DA) does not display these health classes as remediation messages in
the user interface because java binary sdk support is not included.
Scenario: The client will be unhealthy if any of the health classes listed above are configured and
performing a health scan via the DA.

#15986 ClearPass OnGuard returns the product name of “Microsoft Forefront Endpoint protection” AntiVirus as
“Microsoft Security Essential”.

#16181 Symptom: The command level process can be detected using the path “none” but the application level
process can't be detected by setting the path to ”none”.
Scenario: This applies to Mac OS X.
Workaround: The application-level process health should be configured with the path set to
Applications > Firefox.app.

#16550 Symptom/Scenario: The ClearPass OnGuard Unified Agent does not support checking of disk encryption
state using the MacKeeper (ZeoBIT LLC) Disk Encryption Product on Mac OS X. This causes the client to
be treated as healthy even if none of the disk is encrypted.
Workaround: There is no workaround at this time.

#18281 The ClearPass OnGuard configured health quiet period is supported in Health only mode. It doesn’t work
in Auth+Health mode.

#18341 Symptom/Scenario: OnGuard cannot start a process on Mac OS X for non-administrative users.
Workaround: The user must have root privileges to start process-level health checks by OnGuard on
Mac OS X.

#19019 The network interface will be bounced twice (once immediately, and once after the configured interval)
when the log-out/bounce delay parameter is configured. This is expected behavior; the first bounce is
required to end the existing session.

#20316 OnGuard’s Health Check Quiet Period is applicable per network interface. If a machine has more than
one network interface, then each interface will have its own Health Check Quiet Period duration.

#23470 Symptom/Scenario: On a Japanese OS, when upgrading from VIA 2.1.1.3 to the ClearPass OnGuard
Unified Agent, a known issue with uninstalling VIA displays a message asking the user to select the VIA
driver. This does not occur on an English OS.

#23636 Symptom: The value of the Posture:Applied Policy attribute is not correctly displayed in the Access
Tracker for posture policies carried over from releases earlier than 6.3.0.
Scenario: This has been observed when upgrading from 6.2.6 to 6.3.2.
Workaround: This can be corrected by manually saving the affected posture policy once after upgrade.

#24986 Symptom: The Native Dissolvable Agent is not automatically launched after downloading and running
the agent the first time on the Chrome browser.
Scenario: This occurs on Windows and on Mac OS X.
Workaround: The first time you launch the Dissolvable Agent, click Launch ClearPass OnGuard Agent.

#25827 Symptom/Scenario: On Internet Explorer 8, when the security warning message asks whether you want
to view only the content delivered through a secure HTTPS connection, the behavior is not as expected.
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Workaround: For the Native Agent flow to work correctly, click No in the pop-up dialog.

#26224 Symptom/Scenario: Some combined products that include both antivirus and anti-spyware (for
example, McAfee VirusScan Enterprise + AntiSpyware Enterprise) are not shown in the AntiSpyware
Posture configuration.
Workaround: Add products like this only in Antivirus. Both the AntiVirus and AntiSpyware values are the
same.

#27134 Symptom: OnGuard does not support dynamic switching between logged-in users on an Ubuntu client.

#27599 Symptom: The OnGuard logo is not shown on the desktop on Ubuntu.
Scenario: On the Ubuntu OS, the OnGuard logo is not visible on the desktop at first. The logo will be
updated automatically after the desktop is refreshed.

#27876 Users should be aware that RADIUS CoA over VPN is not supported on Ubuntu.

#29243 Symptom: The Unified Agent fails to disable other types of network connections when “Allow Only One
Network Connection” is selected.
Scenario: Users should be aware that the ClearPass OnGuard Unified Agent for Windows does not
support disabling USB data card/modem type network interfaces.

#29598 Symptom: OnGuard does not stop or pause VM Player 7.x virtual machines.
Scenario: Users should be aware that the ClearPass OnGuard Unified Agent does not support auto-
remediation for Guest VMs running on VMware Player.

#29613 Symptom: The Disable USB Mass Storage Device auto-remediation action is not supported on
Windows 64-bit operating systems.
Scenario: If Disable USB Mass Storage devices is selected as the auto-remediation action in the USB
Devices health class, the ClearPass OnGuard Unified Agent does not disable USB mass storage devices
on Windows 64-bit operating systems. The message “Failed to disconnect following USB mass storage
devices.... Please remove manually” is displayed to end users on those 64-bit systems.
Workaround: None.

#30106 Symptom: On Mac OS X, the native and Java dissolvable agents do not get the RTP status of ESET Cyber
Security Antivirus 6.x.
Scenario: Users should be aware that the ClearPass OnGuard Native Dissolvable Agent for Mac OS X
does not support the RTP Status check for ESET Cyber Security and ESET NOD32 Antivirus.

#30243
#30212

Symptom: The ClearPass OnGuard Unified Agent fails to load on Windows Server 2003, and does not
support VPN, Auto Upgrade, or SSO on Windows XP or Windows Server 2003.
Scenario: Users should be aware that Microsoft stopped supporting Windows Server 2003 on July 14,
2015, and stopped supporting Windows XP on April 8, 2014. Aruba will not provide further ClearPass
support for these operating systems.
Workaround: Windows 2003 server and XP machines are required to update the Microsoft root CA
certificate or missing trust certificates in order to load the OnGuard user interface properly.
The following Microsoft knowledge base article provides information, as well as a link to the hotfix
download that needs to be installed in order to enable certificate support with the SHA-256 algorithm:
https://support.microsoft.com/en-us/kb/968730.

#30381 Symptom: The ClearPass OnGuard Unified Agent might not be able to detect the installation of certain
Windows updates that are not visible in Control Panel > Programs and Features > View installed
updates.
Scenario: These are updates that might not use an installer or cannot be removed. Some examples
include the Windows Malicious Software Removal Tool, certain Windows Defender updates (but these are
validated through AntiVirus health class), and foreign language input method editor (IME) files.
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Workaround: There is no workaround at this time.

#30618 Symptom: The ClearPass user interface may become unavailable after installing ClearPass OnGuard
hotfix patches due to a service restart.
Workaround: Log in to the ClearPass CLI using the appadmin account, and restart cpass-admin-server
using the ‘service restart cpass-admin-server’ command. This will only affect the GUI and not the
availability of ClearPass services (for example, RADIUS).

#31734 Symptom/Scenario: When both the wired and wireless interfaces are connected, the ClearPass
OnGuard Dissolvable Agent sometimes picks the wrong interface to perform health checks.

#31893 Symptom/Scenario: Although Windows 10 does not support the Network Access Protection (NAP)
platform, Windows 10 is still listed in the Windows System Health Validator and Windows Security
Health Validator plugins for OnGuard at Configuration > Posture > Posture Policies > Posture
Plugins tab.

#32590 Symptom/Scenario: The ClearPass OnGuard Unified Agent stops performing health checks on clients
where AVG Anti-Virus Free Edition 2016.x is installed.
Workaround: Perform the following steps to resolve the issue.
1. Disable AVG self protection : Open the AVG user interface, go to Options > Advanced settings >

AVG Self Protection, and deselect the Enable AVG self protection check box.
2. Stop the avgwd service. Type the following commands at the elevated command line :

rename "c:\Program Files\AVG\Av\avgwdsvcx.exe" avgwdsvcx.exe.org

taskkill /F /IM avgwdsvcx.exe

3. Rename stats db. Type the following commands at the elevated command line :
rename c:\ProgramData\Avg\AV\DB\stats.db stats1.db

4. Start the avgwdsvc service. Type the following commands at the elevated command line :
rename "c:\Program Files\AVG\Av\avgwdsvcx.exe.org" avgwdsvcx.exe

sc start avgwd

#33332 Symptom: The Java Dissolvable Agent guest portal page hangs.
Scenario: This occurs when the user clicks Continue on the Security Warning dialog after installing or
upgrading to JRE 8u73. This is not an issue with current Java versions.
Workaround: Upgrade to the latest JRE version.

#33458 Symptom/Scenario: If there are more than two auto-connect SSIDs configured, a Windows OS will
sometimes keep connecting to these SSIDs after the OnGuard Agent disconnects the wireless interface.

#33532 Symptom/Scenario: When the ClearPass OnGuard Agent for Windows is running in Service mode, the
Retry button is sometimes disabled and an incorrect system tray icon is shown.
Workaround: Quit OnGuard and relaunch it.

#34571 Symptom/Scenario: The Java-based Dissolvable Agent sometimes does not show health check results
on Windows in the Firefox browser.
Workaround: Rebooting the system or clearing the browser cache might fix the problem.

#34744 Users should be aware that the Dissolvable Agent flow might not work with the latest Google Chrome
versions (49.x and later) on the following operating systems because Google no longer supports Chrome
on these platforms: Windows XP, Windows Vista, and Mac OS X 10.6, 10.7, and 10.8.

#34829 Symptom: The ClearPass OnGuard Unified Agent's Retry and Login buttons sometimes become
inactive if the network interface is disabled or disconnected.
Scenario: This occurs on Windows operating systems, and is only seen in Service mode.
Workaround: Quit and relaunch the OnGuard Agent.
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#34987 Symptom/Scenario: If the VPN component is enabled on the ClearPass OnGuard Unified Agent, multi-
user (switch user) use cases are not supported.

#36208 Symptom: Double backslash characters ( \\ ) are shown in the Access Tracker for the Path and
Command attributes of the Agent Script Enforcement profile, but users should only enter a single
backslash character ( \ ).
Scenario: On the Monitoring > Live Monitoring > Access Tracker > Output tab for an Agent Script
enforcement profile, the Application Response area shows double backslash characters instead of
single backslash characters in Path and Command attribute values.
This is normal display behavior for this form and is not an issue. Users should be aware that, when
creating an attribute, only single backslash characters may be entered in attribute values. Although a
double backslash is displayed in these attribute values on the Output tab, the value sent to OnGuard
uses the single backslash.

#36334 Symptom: The Native Dissolvable Agent does not launch automatically after it is installed, and if the user
clicks “Launch ClearPass OnGuard Agent” it again prompts the user to download the Native Agent.
Scenario: This issue has been observed mostly on Firefox versions 48.x and 49.x.
Workaround: In the Firefox menu, click the Add-ons link and then select Plugins in the left menu. The
Native Dissolvable Agent will then launch automatically.

#36354 Symptom: The Native Dissolvable Agent does not launch automatically after it is downloaded and run for
the first time on the Firefox browser.
Scenario: This occurs on the Firefox browser for both Windows and Mac OS X.
Workaround: When the agent is launched for the first time , click “Launch ClearPass OnGuard Agent” to
launch it manually.

#37354 Symptom: The Java Dissolvable Agent does not work with the Safari browser on MacOS 10.12.
Scenario: When trying to perform health checks using the Java Dissolvable Agent, after the applet opens
OnGuard stops and does not perform the health checks. This is due to recent changes in the Safari
browser, and is not an issue with ClearPass.
Workaround: None.

#37393 Symptom/Scenario: After the RTP status of AhnLab V3 Endpoint Security AntiVirus is enabled on Korean
Windows 7 as part of auto-remediation, the ClearPass OnGuard Unified Agent takes a few seconds to
detect the RTP status as Enabled.

#37531 Symptom:The ClearPass OnGuard Unified Agent fails to enable the Real-Time Protection (RTP) method
of Symantec Endpoint Protection 14.x (SEP14).
Workaround: In Symantec Endpoint Protection, go to Change Settings > Client Management >
Tamper Protection and un-mark the Protect Symantec security software from being tampered
with or shut down check box.

Table 48: Known Issues in OnGuard (Continued)

Policy Manager

Bug ID Description

#10881 Entity updates with PostAuth enforcement fail if the publisher is down.

#12316 Syslog Filters and Data Filters configuration will be removed after an upgrade. Policy Manager does
not carry forward Syslog Filters and Data Filters configuration. Only default data is migrated.

#13645 Authorization attributes are not cached for the Okta authentication source.
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Bug ID Description

#13999
#13975

In order to add or update a PostAuth profile configuration, the admin must first delete old profiles from
ClearPass, and then add the new or updated profiles.

#14186 Symptom: Post auth doesn’t work properly for UNKNOWN endpoints in a MAC Authentication Bypass
(MAB) flow.
Scenario: This has been observed if the user tries to connect using an endpoint that is unknown to
ClearPass.

#14190 Symptom: Blacklisted MAC Authentication Bypass (MAB) users cannot be blocked using the Blacklist
User Repository.
Workaround: In order for post auth to work in a MAB flow, a new blacklist repository must be added
with a custom filter.

#17232 Symptom/Scenario: The error and warning messages returned by the user interface are displayed in
English instead of the localized language.

#18064 Symptom: AirWatch custom HTTP actions needs content even though it’s not required.
Scenario: For AirWatch MDM, custom-defined HTTP actions such as Lock Device or Clear Passcode
fail with error messages. This is due to a bug in AirWatch.
Workaround: Do either of the following:
l Add a header Content-Length:0 in the Context Server Action.
l Add a dummy JSON data {“a”:”b”}.

#18701 Symptom/Scenario: Performing an AddNote operation using AirWatch as the MDM connector fails in
ClearPass. This is due to a bug in AirWatch.

#19176 ClearPass does not currently support posting of Palo Alto Networks (PANW) user ID information when
the PAN OS uses Vsys.

#19826 Palo Alto Networks (PANW) devices will only accept the backslash character ( \ ) as a separator
between the domain name and the username.

#20292 Symptom/Scenario: On the Monitoring > Live Monitoring > System Monitor page, the Last
updated at field displays time based on the time zone of the ClearPass node where the user is
viewing the page.

#20383 The system posture status may still be maintained after Post Auth agent disconnect action. This is
likely to happen when Posture result cache timeout service parameter is higher than the Lazy handler
polling frequency.

#20416 Symptom: The Palo Alto Networks (PANW) operating system firewall rejects user ID updates from
ClearPass when the user ID limit is reached on the firewall. When this happens, user ID updates are
rejected with errors.
Scenario: This occurs when the PANW firewall exceeds its supported limit advertised for user ID
registration.
Workaround: There is no workaround at this time.

#20453 In order for ClearPass to have complete data to post to Palo Alto Networks devices in HIP reports,
profiling must be turned on. This is the expected behavior.

#20455 Symptom/Scenario: When doing an SSO & ASO flow in Safari browsers, the certificate needs to be
added in the trust list of the browser.
Workaround: Please follow these steps:
1. Open the Safari browser and enter the SP URL.
2. After you enter the SSO application in the browser, the Show Certificate option is provided in a

popup window.
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3. Click Show Certificate and select the “Always trust ‘FQDN of SP machine’ when connecting
to IPaddress” check box, and then click the Continue button.

#20456 Symptom: SNMP bounce fails.
Scenario: When only the SNMP bounce in the SNMP Enforcement profile of a Web auth service is
configured, SNMP bounce functionality does not work.
Workaround: Also configure a VLAN ID along with the SNMP bounce in the SNMP enforcement profile.

#20484 Symptom: Dropping the Subscriber and then adding it back to the cluster may fail at times.
Scenario: ClearPass system time might not have been synchronized with an NTP source.
Workaround: Configure an NTP server. ClearPass will synchronize its time with the NTP source.
Attempt the cluster operation.

#20489 Symptom/Scenario: ClearPass 6.3 does not allow a server certificate with a Key Length of 512 bits as
seen in the Self-Signed Certificate and Certificate Signing Request UIs. Earlier ClearPass versions did
not have this restriction, hence their server certificate may use one with a 512 bit Public Key. After
upgrade, these servers will not work properly.
Workaround: The admin must manually fix the server certificate to allow a minimum of 1024 bits long
Public Key prior to upgrade.

#21334 Symptom: ClearPass does not launch.
Scenario: The ClearPass user interface will not launch from Firefox or from older versions of Internet
Explorer (IE) browsers if an EC-based HTTPS server certificate is used. On Firefox, the error message
“Secure Connection Failed. An error occurred during a connection to <server>. Certificate type not
approved for application” is displayed. On older versions of IE, the error message “Internet Explorer
cannot display the Web page” is displayed.
Workaround: Use the latest version of IE, or the Chrome browser instead.

#22023 Symptom/Scenario: Launching the customer's ClearPass user interface through a proxy does not
work on the Internet Explorer or Safari browsers.
Workaround: Use the Chrome or Firefox browser instead.

#23581 Symptom: A database connection error occurs in the Access Tracker UI when it is updated to 6.3.2
with MD2 server certificates.
Scenario: This is a database connection problem because of the MD2 certificate available for
PostgreSQL. MD2 is not supported.
Workaround: After updating to 6.3.2 (patch installation from 6.3.0), if Access Tracker or Analysis &
Trending show errors relating to database query errors, it can be due to an invalid Server Certificate.
1. Go to Server Certificate and select the certificate for the server and RADIUS service.
2. Click View Details for each certificate in the chain.
3. Look for the Signature Algorithm and check to see if it uses MD2.
4. Download the certificate that is MD5 or SHA-1-based algorithm to replace the MD2 algorithm from

the corresponding Certificate Authority site.
5. From the Support shell, restart the cpass-postgresql service.

#23848 Symptom: The ClearPass appliance’s time setting might sometimes be off by as much as eight hours.
Scenario: This is due to a known issue with VMware tools, which periodically checks and synchronizes
time between the host and the guest operating systems. This issue is documented by VMware at
http://pubs.vmware.com/vSphere-50/index.jsp?topic=%2Fcom.vmware.vmtools.install.doc%2FGUID-
C0D8326A-B6E7-4E61-8470-6C173FDDF656.html.
Workaround: There is no workaround at this time.

#24584 Symptom: The Event Viewer sometimes shows two SMS entries.
Scenario: This might occur when “Alert Notification - SMS Address” is saved, or if sending an SMS fails.

#24646 Symptom/Scenario: There are some issues on Internet Explorer 9 (IE 9), including:
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Bug ID Description

#24919
#26698
#27379
#27568

l The login banner is not centered and the footer is not placed at the bottom of the page.
l The IE browser fails to display an error message if connectivity is lost with the ClearPass Policy

Manager server.
l The scroll function does not work in the pop-up that opens from the Monitoring > Audit Viewer

page.
l ClearPass Policy Manager and Insight do not work properly on IE 9.
l The Save operation gets stuck when you try to save the server configuration changes using the IE

browser.
Workaround: Use IE 10 or IE 11 or the Firefox or Chrome browsers instead. Users should be aware
that ClearPass supports IE 10 and later on Windows 7 and Windows 8.x.

#24781 Palo Alto Networks (PANW) devices accept only the backslash ( \ ) character as a separator between
the domain name and the username. If the update uses an “at” sign ( @ ) between the domain name
and the username, the HIP report will not be shown in PANW.

#25720 Symptom/Scenario: The Dashboard shows the server as being down if an HTTPS server certificate is
signed by the Onboard CA using SHA-256.
Workaround: Be aware that SHA-1 RSA is not recommended for security reasons. You must update
your certificates to use stronger keys, such as RSA with > 1024 bits length.

#27306 Whenever IPsec configuration is changed on either end of the tunnel (Wireless Controller or
ClearPass), after the changes, the ClearPass IPsec service should be restarted in ClearPass from
Services Control to establish the IPsec tunnels reliably. After restart, verify the status of the IPsec
tunnel from the Network tab at Administration > Server Manager > Server Configuration.

#27592 Symptom: SAML SSO using TLS certificate does not work in Firefox or Safari browser.
Workaround: Use alternate browsers such as Google Chrome or IE.

#27621 Symptom: The number of authentications per second for non-MS-CHAPv2 methods is reduced when
the Local User or Admin User authentication sources are used.
Scenario: Local and admin user passwords are now stored as non-reversible PBKDF2-based hashes. A
side-effect of this change is reduced performance in password-based authentications (for example,
PAP, GTC, WebAuth, or TACACS+) against the Local User and Admin User authentication sources.
Refer to product documentation for the latest performance numbers.
Authentications against external authentication sources such as AD or external SQL are not affected
by this change.

#27895 Users should be aware that, because of schema changes now that ClearPass supports storing
irreversible passwords, any import of old authentication sources using XML files will break the
required SQL filters. Avoid any import of old authentication source configuration as this causes
authentication failures for guest users and admin users.

#28417 Symptom: After DNS settings are changed, services that are dependent on DNS are not restarted and
the ClearPass application hangs.
Scenario: When the DNS is updated, all services are restarted, so the session is lost.
Workaround: Refresh the ClearPass application and log in again.

#30486 Symptom: Custom filters in an Auth Source do not work after upgrading to ClearPass 6.6.
Scenario: As part of enhancements to tag mappings, the schema for storing the tag values has
changed, and all default filters were migrated to the new schema. It is not possible, however, to
automate the migration of custom filters.
Workaround: If you have custom filters, contact Support to have the custom filters migrated to the
new schema.

#30569 Symptom/Scenario: The Guest Portal name in the ClearPass portal is unchanged after updating the
name in the ClearPass Guest application.
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Workaround: When you change Guest Portal names in the ClearPass Guest application, the admin
must manually update the ClearPass Portal settings if the guest portal is used in that configuration.

#30968 Users should be aware that VMware ESX hosts are not profiled by SNMP CDP based profiling. The
Profiler needs a host MAC or IP address in order to identify the device. ESX servers might not report
the management IP address and MAC address in the CDP announcements, causing the Profiler to
ignore neighbor CDP information for the host.

#31208 Symptom: Multiple entries for the same device can be seen in the endpoints page.
Scenario: Users should be aware that, during the network discovery scan, if devices have multiple
endpoints those endpoints will be listed separately in the endpoints page.

#31769 Symptom/Scenario: Endpoints with multiple IP addresses for the same MAC address might not be
profiled appropriately.

#31810
#30785

Users should be aware that, when upgrading to ClearPass 6.6, any custom authentication source
filters must be migrated manually. During an upgrade, the console now displays a warning message
when custom filters are defined using tag values for Local and SQL authentication sources.

#31916 Symptom: Network discovery adds multiple ports to the display after discovering the same device.
Scenario: During network discovery, if the same device is connected to two different ports of a switch,
the one discovered later will be displayed in the neighbors.

#31942 Symptom: Restore operations fail and the error message “Network Device <#>: No dictionary found
for vendor ‘HP’” is displayed at Configuration > Network > Devices > Import.
Scenario: This occurs when a network device is imported with the vendorName as “HP”.
Workaround: Network devices that had the vendorName "HP" must now use the vendorName
"Hewlett-Packard-Enterprise".

#32145 Symptom: Devices are discovered with incorrect MAC addresses.
Scenario: Network discovery reads the ARP cache (ipNetToMediaTable) to process all the MAC-IP
cache pairs and add them to the endpoints. The Aruba switch returns the same MAC address for all
the IPs, resulting in only one endpoint.

#32980 Users should be aware that, on devices using PAP, notifications sent by ClearPass about a required
password change or advising of an upcoming password expiration might not work. Although TACACS
authen_type=ASCII implementations handle these correctly, devices that use authen_
type=PAPmight only accept a status of SUCCESS/FAILURE and not accept any other status.

#33103 Symptom: After restoring a backup, the SSO page IDP URL still shows the old hostname of the
restored backup instead of the hostname/FQDN if the current ClearPass appliance.
Scenario: This error is only seen when a backup is attempted from one appliance to another
appliance. This is very rare in real time.
Workaround: Manually change the hostname in the IDP URL to the current ClearPass appliance's
hostname\FQDN.

#33371 Symptom/Scenario: Network Discovery through SNMP v1 does not work for Aruba switches.
Workaround: Use SNMPv2 or v3 for discovering Aruba switches.

#33425 If you have a custom authentication source configured to use the session log database, additional
steps are required after upgrade. You have such an authentication source configured if you have a
source of type Generic SQL DB in ClearPass Policy Manager > Configuration > Sources with
server name localhost or 127.0.0.1 and with the database name tipsLogDb. In such cases, manually
restoring the session log database is required after the upgrade completes (see "After You Upgrade "
on page 25). Please contact Customer Support for configuration recommendations to move away from
using the session log database as an authentication source.
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#33535 Symptom: Importing patches might fail with the error "Content-type ‘application/x-macbase64’ is not
supported".
Scenario: This occurs on some versions of the Firefox browser.
Workaround: Use the Chrome or Internet Explorer browser instead.

#33795 Symptom/Scenario: Importing a pre-existing authentication source with custom filter queries is not
reflected or updated if the existing authentication source in 6.6.0 already includes some filters with
same name.

#33811 Symptom: During an upgrade through the user interface, the Reboot button might not trigger a
machine restart after the image is installed.
Scenario: This occurs when the upgrade image is downloaded from the Web server or installed
through the user interface. If the default or configured idle session timeout of the server is exceeded,
the system should display the error message “Session is timed out. Please log in again” when the
Install or the Reboot button is clicked, but it does not. Instead, the installation completes and the
“Reboot initiated” message is displayed, but the reboot is not actually triggered.
Workaround: Refresh the page to log in again, and then click Reboot.

#34086 Symptom: If a system is upgraded from ClearPass 6.5.5 or below with a configuration that is affected
by issue #33036, the configuration will not be auto-corrected during the upgrade.
Scenario: This can occur if an authentication source with type RADIUS server is used in a service
created through a service template in 6.5.5 or below.

#34491 Symptom: A ClearPass Admin UI login will fail against the local user repository if the “force change
password ” option is enabled.
Scenario: Users should be aware that the Local User setting to force a password change at the user’s
next login applies only to network device administration logins using TACACS+.

#34951 Symptom/Scenario: The new cluster-wide parameter Disable Change Password for TACACS has
no effect on TACACS authentications using PAP. Users should be aware that password change is not
supported with the TACACS authentication method.

#35030 Symptom/Scenario: If blacklisted users are deleted as a result of daily cleanup, or as a result of
manual cleanup through the UI, then when those users come back after the defined blacklist period is
over they might be disconnected immediately instead of being allowed a fresh bandwidth or session
limit.
Workaround: The user will have to wait for another cycle of the blacklist period to pass before the
allowed bandwidth limit or session limit will be applied.

#35158 Symptom: Deleting a Certificate Revocation List (CRL) has no effect on the IPsec connection.
Scenario: Users should be aware that if a CRL in Administration > Certificates > Revocation Lists
is deleted, the administrator must restart the ClearPass IPsec service on the Administration >
Server Manager > Server Configuration > Services Control tab.

#35946 Symptom/Scenario: Trying to import an agent enforcement profile or Web authentication service
from 6.5.7 or 6.6.1 to 6.6.2 fails and the error message “File contains invalid XML tags. Try export to
see the valid XML tags” is displayed.
Workaround: There are two possible workarounds:
l An Admin user can re-configure the Web authentication service or or agent enforcement profile.
l Alternatively, before importing, make the following changes in the enforcement profile XML file:

n Replace <GenericEnfProfiles> </GenericEnfProfiles> with
<AgentEnfProfiles> </AgentEnfProfiles>.

n Replace <GenericEnfProfile> </GenericEnfProfile> with
<AgentEnfProfile> </AgentEnfProfile>.

n The type="Agent" attribute must be mapped to agentEnfType="Agent".
n The action="<VALUE>" attribute should be removed from the XML. The action attribute
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is not applicable in 6.6.2. (for example, action="Accept")

#35965 Symptom: SNMPv3 Traps are not sent with the correct user credentials unless the async-netd service
is restarted.
Scenario: In ClearPass, this occurs if the EngineID or the v3 trap receiver configuration is changed and
the cpass-async-netd service is not restarted.
Workaround: After modifications are made in either of the following ways, restart the async-netd
service once in order to reflect the changes:
l When the Engine ID field is modified on the Administration > Server Manager > Server

Configuration > System Monitoring tab.
l When changes are made to any of the fields associated with an existing SNMPv3 user at

Administration > External Servers > SNMP Trap Receivers. These SNMPv3 Trap Receiver fields
include the authentication protocol using MD5 or or SHA, and the Type, Authentication Key,
Privacy Key, and Privacy Protocol fields.

#36032 Symptom: License activation over the proxy server fails.
Workaround: Do one of the following:
l Use offline license activation instead. On the Administration > Server Manager > Licensing >

Servers tab, click the Activate link in the server’s row to open the Activate License form. Follow
the instructions in the Offline Activation area to download a request token and contact Support.

l If you can reach the activation server, remove the proxy. On the Administration > Server
Manager > Server Configuration > Service Parameters tab, select ClearPass system services.
In the HTTP Proxy area, clear all values.

#36902 Symptom: A ClearPass virtual appliance cannot be installed with a default disk type of “virt-manager”.
Scenario: When installing a ClearPass virtual appliance on a KVM hypervisor through the virt-manager
user interface, the provided image file cannot be read and the installation fails if the bus type is left as
the default option.
Workaround: If you are using the virt-manager user interface to install the virtual machine on a KVM
hypervisor, follow the steps below. For installation details, please refer to the Installing or Upgrading to
ClearPass 6.6 on a Virtual Appliance Tech Note.
1. In the virt-manager user interface, import the raw image and add the hard disk as usual.
2. In the “Power On and Configure the KVM Appliance” part of the installation process, click Disk 1 in

the left menu. The Virtual Disk window opens.
3. Click Advanced Options.
4. Change the Disk bus setting to SCSI, and then click Apply to save.
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#34952 Symptom/Scenario: At Configuration > Network > Devices, port configuration for OnConnect
Enforcement might be confusing if the device is configured as a subnet.
Workaround: If a network device is configured as a subnet and OnConnect is enabled, we recommend
that OnConnect Enforcement be enabled on all ports (uplink and trunk ports will be skipped).
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QuickConnect

Bug ID Description

#20867 Symptom/Scenario: Android 4.3 and above fails to install a self-signed certificate for the CA
certificate.
Workaround: For onboarding Android version 4.3 and above, ClearPass must have a RADIUS server
certificate issued by a proper Certificate Authority and not a self-signed certificate. This is a
requirement of Android’s API for Wi-Fi management. In Onboard > Configuration > Network
Settings, the CA certificate that issued the server's certificate has to be selected as the trusted root
certificate to be installed on Android.

#25521 Symptom/Scenario: Embedding admin credentials is not supported on Windows 8+.
Workaround: Provide the admin credentials manually during Onboard provisioning.

Table 51: Known Issues in QuickConnect
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